1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

HELP - Disco USB cheio 100%

Discussão em 'Novidades GNU/Linux & *nix World' iniciada por zzz, 10 de Agosto de 2007. (Respostas: 6; Visualizações: 896)

  1. zzz

    zzz Power Member

    Tenho um router asus (wl500gp - firmware do oleg) aonde está a correr um sistema unix, não me perguntem qual que não sei...

    Esse router tem ligação usb que está ligado a um MyBook 250GB.
    Que por sua vez está ligado por Samba para os PCs com windows (disco de rede)

    Agora o problema é que tanto no windows como no router diz que não tem espaço...
    Código:
    > df
    Filesystem           1k-blocks      Used Available Use% Mounted on
    /dev/root                 2880      2880         0 100% /
    /dev/discs/disc0/part1 240292420 240292420         0 100% /opt
    
    o estranho é que já apaguei alguns gigas... e fica assim

    Código:
     df
    Filesystem           1k-blocks      Used Available Use% Mounted on
    /dev/root                 2880      2880         0 100% /
    /dev/discs/disc0/part1 240292420 234965844         0 100% /opt
    
    já experimentei fazer unmount e correr fsck

    Código:
    umount -l /opt
    Código:
     > fsck.ext3 /dev/discs/disc0/part1 
    e2fsck 1.38 (30-Jun-2005)
    MyBook: recovering journal
    MyBook: clean, 7883/30523392 files, 59699307/61030927 blocks
    
    mas continua na mesma


    Comecei um topico semelhante neste forum:
    http://wl500g.info/showthread.php?t=10254
     
  2. Rui_Carlos

    Rui_Carlos 1st Folding then Sex

    apesar de dizer 100%, já tens algum espaço livre.
    experimenta desmontar o disco e montá-lo num pc normal e vê qual o espaço ocupado.
     
  3. zzz

    zzz Power Member

    Apesar de ter esse espaço, no windows diz que o espaço livre é 0 bytes :(
    logo nem consigo criar um ficheiro de 70KB... diz que precisa de 4MB livres :P

    [​IMG]
     
  4. Rui_Carlos

    Rui_Carlos 1st Folding then Sex

    se calhar houve algum problema ao apagar os ficheiros. tenta eliminá-los agora no windows.
     
  5. esquiso

    esquiso Power Member

    Ora vê lá se nas pastas ocultas não tens uma chamada .trash. Isso aconteceu-me no meu DAP.
     
    Última edição: 10 de Agosto de 2007
  6. zzz

    zzz Power Member

    não tenho nenhuma pasta trash
    Já corri um programa que mostra o espaço ocupado por pastas (tree disk ...) e não encontrei nada fora do normal.
    Se bem que ontem existia uma pasta no /share/terminf que ocupava 12 GB :lol: levou logo com um
    Código:
    rm * -rf 
    o estranho é que tenho espaço livre, mas no windows só parece reconhecer o espaço ocupado e não o espaço total :wow:

    E no comando df devia dar pelo menos 3% livre ...

    Já me tou a passar com isto
    Daqui a pouco apago todos os ficheiros menos o /home do disco (aonde tenho os meus ficheiros pessoais) depois reconfiguro de novo o modem ...>(
     
  7. zzz

    zzz Power Member

    ora bem, voltei de ferias e continua na mesma ... :P

    Agora é que fiz da bonita, apaguei todas as pastas excepto a /home e agora nem monta

    "Invalid argument" :mad:

    Depois tentei correr este para recuperar, aparece aquelas janelas do realocate... (meto o -y para dizer sim a todas ) e parece que lixei o disco

    Também tentei com o -n
    Código:
    e2fsck -n /dev/discs/disc0/part1
    Código:
    e2fsck: e2fsck_read_bitmaps: illegal bitmap block(s) for MyBook
    Vou agora ver se consigo recuperar o disco com este programa: Stellar Phoenix Linux

    é que tenho 250GB de dados e era um bocado chato perde-los:005:
     
    Última edição: 30 de Agosto de 2007

Partilhar esta Página