1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Hyperthreading desapareceu!

Discussão em 'Dúvidas e Suporte Técnico PC' iniciada por FLCL, 3 de Abril de 2006. (Respostas: 10; Visualizações: 1250)

  1. FLCL

    FLCL Power Member

    Boas
    venho aqui colocar uma pergunta a ver se os "experts" me sabem responder :) :

    Tenho um P4 3.2 GHz socket 775 e uma board Asrock 775v88.
    ora recentemente, e penso que terá sido depois de instalar uma XFX 6800GS Xtreme edition @ Ultra.
    o que se passa é que depois de formatar o disco e lhe meter o windows xp (tanto o pro como o home) o hyperthreading desapareceu. no gestor de tarefas, no Historico de Utilização do cpu, só mostra 1 processador:

    [​IMG]


    No gestor de dispositivos nem lá está o item Processadores (penso eu que devia estar), mas aqui aparecem os 2 processadores:

    [​IMG]

    ou isto é apenas a designação e seguido da velocidade real?


    Na bios, tem la uma opção de hyperthreading que so dá AUTO e Disabled, jé experimentei com as 2 e nao ha meio de resolver isto.
    Por causa de duvidas, resolvi testar com o folding. se tivesse reconhecido como 2 processadores so ocuparia 50% do cpu, mas apenas com uma consola estava a ocupar 99%..

    Alguma ideia do que poderá ter originado isto?

    Nuno
     
  2. WindWalker

    WindWalker Power Member

    Auto na BIOS

    Quando instalas o Windows XP (não conheço outra maneira) tens que carregar várias vezes em F5 e escolher a opção "Multiprocessador ACPI"

    http://www.theeldergeek.com/clean_installation_of_windows_xp.htm

    "When XP is first installed it tries to determine what type of BIOS is available on the computer. Newer systems have what is known as Advanced Configuration and Power Interface (ACPI) capability. Unfortunately, XP doesn't always recognize a computer BIOS is ACPI capable and doesn't install the support for ACPI. Even more unfortunate is the fact that if ACPI support isn't determined at the initial install it's virtually impossible to correct this at a later time short of reinstalling XP over the top of the previous XP installation. To do so requires changing the Hardware Abstraction Layer (HAL). The chances of successfully changing a HAL after XP has been installed is pretty close to zilch.

    Once you drop the CD in the tray and fire up the computer to install XP, the first thing you'll see at the bottom of the screen is the option to press F6 if you need to install a SCSI or RAID controller. Don't press F6. Press F5 instead. This will take you to a separate menu of Hardware Abstraction Layer's where you can choose an appropriate HAL that supports ACPI. The choices will be:

    ACPI Multiprocessor PC

    ACPI Uniprocessor PC

    Advanced Configuration and Power Interface (ACPI) PC

    Compaq SystemPro Multiprocessor or 100% Compatible PC

    MPS Uniprocessor PC

    MPS Multiprocessor PC

    Standard PC

    Standard PC with C-Step i486

    Other

    [...]"

    Espero que percebas inglês :P

    EDIT:

    Porquê [email protected]???

    Se queres tirar proveito do Hyper-Threading, memórias em Dual Channel ajudam ;) (para o caso de teres 2x512MB)
     
    Última edição: 3 de Abril de 2006
  3. Juzhan

    Juzhan Power Member

    o meu Hipertreading no inicio dava para ligar e desligar... agora o pc só arranca com o hipertreading ligado...
     
  4. WindWalker

    WindWalker Power Member

    O PC ou o Windows??? É que não estou a ver o HyperThreading desligado a fazer com que o PC não arranque...


    No meu esteve sempre ligado :004:
     
  5. God_Lx

    God_Lx Folding Member

    Muitas bios dão para desligar o HyperThreading na bios... Vê se n desactivaste isso :P
     
  6. FLCL

    FLCL Power Member

    WindWalker, obrigado, vou tentar isso. :D

    Dps digo se resolveu o problema.

    Nuno
     
  7. WindWalker

    WindWalker Power Member

    Como disse, no meu esteve sempre activado...Mas no "primeiro Windows" que tive também só acusava 1 cpu :( mas fazendo como sugeri resolveu. Portanto a opção Auto ou Enabled na BIOS deve servir.
     
  8. CmdC

    CmdC What is folding?

    Tenta ver em propiedades do sistema -> wardware e onde diz computador,
    ve se tens lá: Acpi Multiprocessor Pc... Pode estar em Portugues, o meu Xp é em inglês.
     
  9. WindWalker

    WindWalker Power Member

    Pois realmente nem me lembrei disso xD

    Mas penso que a reinstalação com aquele pequeno "truque" deve resolver
     
  10. FLCL

    FLCL Power Member

    Já está resolvido :D

    Foi so carregar no F5 e escolhes ACPI MultiProcessor na instalação do XP.

    Mto obrigado a todos pessoal!

    Nuno
     
  11. WindWalker

    WindWalker Power Member

    :x2:
     

Partilhar esta Página