1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Imac 21,5 - Alterei as permisões do disco e agora nao arranca!!!!

Discussão em 'Dúvidas e Suporte Técnico - Apple' iniciada por filipetps, 5 de Junho de 2012. (Respostas: 5; Visualizações: 741)

  1. ola a todos, precisava de ajuda para resolver um problema que eu criei...ontem estava a alterar as permissoes de partilha de umas pastas quando me lembrei de alterar igualmente a do disco do Mac que tava no ambiente de trabalho e utilizei a ultima opção para "sem acesso para toda a gente" e a partir deste momento o incone do disco passou a ser uma pasta com o simbolo proibido, fiquei sem acesso a tudo, inclusivamente as aplicações e a possibilidade de alterar a meu erro, e ao reiniciar não passa do ecrã cinzento com a maçã...
    Estou a tentar repor tudo com o utilitario do disco, mas sem sucesso...as outras opções "terminal..., utilitario de palavras-passe de firmware, etc" nem tentei....

    A minha proxima tentativa, caso nao consiga uma solução, devera passar por esta opção "para continuar a instalação do Snow Leopard, clique em continuar"  instalar o sistema operativo novamente, a minha duvida é se vou ter acesso aos ficheiros ou devido a restrição da permissão vou ficar sem nada?

    Agradeço desde ja qualquer sugestão para tentar resolver o meu problema.
     
  2. johncool

    johncool Power Member

    Faz o seguinte: arranca pelo DVD de instalação do SL e abre o terminal. Depois insere os seguintes comandos:

    cd /Volumes (dá enter)
    chmod 755 Macintosh\ HD/ - ou o nome do teu disco - (dá enter)

    Fecha o terminal, sai do installer e define como startup disk o teu disco.
     
  3. quando coloco o segundo comando aparece a mensagem "no such file or directory"

    [​IMG]

    tentei varias formas para ver se tinha colocados os espaços certos....

    [​IMG]

    mesmo assim tentei o startup com o disco e continua na mesma.....

    de salientar que é a primeira vez que utilizo o terminal, o que não me admirava de estar a fazer algo errado ao colocar os comandos....
     
  4. johncool

    johncool Power Member

    Repara que na 2ª instrução eu pus lá "Macintosh\ HD/" ou o nome do teu disco. Como o nome do teu disco é "Mac hd", a instrução deve ficar:

    chmod 755 Mac\ hd/
     
  5. Resultou!!!!!

    muito obrigado pela ajuda johncool!!!!!
     

Partilhar esta Página