1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Imprimir com Samba no server

Discussão em 'Dúvidas e Suporte Técnico - GNU/Linux & *nix' iniciada por hellaxe, 16 de Novembro de 2007. (Respostas: 4; Visualizações: 537)

  1. hellaxe

    hellaxe Power Member

    Depois de procurar muito e ainda não ter tido respostas Pergunto aos meus comparsas:D.
    Acontece que não consigo imprimir através do samba para a impressora que está no servidor com o Clarkconnect 4 ou no outro que tem 3.2.
    A impressão através do IPP é impecável mas com o samba nem pensar. Na minha máquina fica a dizer "job: printing" mas não acontece nada na impressora.
    Com Xp imprime bem com o samba, claro.
    Já vi e revi os ficheiros que deveriam ser implicados no processo mas estou na mesma.
    Ajuda agradecida.
     
  2. slack_guy

    slack_guy Power Member

    E logs, há?
    Código:
    /var/log/cups/error_log
    /var/log/cups/access_log
    
     
  3. hellaxe

    hellaxe Power Member

    Claro que há:
    Error_los
    Código:
    I [16/Nov/2007:11:01:21 +0000] LoadPPDs: Read "/etc/cups/ppds.dat", 3238 PPDs...... 
    I [16/Nov/2007:11:01:24 +0000] LoadPPDs: No new or changed PPDs...... 
    I [16/Nov/2007:11:01:24 +0000] Full reload complete.... 
    I [16/Nov/2007:11:06:58 +0000] Adding start banner page "none" to job 3.... 
    I [16/Nov/2007:11:06:58 +0000] Adding end banner page "none" to job 3.... 
    I [16/Nov/2007:11:06:58 +0000] Job 3 queued on 'LJ4L' by 'nobody'.... 
    I [16/Nov/2007:11:06:58 +0000] Started backend /usr/lib/cups/backend/parallel (PID 2381) for job 3.... 
    I [16/Nov/2007:14:20:44 +0000] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=7152)...
    Access_log
    Código:
    192.168.5.5 - - [16/Nov/2007:14:20:44 +0000] "GET /printers/LJ4L?which_jobs=completed HTTP/1.1" 200 0... 
    localhost - - [16/Nov/2007:14:20:45 +0000] "POST / HTTP/1.1" 200 138... 
    localhost - - [16/Nov/2007:14:20:45 +0000] "POST / HTTP/1.1" 200 862... 
    localhost - - [16/Nov/2007:14:20:45 +0000] "POST / HTTP/1.1" 200 448... 
    192.168.5.5 - - [16/Nov/2007:14:20:44 +0000] "GET /printers/LJ4L?which_jobs=completed HTTP/1.1" 200 5176... 
    192.168.5.5 - - [16/Nov/2007:14:20:45 +0000] "GET /images/printer-idle.gif HTTP/1.1" 200 706... 
    192.168.5.5 - - [16/Nov/2007:14:20:45 +0000] "GET /images/print-test-page.gif HTTP/1.1" 200 288... 
    192.168.5.5 - - [16/Nov/2007:14:20:45 +0000] "GET /images/modify-printer.gif HTTP/1.1" 200 277... 
    192.168.5.5 - - [16/Nov/2007:14:20:45 +0000] "GET /images/stop-printer.gif HTTP/1.1" 200 252... 
    192.168.5.5 - - [16/Nov/2007:14:20:45 +0000] "GET /images/reject-jobs.gif HTTP/1.1" 200 252... 
    192.168.5.5 - - [16/Nov/2007:14:20:45 +0000] "GET /images/config-printer.gif HTTP/1.1" 200 296... 
    192.168.5.5 - - [16/Nov/2007:14:20:45 +0000] "GET /images/restart-job.gif HTTP/1.1" 200 249... 
    192.168.5.5 - - [16/Nov/2007:14:20:45 +0000] "GET /images/delete-printer.gif HTTP/1.1" 200 267... 
    192.168.5.5 - - [16/Nov/2007:14:20:45 +0000] "GET /images/set-as-default.gif HTTP/1.1" 200 278... 
    192.168.5.5 - - [16/Nov/2007:14:20:45 +0000] "GET /images/show-active.gif HTTP/1.1" 200 303... 
    192.168.5.5 - - [16/Nov/2007:14:20:45 +0000] "GET /favicon.ico HTTP/1.1" 404 0...
    Não vejo nada de estranho.

    Tenho a impressão que deve ser qualquer coisa relacionada com autenticações.....
    Mas não sei
     
  4. slack_guy

    slack_guy Power Member

    Quando mandas imprimir, vês o pedido no access_log? (tail -f /var/log/cups/access_log)
    Vê lá se isso não está a bater na firewall... alguma coisa que esteja aí pelo caminho... uma pedra... um pauzinho... um proxy...

    No /etc/cups/cupsd.conf tens alguma regra que impeça o acesso a essa máquina? para imprimires de Linux para Linux o Samba só atrapalha.
     
  5. hellaxe

    hellaxe Power Member

    Pois não parece que há nada na firewall.
    O cups parece não receber nada!!!!!!!!!!
     

Partilhar esta Página