1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Instação do webmin em ubuntu server 12.04LTS

Discussão em 'Dúvidas e Suporte Técnico - GNU/Linux & *nix' iniciada por rodri123, 26 de Maio de 2012. (Respostas: 5; Visualizações: 2368)

  1. boas pessoal ;)

    como diz o titulo, estou com uns pequenos problemas na instação o webmin:
    segui este pequeno tutorial "http://www.webmin.com/deb.html" para instalar o webmin, quando foi para instalar o wwbmin no ubuntu server apreceu varios erros que são estes...

    Faço o comando “sudo dpkg –i webmin_1.580_all.deb”, para instalar o webmin, começa a descompactar depois aparece o seguinte problema “dpkg: problemas com dependências impedem a configuração de webmin:
    o pacote apt-show-version não está instalado.
    Dpkg:erro ap precessar webmin(--intall):
    problemas com dependência – a deixar por configurar
    A processar’triggers’ para ureadahead ….
    Foram encrontrados erros enquanto processava:
    Webmin.”
    Faço para instalar o pacote apt-show-versions com o seguinte comando “sudo apt-get install apt-show-versions”
    Aparece “a ler a informação de estado … pronto
    Voçe deve querer executar’apt-get –f install’ para corrigir estes:
    Os pacotes a seguir têm dependências não satisfeitas:
    Apt-show-versions : depende: libapt-pkg.perl (>=0.1.24)mas não vai ser instalado
    E:dependências não satisfeitas. Tente ‘apt-get –f install’ sem nenhum pacote(ou especicifique uma solução)”
    Executei então o comando “apt-get –f install” a apareceu o seguinte “E:Não foi possível abrir ficheiro de lock /var/lib/dpkg/lock – open (13:permissão negada)
    E: não foi possível criar acesso exclusivo ao directorio de administração (/var/lib/dpkg/), é root?“
    Faço o comando “sudo dpkg –i webmin_1.580_all.deb”, para instalar o webmin, começa a descompactar depois aparece o seguinte problema “dpkg: problemas com dependências impedem a configuração de webmin:
    o pacote apt-show-version não está instalado.
    Dpkg:erro ap precessar webmin(--intall):
    problemas com dependência – a deixar por configurar
    A processar’triggers’ para ureadahead ….
    Foram encrontrados erros enquanto processava:
    Webmin.”
    Faço para instalar o pacote apt-show-versions com o seguinte comando “sudo apt-get install apt-show-versions”
    Aparece “a ler a informação de estado … pronto
    Voçe deve querer executar’apt-get –f install’ para corrigir estes:
    Os pacotes a seguir têm dependências não satisfeitas:
    Apt-show-versions : depende: libapt-pkg.perl (>=0.1.24)mas não vai ser instalado
    E:dependências não satisfeitas. Tente ‘apt-get –f install’ sem nenhum pacote(ou especicifique uma solução)”
    Executei então o comando “apt-get –f install” a apareceu o seguinte “E:Não foi possível abrir ficheiro de lock /var/lib/dpkg/lock – open (13:permissão negada)
    E: não foi possível criar acesso exclusivo ao directorio de administração (/var/lib/dpkg/), é root?“
    [email protected]:$

    qual foi o ponto em falhei ou que falta para instalar o webmim, já dei varias voltas para tentar decobrir estes erros na instação e nao descobri nada, parece que voltei a tasca zero:confused:

    cumps
    -> rodri123
     
  2. barricas

    barricas Power Member

    Chegaste a fazer sudo apt-get -f install ? Não vi aí
     
  3. wwwjunk

    wwwjunk Power Member

    Não podes correr o apt-get se tiveres mais alguma coisa a fazer updates (do género do prog para actualizar via ambiente gráfico) ou com outro apt-get a correr. Só dá um de cada vez.

    Tal como disse o barricas, tens que correr isso como root:
     
  4. Ketheriel

    Ketheriel Power Member

    Nao foste tu que falhas-te, nao tens é repositorios que te forneçam as dependencias necessárias, pelo que mostras:

    - apt-show-version
    - ibapt-pkg.perl

    Pelo que me parece, o apt-show-version está disponivem em repositorio, mas o libapt-pkg.perl não está; o que leva a que o apt nao consiga instalar o apt-show-version (que por sua é uma dependencia do webmin).
    Não sei se forçar a instalação vai resolver-te a questão, porque dependendo dos conteudos dessas dependencias o software pode nao funcionar.
     
  5. wwwjunk

    wwwjunk Power Member

    As mensagens de erro do apt-get quando há dependências que não existem não são essas.
    Já agora: LINK
    O pacote existe com a versão 0.1.25build2

    Sugestão:
    Fazer sudo apt-get update ANTES do sudo apt-get -f install

    EDIT:
    -f, --fix-broken
    Fix; attempt to correct a system with broken dependencies in place
     
    Última edição: 26 de Maio de 2012
  6. boas pessoal ;)

    já consegui instar o webmim, muito obrigado pela vossa disponibilidade

    fiz a sugestão do nosso colega wwwjunk e resultou...:cool:

    cumps
    -> rodri123
     

Partilhar esta Página