1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Instalação Stage3 do Gentoo

Discussão em 'Novidades GNU/Linux & *nix World' iniciada por avantix, 10 de Abril de 2005. (Respostas: 21; Visualizações: 1634)

  1. avantix

    avantix Power Member

    Boas,

    Resolvi arriscar e instalar o Gentoo num computador que cá tinha!

    Tenho ideia de ter seguido o handbook linha a linha, mas parece que devo ter feito alguma coisa mal.

    Reenoiciei agora a máquina, e dá-me o seguinte erro:

    Block Device /dev/hda3 is not a valid root device
    the root block device is unspecified or not detected.
    please especify a device to boot, or "shell" for a shell

    Ora bem ... alguem me consegue dizer o que fiz mal ... como proceder para corrigir ?

    Foi alguma coisa mal feita no fstab ?

    Help :D
     
  2. suB

    suB Banido

    hmm isso foi depois do grub? (o q eu quero dizer é.. n será erro do grub?)
     
  3. avantix

    avantix Power Member

    eu usei o LILO, não cheguei a configurar o GRUB
     
  4. suB

    suB Banido

    Ja agora, editaste mesmo o fstab ou só copiaste o exemplo? 8-) anyway, para reparar isso penso q baste bootares o cd de gentoo, fazeres o chroot e alterare so fstab good luck
     
  5. avantix

    avantix Power Member

    Eu segui os passos todos do handbook, e pelo que já andei a ver o meu fstab está bem ...

    deve ser alguma coisa qwue me falhou ,... vou reeniciar a instalação :(
     
  6. Morpheus

    Morpheus Banido

    da primeira vez que instalei o gentoo tb deu-me um erro mto esquesito ... mas como usei o GRUB para fazer o boot para o linux da segunda vez correu bem.
    Estás a usar que handbook o 2005.0?
     
  7. spastikman

    spastikman Banido

    Quantas partições tens de certeza absoluta ?

    Tens a certeza que a root é hda3 ?

    ve la as partiçoes que tens com fdisk -l
     
  8. Morpheus

    Morpheus Banido

    por isso é que eu perguntei kal era o handbook ke ele usou ... é k a root no handbook 2005.0 está lá explicito que é no hda1 (ou hdb1 depende da drive que usarem) logo seria (hd0,0) ou (hd1,0)
     
  9. avantix

    avantix Power Member

    Boas,

    Já está resolvido ... deveria ser um problema do handbook na parte de criação do LILO!

    Instalei o Grub, retirei uma opção, recompilei o Kernel para me certificar que tava com ext2 e ext3, e depois de um reboot ficou a funcionar!

    Mas ... Não fiquei por aqui :D Não é que o sacan em LiveCD corria a Network toda bem, sem qualquer problema (DHCP), e no reboot com a configuração final, não me identificava a eth0 ...

    Ora bem ... sendo um um GANDA pro, resolvi recompilar novamente o Kernel com suporte para os drivers 8139 ( 8139too que não estavam consigurados), e voilá! :D

    Agora já tá tudo ... pelo menos não tenho erros :P

    Vou ver a Thread do Morpheus .. pois já vi que tou na mesma situação que ele ... e Agora :D ?
     
  10. suB

    suB Banido

    mas, porque não sacar as cenas todaS/quase todas? vale a pena, ficam já com isso up2date ^^
     
  11. avantix

    avantix Power Member

    Tou a começar a ficar desiludido ....

    Apesar daqueles primeiros problemas inicias, batalhei e consegui meter o gentoo a funcionar!

    Agora estou numa fase mais complicada que é meter o gnome ou o KDE
    O problema é que qaulquer um deles me dá erro no emerge!

    Inicialmente deu-me um erro num pacote libxsl se não me engano, mas consegui safar-me bno forum da gentoo (problema de dependencias).

    Agora tou encravado no emerge da gtk+2.6.4 que tb dá erro, e pela net fora ainda não encontrei solução!

    Já tentei com outras versões gtk+2.6.6 (ainda não disponivel no gentoo) e a 2.6.1 ... em todas elas o erro mantem-se e o KDE e o Gnome não instalam!

    O problema é que deixei o PC a fazer emerge -u world durante a noite, e hoje de manhã antes de vir para o trabalho, tinha outro erro de compilação em outro pacote!

    Isto começa a ficar complicado ... mas não vou desistir!
     
  12. fap

    fap Power Member

    isso é bué estranho...muito raramente tenho problemas em emerges...

    quanto à cena dos discos, ainda bem que já resolveste, ia dizer que o prob. podia ser que no kernel 2.6 os discos sata são sda em vez de hda e se tivesses um sata ele podia atrofiar por isso
     
  13. avantix

    avantix Power Member

    Pois nos discos eu tb achei estranho .. pois apenas tenho 1 disco, ide normalissimo, e criei as partições exactamente como estão no handbook, ou seja ... não teria razão para dar a dar buraco ...

    Mas depois andei a pesquisar e das dezenas de soluções possiveis, resolvi aplicar todas :D e usar o GRUB e a coisa foi ao sitio ...

    O outro problema, da rede, deu-me gozo resolver!

    O KDE / Gnome é que me t´a chatear a mona ... porque nem no forum da gentoo encontro solução para o problema ... nem em outro forum qualquer .... e como ALTO CROMO que sou :P não sei o que fazer ....

    Bem .. veremos ...
     
  14. Xpirit

    Xpirit Banido

    se meteres aqui o output talvez se possa arranjar uma solução.

    Se fizeste um emerge -u world talvez fosse bom verificar tudo com um emerge -avutD world não vá haver por aí algumas dependencias não instaladas.
     
    Última edição: 13 de Abril de 2005
  15. avantix

    avantix Power Member

    Assim que chegar a casa, vou testar 2 possiveis soluções para o problema, e depois venho cá!

    Vou tb testar esse emerge -avutD world para ver se tá tudo ok.

    Caso continue com problemas eu meto o emerge --info aqui, e o erro reportado ...

    Thks!
     
  16. avantix

    avantix Power Member

    Ora Bem:

    emerge -avutD world
    Deu erro logo no primeiro pacote "texinfo-4.8" !

    Resolvi este problema, mudande em Make.Conf de sistema athlon-xp para athlon-tbird (não digam nada :D)

    Estou neste momento a compilar mais um "emerge -avutD world" e até agora tudo OK .. mas isto vai durar a noite toda ...

    Antes de realizar o emerge world, tentei ainda voltar a instalar o KDE, e o erro persistia, para já consegui resolver o problema reinstalando o gcc.

    Vamos ver como isto vai correr!
     
  17. Xpirit

    Xpirit Banido


    começa primeiro pela base. Faz um emerge -auvtD system e ficas com tudo actualizado. Cuidado com o que metes no make.conf. Convém que seja compatível com o CPU que tens e não metas flags de compilação para optimizações que podem tornar instável o software.

    No fim terás que fazer um etc-update mas cuidado vê se não vais sobrepor aficheiros de configuração que tenham sido alterados por ti. Se assim for lá se vai a configuração à vida.
     
  18. avantix

    avantix Power Member

    emerge -auvtD world correu bem ... vi hoje de amanhã!

    Deixei agora a fazer um emerge kdebase kdeadmin (para ver se já vem), e depois se tudo correr bem, logo faço emerge ao resto das coisas do KDE!

    Deixei noutro terminal a fazer um emerge -kf gnome (para ele aproveitar as happyhours e velocidades boas) e sacar apenas todos os pacotes de gnome, para posterior instalação!

    Logo á noite meto mais noticias :D

    Obrigado por estarem a ajudar e acompanhar esta dificil tarefa :D !
     
  19. PrOdG

    PrOdG Power Member

    NÃO usem o etc-update. E quando digo não refiro-me a nunca mesmo. Já vi montes de pessoal (eu incluído) a dar quase cabo do sistema à pala do etc-update. Usem o dispatch-conf, está no portage incluído num pack qualquer (já posto qual é, não sei de cor :P).

    Procurem por etc-update nos fórums do gentoo e vejam o que vos aparece em maioria ;)
     
  20. Xpirit

    Xpirit Banido

    qual é o problema do etc-update? Sempre o usei e nunca tive problemas. Bem sei que é só para duros mas há sempre um dia para começar a fazer as coisas a sério.

    Eu diria é para NUNCA usarem o dispach. Coisas que tentam fazer o update aos fich. de configuração dão sempre asneira. A melhor forma de o fazer é saber o que cada config é e nos importantes fazer o merge interactivo.

    Há um etc-update gráfico, parece-me. Eu como sou rápido com as teclas prefiro o modo texto.
     
    Última edição: 14 de Abril de 2005

Partilhar esta Página