1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Instalação windows 7 -> CD driver is missing

Discussão em 'Windows 7 e anteriores' iniciada por fredc, 26 de Dezembro de 2012. (Respostas: 20; Visualizações: 5305)

  1. fredc

    fredc Power Member

    Boas a todos!

    Estou aqui com um problema e já corri sites e sites à procura de solução, sem sucesso...

    Tenho aqui um computador que é usado só para net e office. No entanto ele começou a dar uns problemas, e tenho algumas suspeitas que o disco está danificado. O PC arrasta-se constantemente e por vezes ao ligar o windows não inicia, indo directamente para o assistente de arranque do winwods (que fica um tempão a correr e usualmente faz um scandisc, reinicia e volta a funcionar).

    Resolvi então formatar o PC para ver se consigo perceber se o problema está no software ou hardware (para correr uns testes com o PC limpo). No entanto, surge-me um outro: na instalação (através de DVD), depois do ecrã inicial do win7 (onde carrego em instalar) surge-me a mensagem para indicar onde estão localizados os drivers da drive de CD's... Então ele pede-me as drives do CD quando está a ler o DVD do win7 de lá?!

    Estou perdido, já experimentei re-instalar a BIOS (que já tem a última versão) e quando o PC reinicia dá-me um erro de overclock, voltando à versão anterior pensp (nunca fiz overclock no pc!). Li num fórum para apagar umas coisas no registo relativamente à drive de CD's mas também não resultou... Estou perdido mesmo!!

    Já agora, o DVD foi utilizado já diversas vezes neste mesmo PC e noutros, por isso sei que funciona. O disco está ligado por SATA à board (p5B Deluxe) e a drive de cd's por um cabo HDD (a drive não tem entrada SATA). É um dual core o pc, já tem uns 7 aninhos...


    Obrigado desde já pelas ajudas!!
     
  2. Blue Zee

    Blue Zee Power Member

    Na Bios activa os controladores IDE.
     
  3. fredc

    fredc Power Member

    Como faço isso?
     
  4. Blue Zee

    Blue Zee Power Member

    Qualquer coisa deste género:

    [​IMG]

    Seleccionas IDE (não é RAID como está na imgamem), gravas a alteração, sais da Bios e tentas a instalação do Windows.
     
  5. fredc

    fredc Power Member

    Isso é como estava inicialmente (na verdade a mim aparece depois de entrar no "IDE Configuration" a linha "Sata controller mode" ou algo assim, onde tenho as opções "disable, activate ou enhanced". Com a opção "enhanced" aparece uma nova linha em baixo onde posso seleccionar "AHCI, IDE ou RAID") , depois num website vi que sugeriam alterar para AHCI a ver se resolvia o problema... Não resolveu. Voltei agora a colocar em IDE e ocorre o mesmo problema de pedir as drives da drive de cds.

    Tentei usar o meu CD da motherboard (e outros cá em casa) mas não tenho nenhum com drivers de Cd... Mas nem era suposto na instalação pedir certo? Já instalei várias vezes e nunca pediu! Que se passará?!
     
    Última edição pelo moderador: 2 de Janeiro de 2013
  6. Blue Zee

    Blue Zee Power Member

    Já tentaste instalar com uma pen USB?
    Há vários tópicos sobre o tema aqui no fórum e que poderás tentar.
     
  7. fredc

    fredc Power Member

    Ok, vou procurar esses tópicos para ver como fazer isso. Depois eu digo como correu!
     
  8. fredc

    fredc Power Member

    ok, criei uma us com o boot do win7 e este problema desapareceu... mas apareceu um novo :/

    Durante a instalação do win7 e faz os vários passos e vão aparecendo os vistos ao lado: "Copying files","expanding files"(? ou algo semelhante), "instaling functionalities" e depois no item "installing updates" ele dá um erro... Esse erro é "Windows could not set the offline locale information. Error code: 0x80ff0000". Depois disto ele cancela a instalação e volta ao menu inicial...

    Que posso eu fazer?
     
  9. Blue Zee

    Blue Zee Power Member

    Apaga a partição e recria uma nova como primária (e não lógica).
    Não sendo esta a solução, a alternativa é o disco avariado.
     
  10. fredc

    fredc Power Member

    Quando apareceu a opção de escolher onde instalar o windows eu formatei a drive (só tinha duas partições, uma de 100mb system reserved e a outra de 240GB onde tinha o windows instalado). Formatei ambas e seleccionei a de 240GB (que era a primária) para prosseguir com a instalação.

    Não há volta a dar? É disco avariado?
     
    Última edição pelo moderador: 2 de Janeiro de 2013
  11. Blue Zee

    Blue Zee Power Member

    Tenta nova formatação e marcar a partição como primária para ter a certeza.
    Se não resolver podes ainda tentar uma verificação do disco.
     
  12. rexet

    rexet Power Member

    elimina todas as partições que te são mostradas, depois sem criar nenhuma partição, ou seja logo após teres eliminado todas, clicas em instalar, que ele cria e formata tudo como deve ser. Tenta também o método pela PEN.

    Cumprimentos
     
  13. fredc

    fredc Power Member

    A formatação que falas pode ser no menu de instalação do windows? É que o PC como o formatei durante a instalação do windows não consegue arrancar para nenhum SO nem DOS...

    E verificação do disco como se como disse ele foi formatado?

    Eu eliminei tudo, mas ele deixa sempre 100MB de vago que não me deixa juntar aos 240GB. Depois instalei e deu o erro que descrevi em cima. Toda esta instalação foi através de USB.
     
  14. Blue Zee

    Blue Zee Power Member

    Arrancando pelo disco do Windows ou pela pen, escolhes Reparar o computador:

    [​IMG]

    No menu seguinte escolhes linha de comando:

    [​IMG]

    E na linha de comando escreves

    chkdsk /r C: (faz Enter)

    Em que C: é a letra atribuída ao disco.

    Em princípio irá fazer a verificação e reparação do disco.
    Vê se resulta.
     
  15. fredc

    fredc Power Member

    Obrigado pela ajuda!

    Fiz o scan disk como indicado e tentei novamente a instalação. Ausentei-me do PC durante a mesma, e quando voltei tinha um erro da falta/erro de um ficheiro de instalação (ou algo semelhante). Voltei a prepara a minha pendrive com o windows 7 para voltar a fazer instalação via USB e obtive o mesmo erro que tive inicialmente "Windows could not set the offline locale information." A diferença é que o código do erro é outro, "Error code: 0x80fe0000".

    Provavelmente não tem nada a ver, mas para eu correr o win7 da usb tive de ir à BIOS mexer nas prioridade do arranque/BOOT. Lá não aparecia a opção da USB (apenas pelo disco ou leitor de dvd), pelo que tive de ir a outra opção para definir as "hard-drives" e lá sim, podia escolher entre o disco ou a USB. Assim ao seleccionar a opção USB dentro da opção da "Hard-drive" na lista de arranque/BOOT aparecia a opção USB (mas não aparecia a do disco). Não pode ser nenhum conflito com isto correcto?

    Também verifiquei que na BIOS a data e hora estavam correctas.
     
  16. Blue Zee

    Blue Zee Power Member

    O disco deve estar avariado.
     
  17. fredc

    fredc Power Member

    E porquê a mudança no erro?

    Há alguma forma de ter a certeza que o problema é no disco? Não queria estar a comprar um novo para descobrir que o problema era afinal noutra componente...
     
    Última edição pelo moderador: 2 de Janeiro de 2013
  18. Blue Zee

    Blue Zee Power Member

    Podes arranjar outra versão do Windows e testar a instalação.
     
  19. rexet

    rexet Power Member

    Só para testar, instala uma distro de linux...
     
  20. fredc

    fredc Power Member

    Instalei o fedora e ao reiniciar da instalação apareceu o erro

    "Cannot open font file true"

    Estará relacionado com o disco? Já vi na net soluções mas involve alterar configurações no Fedora e eu não percebi como...
     
    Última edição pelo moderador: 2 de Janeiro de 2013

Partilhar esta Página