1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

intervlan routing e MEO em Cisco 877

Discussão em 'Dúvidas e Suporte—Internet, Redes, Segurança' iniciada por marco75, 13 de Maio de 2009. (Respostas: 21; Visualizações: 4986)

  1. marco75

    marco75 Power Member

    Boas. gostava que me dessem algumas dicas e se possível me dessem a solução para o meu problema, o que penso irá ser dificil, mas aqui vai:
    o 877 tem 3 portas em mode access Vl11, a int vl 11 tem ip de 172.21.0.193 255.255.255.240; a ultima porta está em modo access vl 22, a int vl 22 tem ip de 172.21.0.209 255.255.255.248. o que acontece é que as máquinas ligadas nesses portos que estão em diferentes vlans não se pingam entre si. o que gostaria de fazer era um simples roteamento entre vlans. Config feitas:

    interface FastEthernet0
    description Liga ao Servidor
    switchport access vlan 11
    interface FastEthernet1
    description Liga ao Desktop
    switchport access vlan 11
    interface FastEthernet2
    description Liga ao surecom
    switchport access vlan 11
    interface FastEthernet3
    description Liga ao SPEEDTOUCH
    switchport access vlan 22
    interface Vlan11
    description rede172.21.0.192/28
    ip address 172.21.0.193 255.255.255.240
    ip helper-address 172.21.0.194
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip nat inside
    ip virtual-reassembly
    ip tcp adjust-mss 1412
    interface Vlan22
    description Subrede WIFI
    ip address 172.21.0.209 255.255.255.248
    ip helper-address 172.21.0.194
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip nat inside
    ip virtual-reassembly
    ip tcp adjust-mss 1412
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 Dialer0
    ip route 172.21.0.192 255.255.255.240 Vlan11
    ip route 172.21.0.208 255.255.255.248 Vlan22
    ip routing
    Como configurar o IPTV da MEO no meu cisco 877? Já vi na net alguns exemplos estrangeiros, mas se alguém dos nossos já tiver experimentado e tenha tido sucesso era muito melhor.
    Muito obrigado por toda e qualquer ajuda, fico a aguardar... e um fiquem muito bem!!
     
  2. marco75

    marco75 Power Member

    Ok, o problema do roteamento intervlan está resolvido. Agora só falta por IPTV a bombar no cisco. Alguém dá uma ajudinha?
     
  3. marco75

    marco75 Power Member

    Se calhar não tou a postar no local certo?!?! Ninguém tentou por MEO a trabalhar num router da Cisco? ou ninguém tem uma dica? então pessoal?? uma ajudinha?
     
  4. Kain

    Kain Power Member

    Boas,

    Que eu saiba até agora ainda não vi ninguém a por MEO num Cisco mas deve ser possível. O problema é saber qual a config para a parte de IPTV a nível de vlans e de QOS.

    Tens acesso ao router da MEO certo?
     
  5. marco75

    marco75 Power Member

    Antes de mais muito obrigado por responderes KAIN. Sim tenho acesso ao tg787 da meo. O prblema é que o user e password que para aí corre (Administrator 3!play) é limitativo em termos de acesso a certos comandos do CLI da thompson (ex Comando ATM e IGMP).
    Pelo que tenho investigado e estudado antes de mais e antes de chegar à gestão do tipo de trafego pelo Qos, tenho que conseguir ligação com o ponto de acesso core do DSLAM, mas na parte do IPTV. sei que tens que criar uma sub interface ATM (ex ATM0.2, já que a ATM0.1 é ara acesso ADSL); os valores do vpi/vci do circuito virtual para esta subinterface é de 1/35 (enquanto para o adsl é 0/35). depois existem dois pontos muito importantes que está relacionado com o protocolo IGMP v3 que é o que te permite aceder a grupos de multicast e em que cada grupo representa um canal do IPTV, para além disso existe u comando muito mto importante que é o ip proxy-igmp, no qual o proxy não é mais do que o DSLAM. Para além disso penso que existe um protocolo PIM que penso ter muito importância. RTP (real time protocol), RTSMP (real time straming media protocol) são outros procolos usados por alguns operadores de IPTV, não sei o que a meo usará. o igmp tenho a certeza.
    omeu problema é que nem consigo fazer ligação etre a stb e o dslam, apesar da stb ficar com ip e eu ter acesso á internet pela minha subinteface adsl.
    se quiserem posso postar aqui a minha configuração feita até agora no cisco 877 para o iptv?!
    mas tb seria imprtante ter mais pessoas com interesse e a debater este assunto.
    MUito obrigado KAIN. brço
     
  6. marco75

    marco75 Power Member

    com o "mesmo" refereste a ?? li o thread do link e está um pouco longe do que falo aqui, mas o que conta é a intenção. a 1ª etapa para configurar o meu cisco 877 para iptv meo é conseguir fazer com que as stb's apresentem o status connected e isso eu não consigo fazer para começar.
    no thread do link acima fala-se em rotas. bem, isto sim já pode ser uma ajuda, se bem que no adsl apenas é necessário uma rota por defeito para o Dialer (ip route 0.0.0.0 0.0.0.0 Dialer0), mas isso é no adsl, realmente o iptv pode ser diferente.
    não acredito é na falta de material disponivel aqui no site e na net acerca de config iptv em máquinas cisco, ninguém tem tentado isso???.
    olhem... venham mais opiniões.
     
    Última edição: 28 de Maio de 2009
  7. Boa noite Marco, também tenho um 877w que tem vpns firewall dhcp ssid etc.... está ligado em bridge na fastethernet3 com o thomson da meo, está a workar, o meu unico problema é que não consigo fazer o roteamento entre vlans. podes postar como resolveste?

    obrigado
     
  8. Shakawkaw

    Shakawkaw Suspenso

    Eu também tenho um 877 parado à espera que eu tenha tempo para substituir o TG787. A única diferença é que tenho Meo Fibra.
    Este fim-de-semana vou testar configurações e ver se consigo pô-lo a funcionar.
    Já experimentaste ver se o router recebe alguns pacotes de BGP do lado do ISP?
     
  9. mpb88

    mpb88 Power Member

    Vê este tópico, o user que o criou conseguiu com algum sucesso colocar o 877 a trabalhar com o IPTV Meo. http://forum.zwame.pt/showthread.php?t=536386
     
  10. Boas,
    Peço desculpa mas já estou a ficar desesperado com o meu cisco 877.
    A minha ligação é da telepac e não estou a conseguir de manheira alguma liga-lo a internet.
    Os leds do PPP estao fixas e as RXD e TXD piscam.
    Vou postar aqui as minha conf para ver se há alguma alma que me possa ajudar.
    Obrigado mais uma vez.


    Current configuration : 1339 bytes
    !
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    logging message-counter syslog
    !
    no aaa new-model
    !
    !
    dot11 syslog
    ip source-route
    !
    !
    ip cef
    ip name-server 212.55.154.174
    ip name-server 212.55.154.190
    !
    !
    !
    !
    !
    !
    !
    archive
    log config
    hidekeys
    !
    !
    !
    !
    !
    interface ATM0
    description dsl interface
    no ip address
    ip access-group 111 in
    ip mask-reply
    ip directed-broadcast
    ip flow ingress
    no atm ilmi-keepalive
    pvc 0/35
    pppoe-client dial-pool-number 1
    !
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface Vlan1
    ip address 172.16.1.1 255.255.0.0
    ip nat inside
    ip virtual-reassembly
    !
    interface Dialer1
    ip address negotiated
    ip mtu 1492
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    ppp authentication pap callin
    ppp pap sent-username [email protected] password 0 ******
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 Dialer1
    no ip http server
    no ip http secure-server
    !
    ip nat inside source list 1 interface Dialer1 overload
    !
    access-list 111 permit ip any any
    !
    !
    !
    !
    control-plane
    !
    !
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    login
    !
    scheduler max-task-time 5000
    end
     
  11. Keeper

    Keeper Power Member

    pauloinho, julgo que te falta configurar muita coisa...onde estão as configurações do DHCP client? onde está aquela opção que é necessária ser enviada para poder obter um ip (2WHPL)? enfim...falta-te muita coisa...

    isto.
     
  12. voodooo

    voodooo Power Member

    Qual é a ideia em "configurar o IPTV do MEO no cisco" ? Queres descartar o Thomson ? Tens ADSL ou Fibra ? Pelo que sei, as ligações Meo têm 2 vlans, uma para dados outra pra iptv, penso que só tens que apanhar o vlan id pk os pacotes já vêm com tag, e claro, criar as respectivas vlans com os mesmos ids..
     
  13. Boas,
    Obrigado pelas respostas mas nao necessito conf dhcp e o meu ISP nao e Meo mas sim Telepac.
    Pensei que já nao me faltava muita coisa mas +arece que ainda tenho muito para suar.
    Sera que me podem ajudar a completar as conf?
    Obrigado
     
  14. Boas,
    Depois de algumas alteraçoes consigo pingar 8.8.8.8 mas o mais estranho e que continuo sem ligaçao as paginas WEB.
    Ja verifiquei se existe alguma configuraçao errada dos DNS, mas parece tudo OK.
    Alguem que me possa ajudar com este brinquedo que me esta a dar dor de cabeça
    Obrigado
     
  15. voodooo

    voodooo Power Member

  16. Keeper

    Keeper Power Member

    Paulo, diz-me o seguinte...:

    • consegues pingar os nameservers da google a partir de onde exactamente? router ? pc? router+pc?

    • já tentaste por exemplo, pingar o site da sapo.pt e ver se tb pinga ?

    • tens ip estático + DNS estático (8.8.8.8 ?) configurado no interface de rede do teu PC com uma máscara /16?

    • quando fazes um nslookup www.google.pt tal como sugerido pelo voodoo, o que acontece?


    Tenta tb criar uma access-list 1 permit any e associa-a a um interface ethernet com ip access-group 1 in ...


    Conselho: limpa tudo e faz tudo novamente de raiz, com base nestas configurações.

    Cumps
     
    Última edição: 28 de Junho de 2011
  17. Boas,
    Mais uma vez obrigado pelas respostas mas já está a funcionar.
    Tive de colocar no pc o DNS (por ex:)8.8.8.8 e não o ip do router(como estava). Nao acho normal mas funciona.
    Obrigado
     
  18. Keeper

    Keeper Power Member

    Não te funciona com o ip do router configurado como DNS na placa de rede do teu PC, porque provavelmente falta-te activar a opção "ip domain lookup".

    ex.:

    ciscorouter# conf t
    ciscorouter# ip domain-lookup


    cumps
     
    Última edição: 29 de Junho de 2011
  19. Boas Keeper,
    Esse comando já foi feito daí a minha duvida. Por isso digo que acho que deveria funcinar com o dns a apontar para o router.
    Cump
     

Partilhar esta Página