1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.
  2. A secção Microsoft/Windows encontra-se actualmente em processo de reestruturação.
    Remover anúncio

Latex - problema com a acentuação [urgente plz]

Discussão em 'Windows Desktop e Surface' iniciada por [N], 18 de Outubro de 2005. (Respostas: 7; Visualizações: 8711)

  1. [N]

    [N] Power Member

    Boas, estou com um problema grave. :rolleyes:

    tenho o meu planeamento feito para uma cadeira em latex. so k ao gerar o pdf dava erro e descobri que era por causa da acentuação. a acentuação não aparece. por exemplo se escrevo "programação" apenas aparece "programao". ele come os caracteres com acento ou de certa forma caracteres especiais ou como lhe keiram chamar =p.

    outro problema é que se eu tenho um "\section{}" com uma palavra com acento ele n gera o pdf por exemplo "\section{reunião}" mas se puser "\section{reuniao}" já gera.

    alguem me pode ajudar? obrigado.

    estou a usar MAC OS X e TeXshop
     
  2. itsy

    itsy Power Member

    Põe isto:
    \usepackage[latin1]{inputenc}
    \usepackage[portuges]{babel}

    Aquele latin1 depende do character encode que estas a usar, por exemplo se antes queres utf-8 é isso que lá deves meter.
     
  3. [N]

    [N] Power Member

    Já estive a ver e já estava a usar essa package =(

    deixo aqui o erro que me aparece... o primeiro...

    depois a seguir tem mais =(

    EDIT: afinal é sempre o mm erro só k repetidamente... é esse em cima...
     
  4. itsy

    itsy Power Member

    1) Certifica-te que o teu sistema/editor está a usar o character encoding que pões ali. Por exemplo em vim é assim: :set encoding=latin1

    2)Certifica-te que o latex tem o .def correspondente: #locate latin1.def
     
  5. [N]

    [N] Power Member

    penso que o problema não seja daí =(

    já tentei editar como vim, fiz isso do ":set encoding=latin1" fiz pdflatex do .tex e continua igual

    =(

    tkz pela disponibilidade no entanto =)
     
  6. HecKel

    HecKel The WORM

    Tens aqui uma thread que eu dei de exemplo como uma apresentação do LaTeX, talvez te ajude.

    Eu uso Fedora Core 3 e nunca tive qualquer problema com a acentuação (usando essas packages, claro), no entanto tive de ter em atenção a codificação do ficheiro, nada te UTF-8 :P

    Tens uma forma mais chata de resolver esse problema..., que é LaTeX do mais puro que há..., antes de existirem estas packages a acentuação era feita mediante comandos, \~{a} daria ã, por exemplo, tens mais uns quantos comandos..., eu sei que é chato, mas se tens urgência em entregar esse trabalho mais vale ires-te pevinindo (usa o find-replace para ajudar nisso), mas de qualquer das formas toma em especial atenção a codificação do ficheiro, já agora, certifica-te que tens essas packages instaladas no teu SO.

    abraços, HecKel
     
  7. [N]

    [N] Power Member

    oh já sei qual era o prob!! para mac a package tem que ser [applemac]{babel} em vez de [latin1]{babel} em linux.

    EDIT: Agradeço a todos!! fica aqui um manual muito bom para latex. é do alberto simoes da universidade do minho.

    Saquem o presentation.pdf e o ptlshort.pdf

    por favor vejam se podem usar... pois nao sei se aqui é limitado para alunos da um... penso que nao...

    http://alfarrabio.di.uminho.pt/~albie/lshort/
     
    Última edição: 18 de Outubro de 2005
  8. HecKel

    HecKel The WORM

    em linux é [latin1]{inputenc}, o babel é para o idioma, mas ainda bem que conseguiste resolver o problema ;) não fazia a minima ideia que as packages mudavam em MAC... :sad:

    abraços, HecKel
     

Partilhar esta Página