1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Ligação a AS/400

Discussão em 'Dúvidas e Suporte Técnico - GNU/Linux & *nix' iniciada por kurallarina, 21 de Março de 2013. (Respostas: 15; Visualizações: 1909)

  1. kurallarina

    kurallarina Power Member

    Olá,

    Preciso de ideias ... a situação é que tenho um servidor IBM AS/400 com uma consola que não faço ideia se é dele ou não porque não aparece lá nada, sem teclados ou ratos (e não vejo ligações no servidor para os ligar) e não faço ideia do ip dele apesar de ter ligação ethernet (sei apenas que estava numa rede com uma gama 173...) e preciso obviamente de aceder a ele ou melhor aceder a dados que estão numa tape a inserir no leitor desse servidor.

    (Claro que isto é um equipamente que faz anos que foi descontinuado e é um milagre digo eu ele ainda ligar ... mas já cá não existe ninguem que perceba disto ...)

    Sei que antigamente o acesso era feito através de um cliente qualquer em pc's mas é só mesmo o que sei ...

    Quais são as vossas ideias ?
     
  2. PapiMigas

    PapiMigas Power Member

    Viva

    Não tens nenhum terminal vivo que ainda se ligue a esse server? Isso já é antiguito...
     
  3. kurallarina

    kurallarina Power Member

    Olá,

    Não, a nivel dos pc's que tinham um cliente qualquer ou lá como isso se chama de as400 já foi tudo embora (uns desmantelados para aproveitamento de componentes, outros abatidos), entretanto a lan também foi alterada da gama que eu referi para a normal de 192.168.xxx.xxx e esse as/400 foi desligado ... e arrumado para canto ... fisicamente liga e aparece no painel que tem uns codigos numericos que para mim são chinês ...
     
  4. nfk

    nfk Power Member

    De certeza que é 173 e não 172? A 172 também é "normal" para redes privadas. Será viável tirar o leitor de tapes do servidor e ligar a outro computador? Sabes qual é o interface? O servidor tem alguma porta de série onde possas tentar ligar um computador diretamente?
     
  5. kurallarina

    kurallarina Power Member

    Olá,

    É possivel que possas ter razão e ser 172...

    Não me parece que seja viavel pois o leitor deverá ser scsi e penso que não iria conseguir ler a tape sem ser no servidor ...

    A nivel de portas no servidor o que lá tem são duas portas onde numa delas liga o cabo que depois liga a consola e em outra um cabo identificado como modem que não liga a nada neste momento (presumo que em outros tempos ligasse a um modem analógico) e depois tem mais duas portas que me parecem ser serie uma identificada como ups e outra como "M" ....
     
  6. nfk

    nfk Power Member

  7. kurallarina

    kurallarina Power Member

    Olá,

    @nfk, não conhecia esse forum e o artigo deu-me umas luzes e andei a mexer e neste momento posso dizer o seguinte, o servidor arranca e fica com rede, ou seja acessivel por rede. E aqui o primeiro problema é que eu não sei com que ip é que ele está (sendo que tenho a certeza que está fixo e não por dhcp).

    Pensei que estaria dentro da antiga gama que sei que era usada em alguns pc's da época (IP's: 172.16.xxx.xxx Subnet 255.255.000.000) mas configurei um pc nessa gama e liguei quer o pc quer o as/400 a um router "mixuruca" e depois do as/400 arrancar acende a luz de trafego correspondente a porta ethernet do servidor logo conectividade tem, no entanto tentando fazer um scan nessa gama não o consigo ver ... como é que eu vou agora descobrir o ip do servidor ?!!!

    Eu sei que existem algures manuais internos disto mas imaginem o tempo que vai levar em arquivos andar á procura disso ?!!!!

    Partindo do principio que se conseguirá descobrir o ip como é que eu depois consigo aceder (ou seja é necessário algum cliente especifico ?!!! ou tipo ssh resolve a questão ) ?

    A questão de passwords e logins não se coloca isso eu tenho ...

    Agora um "á parte disto" será possivel aproveitar este servidor para alguma coisa digamos que "actual" ???!!!
     
  8. nfk

    nfk Power Member

    Pelo que vi nesse fórum, deves precisar de algo como isto: http://tn5250.sourceforge.net/

    Em relação a usar para alguma coisa atual, sabes qual é o processador? Às tantas ficavas melhor servido com um Raspberry Pi. Esse servidor tem potencial para dar muito mais chatices do que serviço...
     
  9. O sistema IBM AS/400 não é um PC qualquer nem nada que se pareça. Se não tens consola que se liga por coaxial, e se esta não estiver bem configurada, não fazes nada nele a não ser que sejas técnico especializado em IBM AS/400.
    Quanto a ter uma paca de rede, os sistemas AS/400 mesmo que ligues um cabo de rede e a placa dê sinal, é necessário reactivar a placa no sistema porque quando se desliga o cabo ela entra em modo recuiperação e isso tem de ser configurado para ser automático.
    Já não me lembro como era mas penso que seria WRKCFGSTS ETH* dentro do terminal e reiniciar a placa, ou qualquer coisa do género, já não mexo nisso há mais de 10 anos...

    Pergunto-me, para que queres um sistema AS/400 em casa? Não te vai servir de nada para uso pessoal a não ser que queiras correr aplicações feitas de propósito para ele de CRM, bases de dados DB/2 ou gestão fabril... ou seja, totalmente vocacionado para correr numa empresa.
    Ele corre o sistema OS/400 e é gerido por uma consola ligada a ele por coaxial via SNA. Os clientes ligavam-se quer via SNA coaxial nos mais antigos, SNA over Ethernet com um software Client Access/400 e, nas mais recentes, já IP em que se usava um cliente telnet 5250.
    Era maquinão em termos de robustez. Já ouvi histórias mirabolantes acerca da robustez desse tipo de máquinas especialmente sei de um caso de um AS/400 ter sido emparedado por acidente e a continuar a funcionar. Só descobriram quando queriam fazer um backup e não sabiam da máquina. Tudo estava a funcionar bem... :)
    Também sei de outra que andou a boiar numa cave que encheu de água. Foi secar e continuar a funcionar :D
     
  10. kurallarina

    kurallarina Power Member

    Olá,

    Obrigado por teres respondido.

    Como referi necessito (sim ainda necessito embora não tenha tido tempo ultimamente para me dedicar mais ao assunto) de aceder a esse servidor para extrair uma série de dados que nele ficaram em tempos armazenado, e sim só tenho o servidor em si. Suponho que existisse em tempos (que já não foram os meus ... ) algum tipo de consola lá ligada pois tem dois cabos com etiquetas uma delas referindo modem e outra consola, mas da dita consola nem sinal (prevejo deve ter tido o destino de lixo ... ) após muitos restarts (de certeza mal feitos mas foi a única opção) consegui que no display da maquina aparece-se um código que segundo os manuais manuscritos a que tive acesso e que foram criados pelos operadores do sistema indica que o sistema está em pleno funcionamento.
    Ligando o cabo de rede do as/400 a um router este indica comunicação só que continuo com o problema de não fazer ideia do ip dele para ai tentar a ligação através do referido pelo @nfk.

    Claro que não quero nem tenho um AS/400 em casa ... lol ... este servidor em especifico tinha um software de assiduidade, controlo de ponto e salários e no caso era ai que necessitava aceder. Dos últimos pc's que lhe acederam eram as primeiras edições do XP e acediam por rede logo o equipamento estava acessivel por rede.

    Quando eu perguntei se era possivel aproveitar os as/400 para alguma coisa era no sentido de que temos aqui alguns encostados e se os pudesse por a funcionar nem que fosse tipo para servidores de ficheiros ou outra coisa qualquer estava a aproveitar hardware que tanto quanto sei está perfeitamente funcional.

    (Claro que no que diz respeito a estes servidores eu pouco percebo disto pois nunca vi disto á frente apesar de andarem para aqui caixas e caixas de dossiers IBM com manuais e software em disketes de 3 1/2, CD's e tapes disto...)

    Obrigada
     
  11. kurallarina

    kurallarina Power Member

    Olá,

    Como penso que existiram várias versões dos servidores as/400 aqui ficam algumas fotos do que estamos a falar:

    [​IMG]

    [​IMG]

    [​IMG]

    Obrigada
     
  12. Aviso-te já que não é qualquer um que sabe mexer nisso...
    Ou conheces alguém que seja especialista de AS/400 e co experiência ou então terás de contratar alguma empresa para te recuperar os dados.
    Quanto à consola, ela é mesmo necessária. Sem consola, não vais fazer nada com a máquina porque nem sabes em que estado está o interface de rede. Estar com as luzes acesas de conectividade não quer dizer que a placa esteja operacional a nível de protocolos acima da camada física (layer 1).
    Quanto ao aproveitamento da máquina para servidor de ficheiros, penso que o AS/400 não serve para isso. Além do tipo de aplicações que referiste, não vejo mais nenhuma utilidade para essa máquina. Esse sistema tinha uma vocação muito específica.
     
  13. kurallarina

    kurallarina Power Member

    Olá,

    Arranjei aqui um disco que foi retirado de um pc do tempo em que isso estava a funcionar e estou a tentar ultrapassar os blue screens (pois está a ser colocado num pc em que o hardware não é exactamente igual) para pelo menos tentar aceder ao ambiente de trabalho onde tem um client access configurado, ai pelo menos já dará para tentar ver se a nivel de rede está acessivel ou não digamos que seja mais um passo (eu só preciso de ter esse acesso - ou seja aquela acesso tipo como se fosse um ssh ou telnet - que penso que é isso que faz o client access ... a partir dai chegar aos dados é o que menos me preocupa)....
     
  14. Sendo um AS/400 relativamente "moderno", suportando já nativamente IP, pode ser que esse até tenha a recuperação de linha automática caso o interface ethernet seja desligado.
    Acho que o caminho é mesmo tentar recuperar o cliente para perceber, pelo menos, as configurações do Client Access. :)
    Boa sorte!
     
  15. civismo

    civismo Power Member

    Boa tarde

    Tenho um cliente que tem um servidor de AS 400, similar ao desta image, com 3 ou 4 terminais.

    http://i.imgur.com/3ceSirE.jpg

    Ja so o usam para consultar dados antigos , mas acontece que o mesmo deixou de funcionar ha uns dias , e esta a fazer uns ruidos estranhos

    Sera que ha por aqui algum tecnico de as400 que esteja disponivel para fazer uma assistencia, e cobrar directamente ao meu clinte ?

    Obrigado
     
  16. cubo-x

    cubo-x Power Member

    :offtopic:
    sem ajudar em nada, apenas me fez lembrar da antiga Marconi, e Time-sharing que
    trabalhavam com as400, aquilo eram super maquinas...
     

Partilhar esta Página