1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

lm-sensors no ubuntu 5.10

Discussão em 'Novidades GNU/Linux & *nix World' iniciada por hellaxe, 16 de Julho de 2006. (Respostas: 18; Visualizações: 1306)

  1. hellaxe

    hellaxe Power Member

    Pessoal estou a tentar instalar o lm-sensors no Brezzy mas dá-me este erro:
    Código:
    grep: /usr/src/linux/include/linux/autoconf.h: No such file or directory
    grep: /usr/src/linux/include/linux/autoconf.h: No such file or directory
    gcc -Wl,-rpath,/usr/local/lib -o prog/sensors/sensors prog/sensors/main.ro prog/sensors/chips.ro  -Llib -lsensors
    lib/libsensors.so: undefined reference to `sensors_yylex'
    lib/libsensors.so: undefined reference to `sensors_yyin'
    lib/libsensors.so: undefined reference to `sensors_lex_error'
    lib/libsensors.so: undefined reference to `sensors_yylineno'
    collect2: ld returned 1 exit status
    make: *** [prog/sensors/sensors] Error 1
    
    Any ideas??????

    Obrigado
     
  2. Koncaman

    Koncaman Utilizador Saloio

    sem a biblioteca autoconf.h vais andar sempre com esse problema.
    de certeza que isso não veio no pakote do programa? so tinhas que colocar manualmente no /usr/src/linux/iinclude/
    podes instalar isso com o apt-get? eu no dapper consigo instalar pelo apt-get...
     
    Última edição: 16 de Julho de 2006
  3. hellaxe

    hellaxe Power Member

    não consigo com o apt-get pq instalei o gdesklets e o único lm-sensors que há nos repositorios é esse.
    vou experimentar no dapper depois de instalar no meu pc. mas dava jeito saber como resolver isto.

    EDIT:
    grep: /usr/src/linux/include/linux/autoconf.h: No such file or directory

    Parece que preciso do source do kernel, não é????
    Estive a ver melhor e não tenho a directoria linux dentro do /usr/src por isso digo que me falta o source.
     
    Última edição: 16 de Julho de 2006
  4. Koncaman

    Koncaman Utilizador Saloio

    ele normalmente quando me diz que lhe faltam bibliotecas, limito-me a espetar-lhe os .h onde ele se ta a queixar, e a coisa resolve-se, mais ou menos bem.
    se n tens essa directoria, cria-a, pelo menos se continuar a dar erro, ja não vai ser esse.
     
  5. hellaxe

    hellaxe Power Member

    :lol:

    Boa politica.....

    Mas acabei por encontrar o lm-sensors nos repositórios. Corri o sensors-detect mas depois diz que não tem sensor nenhum quando faço sensors>(

    Isto acontece com algum pessoal mas como não percebo nada desta aplicação peço agora ajuda para por aquilo a funcionar.
    Obrigado novamente.
     
  6. APLinhares

    APLinhares OpenSource Moderator
    Staff Member

    Qual é a board ? 1o tens d carregar os modulos referentes do bus ... é estranho mas é verdade :D
    tipo Nforce 3, modulos eeprom, i2c_core, e por fim it87.
     
    Última edição: 19 de Julho de 2006
  7. hellaxe

    hellaxe Power Member

    Tenho uma Asus A7N8x-x - Nforce2.
    Tenho de fazer o:
    Código:
    modprobe "módulo específico"
    para todos eles?
    São 3. E já agora qual a ordem certa? estive a ver no fórum oficial e falam lá dessa situação mas também não explicaram o porquê.
     
  8. APLinhares

    APLinhares OpenSource Moderator
    Staff Member

    ao que parece o sensors-detect devia carregar os modulos do bus 1 a 1, mas nao acontece isso.
    sim, deve usar modprobe pra cada 1 deles.
    eu costumo usar o locate pra procurar os modulos existentes, tipo "locate i2c" . Ou manual/ (mais chato) é procurar /lib/modulos/versao do kernel/kernel/drivers/i2c/busses/ . 1 deles deve ser o i2c-nforce2. 1o o Bus depois os restantes tanto faz a ordem :)
     
  9. hellaxe

    hellaxe Power Member

    Estás a falar deste ser o primeiro, não é?
     
  10. APLinhares

    APLinhares OpenSource Moderator
    Staff Member

    exacto. o lmxx so no fim. (pra dar tb menos confusao)
     
  11. tmafcerqueira

    tmafcerqueira Power Member

    Boas,
    Estou com um problema parecido. Tenho o Kubuntu Dapper Drake e quando tento usar o gDesklets nao consigo ver as temperaturas... Ja tenho o lm-sensors instalado, mas mesmo assim continua sem funcionar>(. Quanto ao sensors-detect da-me
    Código:
    No i2c device files found. Use prog/mkdev/mkdev.sh to create them.
    Como é que resolvo isto? Desde ja agradecido
     
  12. hellaxe

    hellaxe Power Member

    Faz um search no forum do ubuntu, pode ser que isso já esteja documentado.
    Gostava de ajudar mas sei ainda pouco disto.
     
  13. tmafcerqueira

    tmafcerqueira Power Member

    É o que farei... Obrigado na mesma pela ajuda ;)
     
  14. APLinhares

    APLinhares OpenSource Moderator
    Staff Member

    tens isso incompleto ;)
    1 dos guias que aconselho, simples e bem explicado debian
     
    Última edição: 24 de Julho de 2006
  15. tmafcerqueira

    tmafcerqueira Power Member

    Ja consegui!!! Obrigado pelo grande tutorial, excelente mesmo. Irei posta-lo aqui em portugues.
    Obrigado mais uma vez
     
  16. Koncaman

    Koncaman Utilizador Saloio

    éh pa, ja agora, alguém sabe se isto tem alguma versão para ambiente grafico com actualizações automaticas? e assim uma cena coma temp do cpu para a taskbar...

    é que isto na linha de comandos é um bocado chato...
     
  17. El_UnO

    El_UnO 1st Folding then Sex

  18. Koncaman

    Koncaman Utilizador Saloio

    eu queria mesmo so uma coizita para ter na taskbar.
    mas esse ate servia bem...

    vou ver se me desenrrasco a instalar isso.
    obrigado ;)
     
  19. APLinhares

    APLinhares OpenSource Moderator
    Staff Member

    Se usares KDE,ve o superkaramba + themes (tem varias, pra todos os gostos aqui, ou entao Gnome com o GDesklets aqui.
     

Partilhar esta Página