1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Microsoft Excel - Dúvidas e Suporte

Discussão em 'Windows 7 e anteriores' iniciada por J_NUK_A, 29 de Agosto de 2008. (Respostas: 788; Visualizações: 72308)

  1. ElKun

    ElKun Power Member

    Acho que o mais fácil é colocares na célula A5 =A1 e colocar a formatação personalizada na célula A5 apenas como [h], ou seja, vai aparecer apenas as horas
     
  2. ppt

    ppt Power Member

    Mas ele não quer uma formatação personalizada, quer mesmo o valor inteiro. Da forma que dizes, se ele fizer cálculos de custos (por exemplo), vai contabilizar o valor real (com minutos) e não com o valor certo de horas. É necessário ter cuidado com estas coisas, porque os cálculos não são feitos com o valor visível, mas sim com o valor real.
     
  3. Obrigado pela vossa preciosa colaboração. Um grande bem haja ao pixoxo10!

    Cá vai a formula desejada.
    =_xlfn.DAYS(A1;0)*24+HORA(A1)
     
  4. ElKun

    ElKun Power Member

    O que li sobre a dúvida dele é que pretende apenas que a célula A5 devolva o número de horas.
    Para isso basta uma formatação personalizada, conforme sugeri.
     
  5. ppt

    ppt Power Member

    @ElKun Ter uma célula com 01:30:00, formatada de modo a que apareça "1" é diferente de ter uma célula em que o seu conteúdo é "1". Caso faças cálculos posteriormente com esse valor, não vai dar o resultado desejado.
     
  6. ElKun

    ElKun Power Member

    Mas ele não falou em cálculos posteriores com a célula A5.
    Se for para depois fazer cálculos posteriores, pode fazer o seguinte: coloca a formula na célula A5 =INT(A1*24)
     
  7. ppt

    ppt Power Member

  8. borntonag

    borntonag Power Member

    Viva!

    Tenho esta função:
    Código:
    A3=PROCV(G3;Categorias!B3:E36;2;0)
    A coluna G tem um texto com vários códigos (exemplo: MMD123456 PAG BX VAL-VIAVERDE MOV 13) e a coluna B da folha "Categorias" tem o mesmo texto que a coluna G mas sem os códigos (mesmo exemplo: PAG BX VAL-VIAVERDE).

    O objetivo seria que a fórmula procurasse se o texto da coluna B da folha Categorias está presente na coluna G e apresentar o valor da coluna 2 do intervalo definido (B3:E36).
    Hipoteticamente seria algo assim:
    Código:
    A3=PROCV(G3;"*"&Categorias!B3:E36&"*";2;0)
    Mas sei que é errado. Seria fácil se as colunas fossem ao contrário mas não tenho forma de o fazer. Alguma forma de dar volta a isto?
     
  9. jjmaia

    jjmaia What is folding?

    Boas,
    Tenho um excel com 3 colunas, a primeira e' a matricula de um carro, a segunda a temperatura e a terceira a hora.
    Quero fazer gráficos temperatura em variação do tempo, funcionava sem problemas para uma viatura, o problema e' que tenho varias.

    Como posso fazer um gráfico temperatura em função da hora para todas as viaturas?

    Obrigado.
     
  10. pixoxo10

    pixoxo10 Power Member

    Se o espaço temporal for o mesmo, ou seja, não uma variável mas um eixo igual para todas as viaturas, podes fazer um gráfico com eixos x/y (temperatura/tempo) com várias linhas (uma linha por matrícula).
     
  11. jjmaia

    jjmaia What is folding?

    Sorry a demora na resposta :p
    Podera ser essa a solucao, mas ele esta a meter tudo num so grafico...

    EDIT: O espaco temporal e' o mesmo, mas cada veiculo tem uma hora diferente para cada temperatura.

    A coluna A e' a matricula (nunca tenho mais de 4 de cada vez), a B e' a temperatura, e a C o tempo (horas:minutos:segundos).
    A info para o grafico e' so a coluna B e C, mas tenho que andar a copiar e a colar para fazer 4 grupos de duas colunas (temperatura e tempo para as 4 matriculas), quando o que eu queria (so por uma questao de perder menos tempo) era que o excel lesse a coluna A e fizesse 4 linhas com os dados das colunas B e C.

    Obrigado.
     
    Última edição: 8 de Junho de 2017
  12. lupum

    lupum Power Member

    Boa tarde, estou com um problema irritante no Excel.
    1 6481366216 513432
    2 3358766563 80789
    3 8444725903 NA
    4 MD10005861 A16-9003
    5 MD10006099 A16-9002
    6 MD10005966 A16-9001A/9001B
    7 MD10006277 A16-514
    8 MD10006276 A16-518
    9 MD10006288 A16-534

    São 3 colunas. Numa outra célula, pode ser N2 digito um campo Alfanumérico da coluna 2 e automaticamente na N3 quero que me apresente os dados correspondentes da 3ª coluna. o VLOOKUP dá-me sempre erro #N/A.
    Alguém me pode ajudar?
     
  13. redrose

    redrose Power Member

    Não sei se percebi bem, mas essa tabela que apresentas é a tabela matriz onde vais buscar os dados para preencher uma célula sempre que digitas um código da coluna 2, é isso?

    Se sim, tenta colocar a coluna 2 em primeiro lugar, ou seja, a tabela matriz fica:

    6481366216 1 513432
    3358766563 2 80789
    8444725903 3 NA
    MD10005861 4 A16-9003
    MD10006099 5 A16-9002
    MD10005966 6 A16-9001A/9001B
    MD10006277 7 A16-514
    MD10006276 8 A16-518
    MD10006288 9 A16-534
     
  14. lupum

    lupum Power Member

    Porra... A sério que era só isso? Bem. Deu para resolver. Criei uma outra folha para copiar os dados dessa maneira, porque as colunas têm mesmo de estar naquela ordem. Muito obrigado
     
  15. redrose

    redrose Power Member

    Podias colocar a tabela matriz a começar só na 2ª coluna.
    É que ele vai sempre procurar o identificador na coluna que tiveres definido como 1ª coluna na tabela matriz.
    :beerchug:
     
  16. lupum

    lupum Power Member

    Pensei que o Excel queria sempre uma ordenação para ir fazer uma procura em condições:) Está feito. Obrigado
     
  17. Dav7

    Dav7 Power Member

    Pediram-me para passar um mapa feito em colunas/linhas excel, para um documento Word.

    Há forma? Obrigado
     
  18. pixoxo10

    pixoxo10 Power Member

    Sim...tanto online como copy/paste.
    Mas poderá sofrer desformatação num ou outro aspeto.
     
  19. sKINA1

    sKINA1 Power Member


    Se for só para ficheiro de leitura até podes fazer logo , Salvar como , PDF
     
  20. Dav7

    Dav7 Power Member

    Obrigado, acabei por transformar em PDF e criar um ficheiro neste formato.
     

Partilhar esta Página