1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Microsoft Excel - Dúvidas e Suporte

Discussão em 'Windows 7 e anteriores' iniciada por J_NUK_A, 29 de Agosto de 2008. (Respostas: 788; Visualizações: 72308)

  1. DisturbedGod

    DisturbedGod 1st Folding then Sex

    Boas nunofls,

    Vê lá se é isto que queres, na célula D1 introduz a seguinte função:

    =SE(C1="h";A1&B1;"")
    Se o valor da célula C1 for igual a h então junta a célula A1 e B1. Se o valor de C1 for diferente que h então não acontece nada. Esta fórmula depende do que queres procurar na coluna C.
     
  2. BolaBrancaV7

    BolaBrancaV7 Power Member

    Isto é uma dúvida que tens de um caso que estás a fazer ou é algum exercício para a escola? Esse título é muito específico.

    Para teres um Vlookup a devolver valores de duas células diferentes tens de escrever duas fórmulas e juntar com o operador &

    Algo assim: =VLOOKUP(D1;A1:C20;2;FALSE)&VLOOKUP(D1;A1:C20;3;FALSE)
     
  3. Boas Vasco,
    Não é para escola, é para o trabalho. Envio link, o que pretendo é o que esta na coluna F.
    https://drive.google.com/open?id=1cnLvFEtQ3AFVrPmtvNwbHPkiz35K2RH81zjYchfnCvI

    Podem ajudar?
     
  4. BolaBrancaV7

    BolaBrancaV7 Power Member

    Qual é o número máximo de repetições? Se for no máximo duas, acho que é fazível, se for diverso, penso que (através de fórmulas) não seja fácil de devolver na mesma célula.

    Safas-te com o Inglês? Esta explicação parece-me a mais próxima daquilo que eu utilizaria: https://www.ablebits.com/office-addins-blog/2017/02/22/vlookup-multiple-values-excel/
     
  5. ][_PWNN_][

    ][_PWNN_][ Power Member

    Formatação Condicional

    Conforme o valor de uma determinada célula, a linha (até ao fim da tabela) onde essa célula está fica de uma determinada cor.
    Por exemplo, se a célula A1 tiver o valor de 1, essa linha (1) fica verde. Se tiver o valor de 0, fica vermelha (o exemplo é com 1 e 0, mas pode ser com valores de texto, e pode ser mais que 2 valores).

    Estou a conseguir fazer isto, mas para uma linha de cada vez, em vez de para a tabela toda de uma vez só.
    Como poderei fazer para uma tabela inteira, de uma vez só?


    Desde já agradeço a ajuda :)
     
  6. Seleccionas todas células ou colunas onde queres a formatação.

    Vais ao Conditional Formatting, escolhes "New Rule".

    Depois escolhes "Use a formula...", e em baixo onde diz "Format values where..." colocas $A1="0". Depois clicas em format e escolhes a formatação pretendida.

    Repetes os passos para os outros valores que pretendes (1, 2, etc).

    ;)
     
  7. ][_PWNN_][

    ][_PWNN_][ Power Member

    Já fiz isso. O problema é que isso só funciona com os valores da célula A1. E as outras linhas? A2, A3, etc...
    O problema está aqui. Fazer para meia dúzia de linhas é fácil, mesmo que tenha que fazer uma linha de cada vez.
    Mas e fazer para uma tabela inteira, com centenas de linhas?
     
  8. Tens que fazer exactamente pela ordem que indiquei.

    Por exemplo, se queres que esta regra se aplique da coluna A à coluna P, antes de criares a regra, seleccionas estas colunas.

    Entra na opção Conditional Formatting e escolhe "Manage Rules", tem que estar parecido com isto:

    [​IMG]

    https://imgur.com/a/GUCPi4K
     
  9. ][_PWNN_][

    ][_PWNN_][ Power Member

    Fiz exactamente como disseste, não dá. Fica a tabela toda vermelha ou verde consoante o valor da célula que eu defino para o teste lógico, e só dessa célula.

    [​IMG]
     
  10. ppt

    ppt Power Member

    Tens de mudar
    =$B$4=0
    para
    =$B4=0 (como o @cfmdias tem no seu exemplo)

    Como tens, estás a fixar a linha 4 e ele vai fazer o teste sempre com essa linha.
     
  11. ][_PWNN_][

    ][_PWNN_][ Power Member

    Ah... pormenores :-D não tinha reparado nisso.
     
  12. redrose

    redrose Power Member

    Pessoal, preciso de contar o nº de células numa tabela que tenham números terminados num determinado algarismo.
    Sei que para palavras é fácil utilizando por exemplo =CONTAR.SE(A2:A5;"*s")
    Como faço para números?

    Obrigado!
     
  13. ppt

    ppt Power Member

    Sendo apenas números inteiros:

    Podes descobrir o resto da divisão por 10
    =RESTO(A1;10)
    e depois
    =CONTAR.SE(B1:B5;5)

    Também podes converter para texto usando
    =TEXTO(A1;"#")
    e depois
    =CONTAR.SE(B1:B5;"*5")
    , mas é uma solução menos elegante e eficiente.
     
  14. redrose

    redrose Power Member

    Então tenho de fazer uma tabela a partir da original onde calculo todos os restos de divisão por 10 e depois nessa é que conto os valores que quero? É isso? ou posso fazer diretamente a partir da tabela original?
     
  15. ppt

    ppt Power Member

    Estive a pesquisar no Google e encontrei isto que funciona:
    =SOMARPRODUTO(--(MOD(A1:A5;10)=5))

    Tenho de perceber o que fazem os "--".
     
  16. redrose

    redrose Power Member

    Não consigo aplicar isso.
    Dá erro.
     
  17. Experimenta assim:
    =SUMPRODUCT(--(RIGHT(A1:A5)="8"))

    Se quiseres que a formula vá buscar o valor a contar noutra célula, essa terá que estar formatada como texto e não como numero, senão não funciona.

    Ex:
    =SUMPRODUCT(--(RIGHT(A1:A5)=B2))
     
  18. redrose

    redrose Power Member

    Não estou a conseguir. Será de ter os valores em linha e não coluna?
     
  19. redrose

    redrose Power Member

    Bem, acabei por fazer com esta sugestão do @ppt . Fiz uma tabela com os restos da divisão e depois fiz a contagem nessa tabela.
    Obrigado.

    Agora tenho outro problema:

    Na mesma tabela quero contar os nºs que começam por algarismos entre 3 e 6 em cada linha.
    Tem uma dificuldade extra que é o facto de não querer contar nºs só com um algarismo.
    Ou seja, deve contar nºs começados por 3, 4, 5 e 6, se e só se o nº tiver 2 algarismos.
    Isto acontece porque quem fez a tabela fez mal e, por exemplo, o nº4 não deveria ser 4 mas sim 04.
    Se alguém tiver uma ideia ágil de adicionar o "0" que falta neste nº com um só algarismo, também podemos tentar irt por aí.
     
  20. ppt

    ppt Power Member

    Ora bem, para mostrares o 0 antes do 4, podes formatar o número com a formatação personalizada 00 (vai escrever 04). Mas o 4 continua a ser 4 em valor.

    Para verificares se o número verifica as condições que impões, colocas um teste que resulta em 1 se for verdadeiro e em 0 se for falso, e depois somas para ter o total:
    =SE(E(NÚM.CARACT(A1=2);(A1-RESTO(A1;10))/10>=3;(A1-RESTO(A1;10))/10<=6);1;0)
     

Partilhar esta Página