1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Não consigo fazer boot do windows apos reposição do mbr

Discussão em 'Novidades GNU/Linux & *nix World' iniciada por muddymind, 10 de Agosto de 2007. (Respostas: 17; Visualizações: 1274)

  1. muddymind

    muddymind 1st Folding then Sex

    Boas!

    Queria reinstalar o ubuntu numa maquina que tinha dual-boot com win+ubuntu e para isso fui em primeiro lugar repor o mbr com a consola de recuperação do windows para depois ir para o windows apagar a partição do ubuntu e fazer umas alterações nas outras... o problema é que apos fazer fixmbr fui reiniciar o pc e apareceu-me "Error loading operative system" :S Como é que consigo recuperar o boot do windows?

    []
     
  2. mc_cgp

    mc_cgp Power Member

    Boas,

    Fizes-te os dois comandos fixmbr e fixboot?
    /
     
  3. muddymind

    muddymind 1st Folding then Sex

    PRimeiro como o fixmbr não funcou (das outras vezes tinha funcionado) experimentei fazer fixboot c: mas tambem não deu :S

    []
     
  4. xtr3me

    xtr3me Power Member

    Acho que maraste a tabela de partições.
     
  5. muddymind

    muddymind 1st Folding then Sex

    marei só de fazer fixmbr? ele continua a reconhecer todas as partições de forma correcta...
     
  6. xtr3me

    xtr3me Power Member

    às vezes quando se escreve no mbr a tabela de partições fica arruinada.

    Mas .. ele detecta-te as partições certas? Isto é, o que está no C é mesmo o que era suposto estar, etc?
    É que o que às vezes acontece é ele trocar as letras das "drives".
     
  7. muddymind

    muddymind 1st Folding then Sex

    Tá tudo no lugar e com as letras certas...
     
  8. xtr3me

    xtr3me Power Member

    Estranho.

    De certeza que limpaste bem o mbr? Não houve erros ou alguma coisa fora do normal?
     
  9. muddymind

    muddymind 1st Folding then Sex

    Tudo na maior das normalidades.... tirando o boot do windows é claro...
     
  10. xtr3me

    xtr3me Power Member

    Então não te sei ajudar.

    Pelos vistos não é a tabela de partições. Deve ser mesmo algum ficheiro do windows que se marou.
    Tenta fazer um repair. Caso não dê, tens de esperar que venha mais alguém que te possa ajudar. Assim de repente não estou a ver mais nada.
     
  11. muddymind

    muddymind 1st Folding then Sex

    deixei agora aquilo a fazer recuperação... vamos la a ver o q sai dali pois da ultima vez que o fiz a experiência não foi nada boa...
     
  12. mc_cgp

    mc_cgp Power Member


    Volta a instalar o Ubuntu com um live CD, Podes usar o GParted, o QT ou outra coisa qualquer de partitioning do live CD (Gnome /KDE) para apagares as partições do Linux (ext + swap).

    Logo vez se o windows continua ou não a fazer boot

    /
     
  13. muddymind

    muddymind 1st Folding then Sex

    a recuperação não funcionou :S
     
  14. muddymind

    muddymind 1st Folding then Sex

    tive de reinstalar o ubuntu... Enfim... e se quiser desaparece com o linux e ficar apenas com o XP?

    []
     
  15. xtr3me

    xtr3me Power Member

    Apagas a partição de linux e depois limpas o mbr. Nada mais simples ;)
     
  16. Tyran

    Tyran Power Member

    Boas, apagas o ubuntu, metes cd do xp, crias um novo raw e reinicias, não precisas de fix e é melhor para tipos como eu que só tem o recovery cd logo, não tem linha de comandos xD
    Se não der, mete o live-cd e verifica no gparted o a partição do windows tá com a flag boot..
    cumpzz
     
  17. Hipnoted

    Hipnoted Power Member

    Isso infelizmente já me aconteceu...

    A única solução, no meu caso, foi voltar a instalar o Windows noutra partição para recuperar o grub. Depois recuperei os dados e para não ter o outro windows a estorvar formatava o PC! :D
     
  18. muddymind

    muddymind 1st Folding then Sex

    Isso foi uma das coisas que fiz... o resultado disso foi a bios não reconhecer o disco como bootable porq o fixboot e fixmbr pareciam não actualizar a referencia de onde ir bustar o boot... enfim...

    Entretanto um user do ubuntuforums deu-me um link onde consegui arranjar uma solução que funcionasse:

    http://www.users.bigpond.net.au/hermanzone/p18.htm
     

Partilhar esta Página