1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Não consigo ligar á tmn pela placa ZTE em ubuntu 8.10

Discussão em 'Dúvidas e Suporte Técnico - GNU/Linux & *nix' iniciada por Ghostryder, 6 de Dezembro de 2008. (Respostas: 20; Visualizações: 5878)

  1. Ghostryder

    Ghostryder I fold therefore I AM

    Boas pessoal,

    Aconteceu-me algo muito estranho... e neste momento estou sem net em ubuntu.

    Tenho o toshiba l40 da e-escola a correr ubuntu 8.10 e tinha a placa ZTE da tmn a funcionar lindamente. Para pola a funcionar segui este guia.

    Na quinta à noite instalei as ultimas actualizações ao sistema através do update manager e agora já nao consigo conectar á net através da placa.

    Quando estava tudo bem, ligava a placa ao portatil, passado um bokado aperecia-me tmn no network manager e era so clicar e conectar. Agora, em vez de aparecer tmn, aparece-me outra coisa e se clicar nunca consigo estabelecer ligação.

    Agora estou sem net em ubuntu pk o wireless só funciona ao lado do router e agora nem com a placa consigo ligar á net!

    Cumpz
     
  2. Mr_Holmes

    Mr_Holmes Power Member

    Aparece-te na parte de ligação por placa 3G, uma ligação que tu não crias-te e não aparece as que crias?
    Se for isso, vais ao network manager e essa ligação basta coloca-la com as configurações da TMN e ja pões a funcionar. Também me aconteceu o mesmo mas fiz isso e voltou a funcionar
     
  3. Ghostryder

    Ghostryder I fold therefore I AM

    Exacto... aparece-me uma ligação que eu nao criei... mas depois cliquei com o botao direito no network manager - mobile broadband, e configurei de novo a ligação tmn...mas ela nao aparece depois para eu fazer a ligação...nao sei pk...
     
  4. Também não consigo... ZTE MF620 e Ubuntu 8.10

    Olá, estou com o mesmo problema...
    Passo a descrever a minha história:

    Tenho um Asus eeepc 1000h (e estou satisfeito) recentemente instalei-lhe o Ubuntu 8.10 (via Windows) e correu tudo bem.
    Ontem liguei-lhe o modem, a placa foi detectada e iniciou-se o assistente de ligações. Escolhi tmn e depois efectuou-se a ligação à rede (impecável).


    No icon de rede do canto superior direito aparecia


    Rede Com Fios
    o Auto eth0 (translucido pq n tenho rede de cabos)
    Banda Larga Móvel
    o TMN


    Entretanto efectuei as actualizações do UBUNTU, instalou cerca de 200MB e depois, após reiniciar, a luz do modem deixou de acender, este deixou de reagir e no icon de rede no canto superior direito passou a aparecer:


    Rede Com Fios
    o Auto eth0 (como seria de esperar mantem-se translucido)
    Banda Larga Móvel
    o TMN (sendo que TMN esta translucido, sem dar para clicar, mesmo com a placa ligada)
    o Auto Mobile Broadband (CDMA) conection (tentei clicar nesta mas falha sempre...)


    Em que a rede CDMA tem as seguintes definições:
    Number: #777
    Username: <em branco>
    Senha: <em branco>




    Nas definições da tmn, está:
    Number: *99#
    Username: <em branco>
    Senha: <em branco>
    .
    APN: internet


    Além disto, a tmn tem um endereço de dns no terceiro separador...


    Quando retiro a placa desaparece também a ligação CDMA, voltando a aparecer se voltar a ligar a placa.


    Agradecia se alguém pudesse dar uma ajuda...


    Obrigado,
    Cumps
    PireXeee
     
  5. Ghostryder

    Ghostryder I fold therefore I AM

    eu ja resolvi o meu problema...

    faz o seguinte:

    - copia todos os parametros da ligaçao tmn para a ligaçao que ele criou!
    - depois quando quiseres ligar o modem executa estes comandos na consola:
    /usr/sbin/usb_modeswitch -d 1 -v 0x19d2 -p 0x2000 -V 0x19d2 -P 0x0001
    /usr/bin/gcom -d /dev/ttyUSB0
    - depois disto tenta fazer a ligação no network manager... ja deve funcionar!

    Eu sei que é incomodo ter que fazer estes dois comandos na consola antes de ligar...mas enkuanto nao ha novidades para resolver isto... grava esses dois comandos num ficheiro de texto!

    Cumpz
     
  6. Olá,
    Obrigado pela ajuda Ghostryder! Mas infelizmente tive uns contratempos...
    Tanto o usb_modeswitch como gcom não existem no meu pc (deviam existir?).

    Para juntar à festa, também a placa wireless (integrada no pc) não é detectada pelo sistema, pelo menos não aparece nenhuma referência a ela lá no icon das redes.

    Secalhar dá é para sacar da net esses programas que faltam e depois instalá-los!? Mas acho que é preciso compilar depois de sacar, não é? Alguém me pode explicar (como se fosse muito burro) como me hei de safar destas complicações?

    Cumps
    PireXeee
     
  7. Ghostryder

    Ghostryder I fold therefore I AM

    nops...nao deviam existir...segue isto direitinho e ve se funciona aquilo que eu te disse.
     
  8. Hey,
    A net já bomba...

    Obrigadão!!!!
    Cumps
     
  9. alguem me pode ajudar eu estou com o mesmo problema em relaçao a placa da tmn... e o site que deram parece estar off... alguem tem outra ideia? é que estou farto de procurar e nao encontro nada
     
  10. rare

    rare Power Member

    Boas

    Também tenho um portátil, do eescola, o insys gameforce com linux

    Para ligares a net esperas que o computador inicie e depois está uma espécie de cabo nos ícones do canto inferior direito com um x com um fundo de um círculo vermelho (onde está sistema, aplicações etc.)

    Carregas com o lado direito do rato nesse ícone, aparecem várias opções e poes conectar ppp0, se demorar muito carregas outra vez ou então esperas porque acho que a ligação demora algum tempo

    Fikem bem
     
  11. ZTE MF622 em UBUNTU 8.10

    Ola,

    Não sei se pode ajudar, mas tive esse mesmo problema até hoje no meu Toshiba p300 com UBUNTU 8.10 e a placa MF622 da ZTE (e operadora TMN).

    Hoje acordei e lembrei-me de desativar o PIN da placa (em Windows) no programa fornecido com a placa.
    Depois reiniciei em UBUNTU...
    Espantosamente, e depois de ter alterado o numero de ligação de #777 para *99# (na ligação criada pelo UBUNTU), passei a ter net....
    Parece que, pelo menos no meu caso, o único problema era que o software que reconhece a placa não permite introduzir o código PIN relativo ao meu cartão de dados...

    Notem que não percebo muito de computadores, peço desculpa se estiver a dizer disparates...

    Boa sorte
     
  12. A solução definitiva para ZTE MF628 (ou outras):

    Você vai precisar também do usb_modeswitch:

    http://www.draisberghof.de/usb_modeswitch/...h-0.9.4.tar.bz2
    (pode sacar uma versão diferente, mais recente)

    E do usb_modeswitch.conf:

    http://www.draisberghof.de/usb_modeswitch/...modeswitch.conf
    (pode procurar por mais recentes)

    De posse dos arquivos, vamos efetuar a compilação do usb_modeswitch.

    Copie o arquivo usb_modeswitch.conf para /etc: (ficheiro inicial tem que estar na home)

    # cp usb_modeswitch /etc/

    Descompacte o arquivo usb_modeswitch-0.9.4.tar.bz2:

    # tar -xvjf usb_modeswitch-0.9.4.tar.bz2

    Entre na pasta usb_modeswitch-0.9.4 que foi criada: (se for outra versão a pasta é diferente)

    # cd usb_modeswitch-0.9.4/

    Agora com permissão de root, copie o arquivo usb_modeswitch para a pasta /usr/sbin/:

    # cp usb_modeswitch /usr/sbin/

    2º Editar o ficheiro /etc/usb_modeswitch.conf na consola, com o seguinte comando:
    sudo gedit/etc/usb_modeswitch.conf
    descomentar a parte relativa ao modem ZTE, ficando assim:
    (pode apager todo o conteudo do ficheiro ficando só isto...)

    (se for outra placa, é só descomentar a parte relativa a essa placa em vez desta!!!)

    ########################################################
    # ZTE MF628
    #
    # Captured with "usbmon". Has a micro SD slot which can be
    # activated alternatively
    #
    # Contributor: Alvaro Lopes <alvieboy at alvie dot com>

    DefaultVendor= 0x19d2
    DefaultProduct= 0x2000

    # To modem mode:

    TargetVendor= 0x19d2
    TargetProduct= 0x0015

    MessageEndpoint=0x08
    MessageContent="5553424312345678000000000000061b000000030000000000000000000000"

    # To SD slot mode:

    ;TargetVendor= 0x05c6
    ;TargetProduct= 0x2001

    ;MessageEndpoint=0x08
    ;MessageContent="55534243123456782000000080000a86010101180101010101000000000000"

    ;ResponseEndpoint=7

    Gravar e sair do gedit

    3º Em /dev/ criar um ficheiro chamado ttyUSB0 utilizando o seguinte comando na consola:
    sudo gedit /dev/ttyUSB0
    Gravar e sair do gedit

    4º Executar na consola o seguinte comando:
    sudo /usr/sbin/usb_modeswitch -v 0x19d2 -p 0x2000 -V 0x19d2 -P 0x0015 -m 0x08 -M 5553424312345678000000000000061b000000030000000000000000000000

    O modem deverá reeniciar e depois de alguns segundos será detectado automaticamente.
    É só seguir as instruções, escolher o operador , colocar o PIN caso esteja activado e depois é só fazer a ligação clicando no icon das ligações de rede.

    Interessante é que na primeira ligação que se fizer, o modem ficará com a luz apagada, mas se depois se desligar a ligação, da segunda vez e seguintes, já funcionará com as indicações luminosas.

    5º Deverá criar na Área de Trabalho um ficheiro por exemplo com o nome Placa 3g e colocar lá a seguinte linha de comando:
    sudo /usr/sbin/usb_modeswitch -v 0x19d2 -p 0x2000 -V 0x19d2 -P 0x0015 -m 0x08 -M 5553424312345678000000000000061b000000030000000000000000000000

    Depois nas propriedades do ficheiro em "Permissões" colocar um visto em "Permitir executar o ficheiro como uma aplicação".

    Sempre que inicia o computador deverá executar este ficheiro, para que o modem ZTE MF628 fique activo.
    Atenção deverá escolher o botão "Executar na Consola" e colocar a palavra-chave de administrador.
     
  13. monkeypuke

    monkeypuke Power Member

    Também funciona na Option's iCon 225?

    [​IMG]
     
  14. a placa é modem+pen?
    se for tenta fazer como eu explico....
    Mas uma procura no google não te faz mal
     
  15. monkeypuke

    monkeypuke Power Member

    Já procurei no google.
    O "modem-pen" tem aquela treta que faz o modem ser reconhecido como um dispositivo de armazenamento onde tem os drivers.

    Fui capaz de impedir que isso aconteça através da aplicação ozerocdoff que encontrei no site:

    http://www.pharscape.org/

    O modem agora é reconhecido e quando clico lá no simbolozinho do network manager (ou lá como se chama) aparece a rede TMN.

    Mas quando eu me tento conectar, logo de seguida, recebo uma mensagem a dizer que a rede foi desactivada (ou desligada (não estou com o portátil aqui ao lado, por isso não sei os termos exactos que lá aparecem)).

    Muito provavelmente acho que é da rede que está mal configurada.... não sei...
    Vou mandar um email para o apoio da TMN e ver o que eles me dizem.

    Mas se alguem me conseguir ajudar era bom.

    Alguem que tenha uma placa da TMN (qualquer que ela seja) a funcionar no Ubuntu podia-me postar as configurações da vossa rede?

    Obrigado

    E quando chegar a casa experimento a tua solução ruilvo

    Obrigado
     
    Última edição: 6 de Março de 2009
  16. isso tambem me acontecia.
    faz o seguinte.
    desconecta a placa.
    espera.
    insere a placa.
    espera.
    se tiveres que fazer alguma coisa par a placa mudar pa modem, fa-lo.
    espera mais um pouco para a placa apanhar o sinal
    tenta então ligar-te.

    tens o PIN activado?
    se tiveres vai ao sitio da conecxoes de rede e põe o PIN na rede TMN...
     
  17. monkeypuke

    monkeypuke Power Member

    o pin não está activo
     
  18. Boas,

    tenho o Ubuntu 9.04 instalado e tenho q confessar q sou novo nisto....:D

    Preciso da vossa ajuda para ligar a minha placa da TMN ZTE MF622....Ja tentei seguir um tutorial q esta em cima, mas os liks para modeswitch n funcionam....

    Ao ligar a placa ao PC n aparece nada no Ubuntu? N devia dar algum sinal?

    Basicamente, como tenho q fazer para ligar a minha placa e poder utilizar no Ubuntu?
     
    Última edição: 1 de Maio de 2009
  19. Alguém sabe por isto a funcionar no Fedora 10???
     
  20. Stlkr

    Stlkr Power Member

    boas pessoal ando a procura de como por a funcionar a placa da tmn de banda larga no ubuntu 8.10

    a placa é esta:

    [​IMG]
    já andei à procura em muitos sites e nada =x

    o modelo é MODEM MF630 HSUPA EDGE USB

    cumps
     

Partilhar esta Página