1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Não percebo onde está o erro...

Discussão em 'Web Development' iniciada por DannyPt, 22 de Maio de 2012. (Respostas: 7; Visualizações: 521)

  1. DannyPt

    DannyPt Power Member

    Estou a fazer experiências em css...

    Basicamente tenho um menu com a id=menu e no CSS fiz display: inline-block;

    deveria aparecer tudo em linha supostamente...mas não, continua a aparecer-me em bloco tudo um a seguir ao outro.

    Isto é o que tenho no index na parte do menu:

    <nav id="menu">
    <ul>
    <li>HOME</li>
    <li>SERVIÇOS</li>
    <li>CONTACTO</li>
    </ul>
    </nav>


    isto é o que tenho no CSS:

    #menu{
    background: #666;
    border: 1px #F00;
    padding: 20px;
    }
    #menul li{
    display: inline-block;
    }


    o background aparece bem, as cores bem, a padding bem...mas o display não, continua-me a aparecer como sempre apareceu. Onde raio está o erro? Não entendo... :\

    Obrigado
     
  2. DannyPt

    DannyPt Power Member

    Já resolvi...escrevi tudo de novo e deu...ainda não entendi onde estava o erro, mas já funciona...lol
     
  3. amando96

    amando96 Power Member

    Terá sido o typo "#menul li" em vez de #menu ul il?
     
  4. DannyPt

    DannyPt Power Member

    Penso que não...porque eu deixei estar #menu li e ficou tudo ok...lol
     
  5. fatm

    fatm Power Member

    mas ele nao se refere ao menu li mas ao menul repara la bem no codigo que metes-te
     
  6. DannyPt

    DannyPt Power Member

    Txi...tens razão, que falha! Nem tinha reparado nisso...lol

    Obrigado
     
  7. amando96

    amando96 Power Member

    É o que dá ficar no PC até tarde :007:
     
  8. DannyPt

    DannyPt Power Member

    Mesmo...lol
     

Partilhar esta Página