1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

.NET E Vista

Discussão em 'Programação' iniciada por Grabitzz, 16 de Maio de 2007. (Respostas: 6; Visualizações: 665)

  1. Boas... Tenho uma aplicação desenvolvida por mim em c#.NET em que liga a um servidor onde se encontra uma base de dados postgreSQL, se essa aplicação correr num SO windows xp funciona na perfeição mas ao tentar correr essa aplicação num SO windows vista nao se consegue ligar ao servidor. Sera que alguem sabe o que esta a originar este erro?
     
  2. joao.miguel

    joao.miguel Power Member

    Que erro dá ?

    A conta com que está a aceder tem as devidas permissões para aceder á BD ? Não esquecer que o vista está muito mais seguro que o XP.
     
  3. o erro que que dá é "o anfitriao ligado não respondeu"!

    eu ja instalei no vista pgadmin3 no qual fiz a ligação á base de dados que esta no servidor e conseguiu liga, so nao liga atraves da aplicaçao.
     
  4. SoundSurfer

    SoundSurfer Power Member

    Vê se a firewall do Vista não está a bloquear o porto do SQL.
     

  5. Ja verifiquei e ela encontra-se desligada, tem é a firewall do panda mas ja dei as permissoes necessarias na firewall
     
  6. madcat1990

    madcat1990 Power Member

    a firewall do panda tem problemas xD tive uma vizinha que nao podia aceder a internet por causa dessa firewall xD
     
  7. Mas o problema não é dessa firewall, ja experimentei com ela desligada e mesmo assim não consegui aceder. Penso que o problema está em algum definiçao que me passou ao lado ou algum conflito do vista com a framework .net 1.1, ou devido a uma dll (npgsql) que utilizo para fazer a ligação á base de dados. Ja pesquisei no google mas nao consigo chegar a nenhuma solução!
     

Partilhar esta Página