1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Net em Ubuntu com modem Huawei SmartAX MT882

Discussão em 'Novidades GNU/Linux & *nix World' iniciada por HecKel, 2 de Março de 2006. (Respostas: 21; Visualizações: 1852)

  1. HecKel

    HecKel The WORM

    Boas!

    Tal como o titulo indica, pretendo aceder à net pelo ubuntu usando este modem. Para quem não conhece este modem é um "pequeno" hub e a sua ligação ao pc é por ethernet.

    Pedi ajuda ao pessoal nesta thread, mas visto já estar a fugir uma beca ao ambito do assunto da thread achei que seria mais apropriado criar uma nova thread especificamente para este assunto, assim pode ser que ajude mais gente ;)

    Na thread que indiquei o Alph deu-me umas dicas bacanas, no entanto continuei sem conseguir ligar-me :( Alguém tem alguma ideia do que possa ser?

    abraços, HecKel
     
  2. souto

    souto To fold or to FOLD?

    epá, se o modem é ethernet, o problema não deve residir no modem, mas sim na placa de rede. faz ifconfig e vê se tens a interface ethX sendo X um numero.

    cumprimentos.
     
  3. JPgod

    JPgod Moderador
    Staff Member

    Eu consegui configurar isso logo na instalação :D Foi só por os IP's e já estava a trabalhar ;)
     
  4. HecKel

    HecKel The WORM

    O problema não está no modem, nem na placa, tanto que tenho o modem a funcionar correctamente em windows! Simplesmente não consigo meter a net a bombar em linux :(

    abraços, HecKel
     
  5. falco

    falco Power Member

    Pá descreve o problema... O que escreveste no outro post é no mínimo confuso, ainda não percebi qual o real problema.

    Já agora os speedtouch funcionam bem em GNU/Linux...
     
  6. HecKel

    HecKel The WORM

    Bem.

    Basicamente comprei este modem(hub) e tenho-o devidamente configurado tanto que consigo ter net em windows sem qualquer problema, para aceder à net tive que alterar as propriedades da ligação de rede definindo o hub como gateway (isto tudo em windows), suponho que para aceder à net em linux seja algo similar, no entanto não estou a conseguir obter resultados.

    Para ser mais sucinto, o hub liga-se à net e o pc recebe net pelo hub e tenho de "dizer" ao sistema operativo que tem de "receber" net pelo hub.

    Sobre a sugestão dos speedtouchs, eu tenho um speedtouch e não é assim tão bonitinho como parece, se eu quiser instalar gentoo tenho de ter uma ligação à net e com o speedtouch tenho que alterar/sacar muitas coisas antes, no entanto este problema é facilmente resolvido com um modem de entrada ethernet (como é o meu caso), só tenho de dar a instrução ao SO que tem de receber net do hub.

    abraços, HecKel
     
  7. hellaxe

    hellaxe Power Member

    O modem são faz dhcp?
    Creio que sim. Só tens de entrar na configuração do modem e activares o dhcp.
    Se estou enganado desculpa qq coisita.
     
  8. jamper

    jamper I quit My Job for Folding

    Heckel quando dizes hub queres dizer router ou é mesmo hub?
     
  9. HecKel

    HecKel The WORM

    agora deixaste-me a pensar..., mas após umas pesquisas no google..., cheguei à conclusão que é router :X sorry a má informação :005:

    abraços, HecKel
     
  10. TuxBoss

    TuxBoss Power Member

    dhclient ethX (em que X é o numero da iface que queres configurar) (já agora vê se é mesmo dhclient, pq por exemplo no Debian é dhclient3 noutros e dhcpcd, etc).
     
  11. HecKel

    HecKel The WORM

    :(

    O que fiz mal agora? Tive a ver a manpage..., mas fiquei na mesma... :( como indico a gatway, ou não é necessário?

    abraços, HecKel
     
  12. jamper

    jamper I quit My Job for Folding

    tu dizes que esse modem é um mini router... sabes o ip do modem? ou nao tem? se nao souberes tenta por no gateaway 192.168.1.1 ou se nao der poe 192.168.0.1
    se não resultar experimenta por o ip da tua placa de rede no gateaway
    para saberes qual é o teu ip faz ifconfig eth0
    espero q te ajude o pouco que sei...
     
  13. HecKel

    HecKel The WORM

    Bem, quando configurei em win tive de ir às propriedades das ligações de rede (lan) e onde diz TCP/IP tive de preencher da seguinte forma:

    Endereço IP: 192.168.1.2
    Mascara de sub-rede: 255.255.255.0
    Gateway predefinido: 192.168.1.1

    (mais dns's do isp)

    abraços, HecKel
     
  14. TuxBoss

    TuxBoss Power Member

    Tens um de dois problemas (podem ser considerados 3 mas fiquemos pelos dois).
    1) O router ou não tem um servidor de dhcp integrado ou está desligado (o facto de teres de configurar a ligação do windows puxa para este)

    2) A tua placa placa de rede pode ter algum problema com o driver no linux (extremamente raro mas possivel, em centenas de installs e de box's que mexi só vi acontecer 2 vezes, uma o hotplug no install escolhia o driver errado ,por acaso foi no gentoo (2004.0...oh the irony :lol:) e outra foi um conflito de IRQ's no meu portatil na qual tive de criar um boot sem acpi e sem apic pq com eles ficava com o IRQ da placa em conflito com outro qq q nunca descobri qual era)

    Possiveis soluções:

    1) Vê a situação do dhcp server no router, caso não exista procura como configurar o iface para ter um ip estático.
    2) Procura no google pelo modelo especifico da placa a ver se alguém tem problemas semelhantes, normalmente se tiverem é meio caminho para o problema estar resolvido.
     
  15. HecKel

    HecKel The WORM

    /me assobia....

    DHCP Server Disabled

    Vou tentar agora...

    tnks, ;)

    HecKel
     
  16. hellaxe

    hellaxe Power Member

    Como está isso?

    O Ubuntu tem no administration ->networking-> "a tua placa" forma de configurares isso em GUI. É só pores em dhcp que o bixo resolve tudo, pelo menos a mim resolve.

    Se dizes que o modem tem dhcp server é só ligá-lo que o gajo começa a bombar e não tens de te preocupar mais.


    Agora se quiseres fazer port forwarding para pastar com máximo ID tens de meter isso com ip estático. A configuração podes fazê-la no mesmo que disse anteriormente.

    Eu acho que é simples de configurar.
     
  17. HecKel

    HecKel The WORM

    tentei..., mas ao meter o dhcp ligado a luz de indicação de "link" não voltou a acender..., ou seja..., nada de adsl... :( não funcou :(

    Fiz agora essa pergunta no ubuntuforums.org a ver o que me dizem...

    vou tentar fazer o k dizes agora..., mas só amanhã :( tenho que bazar agora e só volto à noitinha mesmo.

    tnks ;)

    abraços, HecKel
     
  18. xiserre

    xiserre Power Member

    Não percebo muito de linux, mas tenho Kubuntu a correr com Windows e tambem comprei o router da Clix. A partir do momento que consegui pôr a net a trabalhar com Windows, instalei o linux e ficou logo a trabalhar. Se não conseguires mais nada, tenta reinstalar o linux. Comigo resultou... Não ajuda muito, mas...
     
  19. HecKel

    HecKel The WORM

    por acaso até ajuda e muito..., foi mesmo isso que me responderam no fórum do ubuntu....

    disseram-me que é mais fácil do que configurar...., pena não ter uma cópia do cd de instalação na terrinha :( vai ter de ficar para o próximo fim-de-semana...

    abraços, HecKel
     
  20. TuxBoss

    TuxBoss Power Member

    Eis pq odeio essas distros ditas "user friendly", preferem tratar os users como retardados do que explicar como funcionam as coisas.

    http://easylinux.info/wiki/Ubuntu_pt#Como_activar.2Fdesactivar_as_liga.C3.A7.C3.B5es_de_rede.3F
     

Partilhar esta Página