1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Outra vez o GCC 4.0

Discussão em 'Programação' iniciada por ngm, 5 de Dezembro de 2006. (Respostas: 9; Visualizações: 747)

  1. ngm

    ngm Power Member

    Boas,

    Instalei o GCC 4.0 + Eclipse + CDT em OSX.

    Tudo OK.

    O problema é que sempre que tento compilar um projecto que invoque header files da biblioteca standard (iostream.h, string.h,...) aparece uma mensagem de erro indicando "file or directory not found".

    E de facto não encontra, porque o GCC não instalou esses headers! Alguém sabe como solucionar o problema?
     
  2. daminufe_tig

    daminufe_tig Power Member

    instala-os tu!! podes fazer assim!! :)
     
  3. ngm

    ngm Power Member

    Bem, com o devido respeito, mais valia estares calado!

    Fazendo uma analogia com alguém que te encontra na rua e te pergunta "Onde fica o hospital?" tu respodes: "Encontra-o! É fácil!" Há cada um!

    Anyway... problema resolvido!
     
  4. jaac

    jaac Power Member

    Problemas no INCLUDE?

    Quando compilas podes sempre passar o directório onde estão os headers com o -I/path

    Em mac os x é o /usr/include
     
    Última edição: 5 de Dezembro de 2006
  5. ngm

    ngm Power Member

    Obrigado jaac...

    O /usr/include já estava linkado... o problema é que não existiam os headers nesse directório.

    Para resolver o problema tive que instalar o Mac OS X SDK (que por sua vez, encheu o /usr/include com os headers necessários).
     
  6. Simao

    Simao Power Member

    Hum eu instalei o xcode que ja veio com essas libs tdas
     
  7. ngm

    ngm Power Member

    Quem instalar o Xcode na totalidade fica com todas as libs que necessita e mais algumas...

    Mas convenhamos... ocupar 3GB com uma suite para só se utilizar 5% é um grande desperdício de espaço!
     
  8. jaac

    jaac Power Member

    Tens que escolher melhor as bibliotecas, consegues reduzir esse valor.

    Além disso devias fazer um test-drive ao cocoa vale a pena :)
     
  9. ngm

    ngm Power Member

    Escolher melhor as bibliotecas? Mas escolhidas era impossível!

    Eu não instalei o Xcode na totalidade... apenas o GCC e o SDK, ou seja o mínimo dos mínimos para que as aplicações *básicas* que pretendo desenvolver fossem compiladas sem problemas!

    Quanto ao Cocoa:

    Não é, do todo, o mais adquado para mim.

    Para além disso... todo o meu grupo de trabalho utiliza o Eclipse e portanto será melhor funcionarmos com o mesmo IDE.
     
  10. sapropel

    sapropel Power Member

    se queres iostream, queres c++
    tudo o que seja standard c++ com .h está deprecated há anos!
    usa <iostream> <string> etc
     

Partilhar esta Página