1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.
  2. A secção Microsoft/Windows encontra-se actualmente em processo de reestruturação.
    Remover anúncio

Problema Partilhar impressora entre Win7-WinXP

Discussão em 'Windows 7 e anteriores' iniciada por Z3D, 16 de Junho de 2009. (Respostas: 9; Visualizações: 1896)

  1. Z3D

    Z3D Power Member

    Boas amigos,

    ok isto pode parecer um problema ridiculo, algo já aqui falado e respondido N vezes (ou não), mas na realidade não estou a conseguir dar volta a isto... passo a explicar.

    Tenho um desktop e um portatil e pretendo partilhar a impressora ligada ao desktop, para que possa imprimir documentos a partir do portatil. Ambas as máquinas estão ligadas ao mesmo router via wi-fi.

    No desktop tenho instalado o Win7 x64, com a impressora ligada e a funcionar (drivers x64 instaladas)

    No portatil tenho instalado o WinXP x86, com a drivers da impressora x86 correspondentes. Já testei a impressora ligada ao portatil e tudo ok.

    Agora começa o problema:
    Faço a partilha da impressora no Win7, certifico-me que ambos os PCs estão no mesmo workgroup. Ambos os PC's conseguem identificar-se mutuamente na rede, portanto parece-me tudo ok no que toca à rede.

    Vou ao portatil (WinXP) e tento adicionar uma impressora de rede, abre-me a janela de configuração passo-a-passo, e encontro a impressora que pretendo adicionar instalada no desktop. Quando dou o OK para adicionar, o WinXP pede-me as informações do controlador .INF.
    Eu julguei que não fosse necessário já que já tinha instaladas as drivers da impressora neste portatil, mas depois lembrei-me que a impressora está "hospedada" no Win7 que é x64...

    Mesmo assim, tentei dar-lhe o .INF das drivers x86 já instaladas, e dá-me erro dizendo que não consegue instalar, ou algo parecido.

    Fui sacar as drivers x64 ao site do fabricante, descompactei no portatil, fiz todo o procedimento anterior de adicionar impressora de rede, e procurei o .INF x64 correspondente quando me foi pedido. Same luck, no luck...

    Isto deve ser uma estupidez de um promenor de caca, mas está-me a falhar!! E não tou a dar a volta...

    Alguém me ajuda?

    Obrigado!
    Z3D
     
  2. vascorama

    vascorama Power Member

    Quando escolhes "Partilhar a impressoa" no host(win7) ele não pergunta como queres gerir os controladores dos pc cliente?
     
  3. Z3D

    Z3D Power Member

    Ok, ca vai as prints no WIN 7:

    Nesta primeira é as Propriedades da impressora (uma multifunções Canon MP500)
    [​IMG]




    Experimentei carregar no botão "Additional Drivers", e escolhi a opção X86 (a amarelo). De seguida fiz OK.

    [​IMG]




    [​IMG]
    Aparece uma janela para procurar o .INF. Clicquei no botão "Browse..."


    [​IMG]
    Escolhi o .INF do driver da impressora (o outro é do scanner pois é multifunçoes)

    Faço OPEN, e dá-me este erro...

    [​IMG]



    Já experimentei o -INF para x64 e nada....
    Este erro tb acontece no portatil quando tento adicionar o controlador x86 ou x64 ao instalar a impressora de rede.

    Ja nao sei o que fazer...
     
    Última edição: 20 de Junho de 2009
  4. Z3D

    Z3D Power Member

    Alguma alma caridosa por aí?
     
    Última edição: 20 de Junho de 2009
  5. vascorama

    vascorama Power Member

    Boas, mas esta imagem:

    [​IMG]

    é do pc que a tem ligada fisicamente, correcto?
    vamos por partes, tens firewall adicional? anti-spyware, qq coisa que possa estar a bloquear a comunicação?
    nas definições de rede, tens o perfil "casa" ou "trabalho" ou "local público"?


    edit: btw, o imageshack demora muito a abrir as imagens...o photobucket é melhor.


    edit2: experimenta lá estas drivers a ver...:

    http://www.sendspace.com/file/vlxckw
     
    Última edição: 17 de Junho de 2009
  6. Z3D

    Z3D Power Member

    Boas,

    essas imagens foram tiradas no PC host (Win7 x64), tem a impressora ligada fisicamente.

    Não tenho firewall sem ser a nativa do windows, mas como disse no outro post ambos os Desktop e portatil conseguem "ver-se", estão ligados ao mesmo network, com o mesmo nome "WORKGROUP".
    Como se vê o perfil? Não tenho a certeza, mas julgo que está definido como "casa". (neste momento estou no trabalho, logo mais confirmo)

    PS: como consegues meter a imagem dessa forma? Já tentei e nao consigo, aparece sempre como um thumbnail...

    edit: confirmo, está em home network
     
    Última edição: 18 de Junho de 2009
  7. Z3D

    Z3D Power Member

  8. Z3D

    Z3D Power Member

    Oi!

    continuo com o mesmo problema :005:
    Pelo que me parece o problema não é da ligação w7-xp por rede, pois ambos os pcs "pingam-se", alem de que consigo partilhar pastas e ficheiros entre ambos,

    Alguem me pode ajudar?
     
  9. vascorama

    vascorama Power Member

    Tens de instalar as drivers no portátil com o XP, e só depois procurar a impressora.
    Aconteceu-me o mesmo há dias.
     
  10. Z3D

    Z3D Power Member

    sim, mas isso já o tinha feito. (ate ja tentei com as drivers x64, mas claro que no xp isso não funciona, foi mm desespero)
     

Partilhar esta Página