1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

PHP Form Method POST

Discussão em 'Programação' iniciada por Ayato, 8 de Agosto de 2006. (Respostas: 7; Visualizações: 2983)

  1. Ayato

    Ayato Power Member

    Vocês já devem tar fartos de mim mas como não tenho assim nenhum mestre com quem tirar dúvidas de PHP tenho de recorrer ao fórum, não confio nos ingleses xD! Passando à frente, é assim tenho estes dois códigos:

    PHP:
    <HTML>
    <
    head>
    <
    title>PHP Form</title>
    </
    head>
    <
    form enctype multipart/form-data" method="POST" action="php_2.php">
    <p>Nome <input type="
    text" name=nome size="30"></p>
    <p>Idade <input type="
    text" name=idade size="2"></p>
    <p>What's your favorite car?
    <select name=marca>
     <option>Ferrari</option>
     <option>Mercedes</option>
     <option>BMW</option>
    </select></p>
    <p><input type="
    Submit" value="OK"></p>
    </form>
    <p>
    </html>
    e

    PHP:
    <html>
    <head>
    <title>Result</title>
    <body>
    <?php
    echo "Welcome ".$_POST['nome'].", you've ".$_POST['idade']." and you like ".$_POST['marca'];
    ?>
    </body>
    </html>
    Estou a fazer estes exercícios de acordo com um livro tuga "Programação com PHP 4.3" de Carlos Serrão e de Joaquim Marques, de acordo com o livro a forma deveria ir dar na página php_2.php um código com o nome, idade e marca que foram introduzidos... mas isso não acontece.... Ajuda? Será por estar a fazer isto no localhost? Tem limitações? Thanks do vosso n00b favorito xD! Fiquem
    :x2:
     
  2. spastikman

    spastikman Banido

    estás a chamar ao segundo pedaço de código php_2.php ?
     
  3. Ayato

    Ayato Power Member

    sim, porquê, isso altera alguma coisa?:S
     
  4. machu

    machu Power Member

    esquceste-te especificar o BODY do ficheiro HTML e de fechar o HEAD no ficheiro php...se continuares com problemas especifica melhor qual o problema...

    abrc
     
  5. PandMonium

    PandMonium Power Member

    Olá,
    isso parece estar tudo correcto, tens tudo bem configurado na tua maquina? Apache e PHP a funcionar?
     
  6. PandMonium

    PandMonium Power Member

    Está lá, só que como está com letra preta, quem tem o theme original não ve o código a não ser que selecione tudo :P
     
  7. machu

    machu Power Member

    sim existe codigo html a preto e selecionando vejo-o bem mas continuo a nao ver aquilo que referi...tens a certeza que vez aquilo que referi? ~

    abrc
     
  8. PandMonium

    PandMonium Power Member

    sim faltam as tags de que falaste, de qualquer maneira funciona que experimentei agora.
     

Partilhar esta Página