1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

PostgreSQL ??????

Discussão em 'Novidades GNU/Linux & *nix World' iniciada por hellaxe, 17 de Abril de 2005. (Respostas: 14; Visualizações: 1706)

  1. hellaxe

    hellaxe Power Member

    Relacionado com a thread do evaristo, tentei instalar o postgresql no Ubuntu 5.. que pelo que vasculhei no synaptic não tinha instalado. Como não consegui ver se estava nos repositórios saquei do site deles e tentei instalar.
    Mas acontece uma coisa engraçada que é depois de se fazer "./configure" manda fazer "gmake" e não dá nada. Procurei na net e a resposta que obtive é que era o GnuMake e isso já está instalado pq é o "make".
    O Evaristo só trabalha bem com esta bd, pelos vistos.

    Será que podem ajudar?

    Thanx
     
  2. xtr3me

    xtr3me Power Member

    o evaristo só bomba bem com postgreSQL?
    duvido seriamente.
    outra coisa estranha é não teres encontrado o deb para instalares o postgreSQL.
    faz apt-get update para ele fazer o update ao apt, e dps procura o pacote outra x.
    Acho isso mto estranho.

    para procurares o postgres vai ao terminal e escreve apt-cache search postgreSQL e vê se ele retorna alguma coisa.
     
  3. hellaxe

    hellaxe Power Member

    Nas Faq's é o que diz.
     
  4. xtr3me

    xtr3me Power Member

    acabou de descer bastante na minha consideração :005:
     
  5. hellaxe

    hellaxe Power Member

    o que me dá depois de fazer o apt-cache é isto:

    [email protected]:/home/axe # apt-cache search postgresql
    libpq3 - PostgreSQL C client library
    python-pgsql - A Python DB-API 2.0 interface to PostgreSQL v7.x
    python2.4-pgsql - A Python DB-API 2.0 interface to PostgreSQL v7.x

    mas isto tenho instalado.

    Será que ele não vai aos sites do repositório e sim ao meu cd virtual?
     
  6. xtr3me

    xtr3me Power Member

    tens de ver como tens o sources.list e o apt configurado.
    Como configuraste na instalação? Configuraste um ftp ou instalaste tdo do cd?
     
  7. Nemesis11

    Nemesis11 Power Member

    Como é que tens o sources.list?

    Eu estou a vê-lo

     
  8. hellaxe

    hellaxe Power Member

    Ok Nemessis. tinha problemas na sources.list.

    Mas o problema abaixo mantem-se, e agora gostava de saber como resolver esta questão do gmake.

     
  9. acrobat

    acrobat Power Member


    o evaristo trabalho com Bases de Dados que suportem transacções e stored procedures

    por exemplo : oracle , db2,sqlserver, pointBase etc
     
  10. hellaxe

    hellaxe Power Member

    Bolas!!!!!!!!! não consigo fazer o apt-get do postgresql.

    Dá sempre problemas na ligação ao servidor.
     
  11. hellaxe

    hellaxe Power Member

    Não sabia se devia colocar esta na thread do Evaristo ou nesta mas aqui deve estar correcto.

    É o seguinte: no Ubuntu fiz por apt-get a install do postgresql 7.4.
    Como tinha sacado do site deles o 8.xxx resolvi ver como instalava aquilo. depois de partir um pouco de pedra lá foi direitinho.
    Agora tenho 2 instalados e como isto na é windoze que faz tudinho, não sei como hei-de fazer para direccionar para a instalação do 8.xxx. Já li no site deles e não pareceu dizer como se faz.
    Isto para mim é importante porque pode resolver as dúvidas em geral que tenho de como instalar novo software ou actualizações e pô-las a funcionar.
    Eventualmente isso está escrito algures mas nem no livro que tenho nem em lado algum li como se faz.

    Thanx
     
  12. hellaxe

    hellaxe Power Member

    UPDATE da coisa:

    Isto é esquisito: instalei pelo menos 3 vezes o dito cujo no Ubuntu 5.04 que está numa VMWare.
    Fica a funcionar bem.
    Depois de desligar a VM quando volto a entrar o serviço não está activo nem aparece no "/etc/init.d" para fazer start. Tudo o resto está na directoria "pgsql" mas a sub directoria "Data" não se deixa ver (no nautilus tem uma cruz se tentar abrir desaparece).
    Estou perdido.

    Agradecido pela ajuda antecipadamente :D


    EDIT - RESOLVIDO - Depois de Ler o manual no capitulo 16.3 cheguei algumas conclusão interessantes. Isto já funciona.
     
    Última edição: 20 de Maio de 2005
  13. pedrotuga

    pedrotuga Power Member

    Resolvi ressuscitar este ópico pois vou ter que usar postgresql.

    Ora bem... já estava habituado ao mysql, que agora até suporta transações, mas vou mesmo ter que mudar pois na faculdade não me deixam lá usar o mysql p um trabalho.

    Heis as minhas duvidas existenciais... depois de tanto tempo c istodo mysql... até já me tinha habituado a ver o mysql como o parceiro ideal do php... vou ter k me abituar ao postgres...
    vou instalar o postgres no windows?
    Aquilo vem com uma consola facil de usar como o mysql? Qual é o comando que tenho que inserir para abrir uma consola pgsql com o user root no localhot? como é que se chama a aplicação (consola)? há alguns frontends tipo mysqladministrator e mysqlquerybroser ou mysqlfront?
     
  14. tambem tenho esse problema...
    :smilliex:
     
  15. hellaxe

    hellaxe Power Member

    Qual a distribuição que estás a usar?

    Segundo me recordo tinha de instalar umas libs de *dev não me lembro quais.

    Se estiveres a usar Ubuntu:
    Código:
    sudo apt-get install build-essencial
    Creio que vai resolver a questão.
     

Partilhar esta Página