1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Probelemas com instalação de webspell

Discussão em 'Web Development' iniciada por Soad92, 1 de Fevereiro de 2009. (Respostas: 12; Visualizações: 851)

  1. Soad92

    Soad92 Power Member

    Boas,

    Estou a tentar instalar o webspell no meu website, ja fiz upload dos ficheiros e agora existe um pequeno problema... apareceme este erro

    Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'soad92'@'localhost' (using password: YES) in /home/massityg/public_html/webs/install/step06.php on line 100
    ERROR: no connection to mysql

    Já exprementei por tudo com CHMOD 777 mas não funciona se estiver assim... já exprimentei por apenas os programas que ele me diz com CHMOD 777, e já confirmei e a password e o user e a db esta certo.... Alguém me pode ajudar?

    Cumps
     
  2. Santo38

    Santo38 Power Member

    Chegaste a dar permissões ao user para aceder à base de dados?
     
  3. REEF^

    REEF^ Power Member

    não dêz 777 em tudo. ve no readme.txt que vinha junto com o webspell qual é os fixeiros que tens de dar 777. diz lá! e dá a permição só nesses que o webspell as vezes atrofia
     
  4. SeventhDoor

    SeventhDoor Power Member

    O Host do Mysql é mesmo localhost? Na maior parte dos free host's as bd's estão alojadas em máquinas diferentes.
     
  5. Soad92

    Soad92 Power Member

    O meu não é free-host...
     
  6. geoblast

    geoblast Power Member

    Podes por aqui os strings de ligação à bd??
     
  7. Soad92

    Soad92 Power Member

    Como faço isso?
    Eu criei DB pelo Cpanel... MySQL
     
  8. geoblast

    geoblast Power Member

    E no php, como é que fazes a ligação??
     
  9. Soad92

    Soad92 Power Member

  10. geoblast

    geoblast Power Member

    Sim. Algures no teu código, deve haver um função ou uma classe que ligue ao mysql (não conheço o webspell, por isso não sei como é nem onde é), mas, nessa ligação convinha verificar se os dados utilizados estão correctos.
     
  11. Soad92

    Soad92 Power Member

    Epa não sei... não percebo muito disto... O que eu faço é: upload dos ficheiros pelo FTP para a pasta public_html e depois meto no site a pasta e aquilo lança a instalaçao...
    Claro, no meio disto tudo mudo o CHMOD e crio a DB e o user.
     
  12. REEF^

    REEF^ Power Member

    adicionaste o user a bd ? que erro te dá em concreto ?
     
  13. REEF^

    REEF^ Power Member

    adicionaste o user a bd ? Faz o que disse anteriormente, revê as permissões do CHMOD. Mete a permissão CHMOD 777 apenas nos ficheiros que diz no readme.txt que vêm junto do webspell.
     

Partilhar esta Página