1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Problema - 3D Blaster Savage 4 - Ressuscitar máquina antiga

Discussão em 'Dúvidas e Suporte Técnico PC' iniciada por Rexobias, 22 de Agosto de 2008. (Respostas: 11; Visualizações: 904)

  1. Rexobias

    Rexobias Power Member

    Olá malta.

    Bem, vou começar por explicar toda esta situação/problema que me faz escrever este pedido de ajuda. A minha 1ª máquina foi um Pentium 200 MMX que tinha uma gráfica S3 Virge.

    Com o passar do tempo acabei por trocar a gráfica para uma 3D Blaster Savage 4 PCI de 32 Mb (muito boa na altura, pelo menos respondeu na perfeição a todas as minhas necessidades em videojogos). Após isto, e passados alguns meses obtive uma Voodoo 2, pois o efeito 3DFX, na altura, era fantástico.

    A máquina trabalhou sempre bem, mas obtive um PC mais recente e coloquei o antigo de lado, tendo por ele um amor especial (1º PC). De vez em quando exprementava o bixo e ele corria bem, até que num triste dia este deixou de trabalhar - Motherboard queimada.

    Na semana passada ofereceram-me um PC velho praticamente igual ao meu antigo (até a caixa era igual fora a parte frontal) que tinha algumas peças pifadas. A verdade é que aproveitei e combinando as duas máquinas consegui recuperar a minha torradeira. A máquina ficou a funcionar na perfeição, e instalei o velhinho Windows 98.

    O problema estranho veio depois.

    Após a instalação do Windows só falta-me instalar as drivers de dois hardwares, a 3D Blaster Savage 4 e a Voodoo 2, situação que eu tinha conhecimento do passado.

    Prosegui á instalação deste Hardware com os CD's de instalação que tinha por aqui. Começei por instalar a Savage 4. Após a instalação o PC tem que ser reiniciado. O que acontece é que após mostrar aquela imagem a dizer Windows 98 durante o boot, no momento em que devia entrar no Windows fico com o ecra a preto e com o pointer de relógio de areia do rato no centro do ecrâ, e não sai mais daqui.

    Após reiniciar o PC com o botão frontal ou com a combinação neste ecra ctrl+alt+del, entro em modo de segurança e entro na máquina. Sou obrigado a desinstalar através do "Adicionar/Remover Programas" o software da Savage 4 para poder conseguir voltar a entrar no Windows.

    Já exprementei com a Savage 4 em outros slots PCI, já exprementei com a Voodoo 2 removida e não há nada a fazer, sempre que instalo as drivers da Savage 4 o sitema fica bloqueado no tal screen e só consigo aceder ao Windows após remover as drivers em modo de segurança.

    Após ler o Readme da instalação (coisa que raramente faço) descobri o seguinte:

    " B. System is suspended after Windows splash screen (AGP card only)
    -------------------------------------------------------------------
    Certain systems may be suspended ('system hang') after the
    Windows splash screen is displayed. You may see just a black
    screen with the hourglass mouse pointer.
    When the above happens, do the following:
    1. Restart Windows in Safe mode.
    2. Run the BlasterControl application.
    3. Open the BlasterControl Properties dialog box.
    4. Click the Tweak icon.
    5. In the Tweak module, clear the "Sideband protocol" check box.
    6. Click the OK button in the BlasterControl Properties dialog box.
    7. Restart Windows in Normal mode.
    The system should run smoothly now."

    O problema é exactamente este, só que exitem dois novos problemas:
    -No titulo refere "AGP Only", e a minha Savage 4 é PCI;
    -É impossivel aceder ao BlasterControl pois este é uma applet que é carregada nas Propriadades de Visualização (botão direito do rato no Desktop -> Propriadades). Mesmo tentando abrir o software na origem (pasta Windows\System) o mesmo não é carregado.

    Tenho que referir por último que após a tentativa de instalação das Drivers da Savage 4 e respectiva desinstalação em modo de segurança (não tenho outra hipótese se quero entrar no Windows), no Gestor de Dispositivos a gráfica aparece como Savage 4 (e não como Placa PCI padrão como aparecia após a instalação do Windows), mas tem o simbolo de conflito (problema com o controlador).

    -------------------------------------------------------------------

    Saltando a fase do problema, estive a procurar na Internet eventuais soluções como estas:
    -Aceder ao BlasterControl em modo de segurança (impossivel para mim);
    -Alterar uma opção na BIOS chamada Byte Merge - Infelizmente não tenho isso na minha BIOS.

    Olhando com atenção para a situação e sabendo que o problema não é da Voodoo 2 (já instalei o seu software e não tive nenhum problema), nem do Windows 98 (já exprementei colocar o Millenium - não gozem) o problema só pode ser a Savage 4 e um conflito nas suas drivers, mas ...

    No passado não tinha este problema, era só instalar a gráfica e estava feito. A única coisa que mudou no hardware foi a MotherBoard. Será alguma incompatibilidade com esta?!
    De certeza que o problema está na Board ...

    Sei que provavelmente ninguém me poderá ajudar tendo em conta diversos factores, mas usando os vossos conhecimentos na matéria o que acham que pode ser?!

    ----------------------------------------------------------

    Aproveito também para fazer um pedido, embora saber que aqui não é o local indicado. Caso não descubra o problema, a substituição da gráfica será uma opção.

    Estamos a falar de gráficas muito antigas, por isso pergunto a voces meus caros amigos senão têm aí na vossa sucata uma gráfica com uma capacidade pelo menos igual á 3D Blaster Savage 4 32 Mb, que seja PCI e possa ser usada neste Pentium 200 MMX.

    Ouvi falar de umas GeForce para PCI (as primeiras) e lembro-me das Voodoo 3 ... mas infelizmente não encontro nenhuma.
     
  2. Crusher

    Crusher Power Member

    Pelo sim pelo não, essa motherboard que colocastes têm a BIOS actualizada não têm?

    Quanto à outras gráficas PCI que enumerastes... sim existem mas são difíceis de arranjar. Eu próprio tive uma GF2 MX PCI.

    Acho que só procurando em leilões. Mas no geral deves contar com preços um pouco mais inflacionados.
     
    Última edição: 22 de Agosto de 2008
  3. Rexobias

    Rexobias Power Member

    Por acaso não tem a BIOS actualizada :S mas ... também não sei qual o modelo da mesma. Qual o software a usar para saber ao certo que Board é, e que seja compativel com Win98?!

    Tenho o Everest, mas não há nada mais prático, rápido e leve?!
     
  4. Crusher

    Crusher Power Member

    Sisoft Sandra? Mas tenta ver se encontras alguma versão mais antiga.

    Se não, eu penso que tenho alguns CDs antigos de software que vieram com revistas e certamente que têm uma versão do Sandra mais compatível.
     
  5. Rexobias

    Rexobias Power Member

    Crusher, também já pensei em usar umas driveres que não as da Creative.

    Algum tempo atrás (4/5 anitos) encontrei na Internet umas drivers bem porrerias não-oficiais para esta gráfica, usei as mesmas e eram exelentes. Pode ser que funcionem desta vez, o problema é que não encontro em lado nenhum as tais drivers. Já perdi a tarde toda em pesquisas, forums e afins, e nada :S

    Se quiseres ajudar a encontrar as tais drivers não-oficiais, ou mais alguém, a placa é esta:

    Creative 3D Blaster Savage 4 32MB PCI

    P.S: Vou testar a Sandra :D
     
  6. Crusher

    Crusher Power Member

    Esgalha a Sandra. :D

    Já agora não tinhas nenhuma placa PCI colocada para além da gráfica pois não? E como estão os IRQs? O IRQ da gráfica está a partilhar com outro?
     
  7. Rexobias

    Rexobias Power Member

    Bem, acabei por usar o Everest, lol. Preferia a Sandra, lol, mas paciência ...

    Já sei qual a Board que a minha máquina tem:

    Ability MB-586TXA com um Chipset Uli/ALI M1531 e a BIOS é uma da AMI (American Megatrends)

    Onde poderei encontrar com confiança uma BIOS mais actual para a Board?!

    As únicas placas que estão colocadas além da gráfica são a de som (Sound Blaster Live 16 Value) e a Voodoo 2. Já olhei para os IRQ e está tudo em auto. O problema parece-me ser mesmo uma incompatibilidade lixada com a Board :S

    As minhas únicas esperanças neste momento são:
    -Update da Bios da Board;
    -Drivers não-oficiais;
    -Gráfica nova que seja compativel.
     
  8. Rexobias

    Rexobias Power Member

    Acabei de fazer o Update da BIOS, e ... nada feito.

    O problema continua :S
     
  9. Crusher

    Crusher Power Member

    Sobre o IRQ não era bem isso. Tinhas que ver dentro do Windows a partir das Informações do Sistema ou usando um programa como o Everest para ver que recursos estão partilhados.

    Experimentas o seguinte: retiras essas placas PCI, e desactivas tudo o que for porta paralela, MIDI, controlador USB e porta de série. Depois vê se acontece o mesmo.

    Já experimentastes estes drivers?

    http://www.savagenews.com/?action=articles&article=8

    Se não der receio mesmo que a gráfica está a ser "gato bravo" com a motherboard. :-|
     
    Última edição: 23 de Agosto de 2008
  10. Rexobias

    Rexobias Power Member

    Infelizmente já estive n vezes nesse site e não consigo sacar nada ... links quebrados sempre :S

    Crusher, há pouco fiz o Update do firmware da gráfica (acabou por não resolver), e descobri uma coisa nova.

    Finalmente consegui entrar no Windows sem ter que recorrer á desinstalação das drivers no modo de segurança após a instalação das mesmas. Instalei as drivers e reiniciei. Após isto, o PC bloqueou ao entrar no windows (o tal ecra). Reiniciei e entrei no modo de segurança.

    Aí, nas Propriadades de Visualização\ Avançadas\ Resolução de Problemas desliguei a aceleração de Hardware.

    Reiniciei e não bloqueou, entrou no Windows e reconhece a gráfica. Infelizmente o programa Blaster Control (definições da gráfica) não é carregado, e assim não posso desligar o tal "Sideband Protocol" (acredito piamente que ao desligar este protocolo fica tudo resolvido - tendo em conta a descrição e solução da Creative).

    A partir daqui, o problema volta se:
    -Ligar a aceleração de hardware nem que seja só um traço;
    -Passar a Qualidade de cor para 256 cores ou maior - tenho que continuar nas 16 cores sempre.

    Estou mesmo para desistir e implorar a alguém aqui do fórum por uma gráfica PCI de 32 MB.
     
  11. Crusher

    Crusher Power Member

    Mesmo que o programa acabe por dar acho que não vais conseguir mexer no Sideband Adressing já que isso é uma função própria do AGP.

    Mesmo assim... porque não experimentas um outro programa de tweak? Deve haver alguma coisa perdida na internet que dê para mexer nessa opção ou noutra. Por exemplo porque não o Powerstrip?

    EDIT: Já agora o chipset da motherboard que avariou era diferente não era?
     
    Última edição: 23 de Agosto de 2008
  12. Rexobias

    Rexobias Power Member

    Penso que era diferente sim ... deve ser mesmo incompatibilidade ... enfim :S

    Acho que um primo meu tem uma Matrox de 32MB PCI ... vou pedir-lhe.

    Infelizmente deve ser mesmo incompatiblidade :S
     

Partilhar esta Página