1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Problema a instalar aplicação

Discussão em 'Dúvidas e Suporte Técnico - GNU/Linux & *nix' iniciada por Guycool, 13 de Junho de 2009. (Respostas: 15; Visualizações: 1478)

  1. Guycool

    Guycool Folding Member

    outro problema... agora da outro erro...
    Código:
    [email protected]:~$ cd Desktop
    [email protected]:~/Desktop$ cd sem*
    [email protected]:~/Desktop/semantik-0.6.4$ sudo ./waf
    WARNING:  == Scripting ==  Run waf configure first...
    [email protected]:~/Desktop/semantik-0.6.4$ sudo ./waf configure
    You are using Linux, that's good (tm) 
    WARNING:  == wscript_main ==  For now Semantik uses a few kde icons - if you have problems seeing the icons install kde
    Checking for program g++                : not found 
    Checking for program c++                : not found 
    g++ was not found 
    [email protected]:~/Desktop/semantik-0.6.4$ sudo ./waf
    WARNING:  == Scripting ==  Run waf configure first...
    
    Por isso e que nao gosto de ubunto so erros na consola

    e ja agora vejam o que diz no readme

     
  2. Underground909

    Underground909 Power Member

    Mas que raio estás tu a fazer?

    Esses programas que queres não estão nos repositórios?
     
  3. Guycool

    Guycool Folding Member

    vieram em .tar.bz e eu extrai...
    como e que se faz entao? sou noob...
     
  4. Underground909

    Underground909 Power Member

  5. Guycool

    Guycool Folding Member

    E que o problema e que eu nao consigo instalar nos repositorios eu fasso sudo ./waf configure
    e dame um erro qualuquer...
    deve ser preciso saber o codigo todo do linux para andar a instalar uma simples aplicacao como esta.
     
  6. Underground909

    Underground909 Power Member

    Leste sequer alguma coisa do link que eu dei?
     
  7. Red_Beret

    Red_Beret Power Member

    Mas o que é esse waf, afinal? Não existe nos repositórios do Ubuntu? Não existem repositórios 'externos' que tenham esse programa?

    Quanto ao dar um erro qualquer, não é um erro qualquer. Ele diz-te que não encontra o c++ e o g++, é questão de investigares o que são, e o porquê de não os encontrar.

    Não sei o que são esses c++ e g++, mas provavelmente são packages que precisam de estar isntalados na máquina, para conseguires instalar esse package (ou seja, dependências).

    Aliás, no 'readme' que tu postaste diz:

    Código:
    First, make sure that you have a Linux(tm) system (a *BSD system should do it too)
    * the KDE4 development packages must be installed (KDE4 >= beta4)
    * the Qt development packages must be installed (Qt >= 4.3)
    * Python with development headers must be installed (Python >= 2.4)
    Ou seja, tens de ter isso tudo instalado antes de fazeres o ./waf configure. Já validaste se tens isso tudo instalado?
     
    Última edição: 13 de Junho de 2009
  8. Guycool

    Guycool Folding Member

    li sim

    Open System → Administration → Software Sources and select Third Party Software.
    Click Add to add a new repository.
    Enter the APT line for the extra repository. This should be available from the website of the repository, and should look similar to the following:
    deb http://ftp.debian.org etch main
    Click Add Source and then click Close to save your changes.
    You will be notified that the information about available software is out-of-date. Click Reload.
    Packages from the new repository should now be available in your package manager.

    o meu e o kubunto nao tem a parte do system na barra
     
  9. Guycool

    Guycool Folding Member

    o waf e o ficheiro de instalacao do progrmaa que eu quero instalar e acabei de fazer download chamado kdissert que vinha com a extenssao .tar.bz extrai e foi a pasta a partir da consola e executei os comandos que estao no README como por exemplo ./waf e ./waf configure

    o ficheiro .deb que extrai deu erro logo na instalacao... abro o ficheiro deb com duplo clique e passados exactamente 1.5 segundos da erro
     
  10. Red_Beret

    Red_Beret Power Member

    acabei de validar e esse programa está disponivel no 'Adicionar/remover aplicações' do Ubuntu, por isso tb deve estar no do kubuntu.

    Não precisas de ficheiros nem de downloads para nada. vais lá, procuras pelo nome e ele instala sozinho

    Ou então, visto que queres complicar, faz:

    Código:
    sudo apt-get install kdissert
     
    Última edição: 13 de Junho de 2009
  11. Underground909

    Underground909 Power Member

    Os programas que o Guycool quer existem nos repositórios sim

    http://packages.ubuntu.com/jaunty/semantik
    http://packages.ubuntu.com/jaunty/kdissert

    Mas pronto, ele embirrou que quer à força compilar da source para poder dizer "ai isto do linux é tão difícil".

    O que é que se há-de fazer...
     
  12. Underground909

    Underground909 Power Member

    Isso é para adicionar um novo repositório, os programas que queres estão nos repositórios oficiais que vêm configurados por defeito (salvo erro, a componente universe vem activada). Não precisas de nada disso.
     
  13. Guycool

    Guycool Folding Member

    underground ja deu >D
    obrigado a todos >D
     
  14. Aparicio

    Aparicio /dev/mod
    Staff Member

    O erro é explícito, falta o g++, que não é nada mais que o compilador para compilar o source desse tal programa.
    Instalando o build-essential deve resolver isso, penso eu.
    De qualquer forma não fazia mal ler sobre este tipo de coisas para ao menos saber o que está a fazer.
     
    Última edição: 13 de Junho de 2009
  15. arpinacio

    arpinacio Power Member

    Pois, vim atrasado... faltam-te dependências que através do apt-get seriam instaladas...

    Conselho, usem primeiro o apt-get, se não der procurem por repositórios para tal, senão mandem-se para as compilações de sources...
     
  16. Guycool

    Guycool Folding Member

    o facto é que o ficheiro *.sh tem uma lista de commandos que são executados, para instalar o programa e uma delas era, provavelmente era o de compilar o programa com o comando gcc mas como deu erro nessa linha apareceu a menssagem "g++ was not found " e para resolver o problema, instalam o programa gcc para fazer esse mesmo commando funcionar, e dar continuação à instalação.
    Ok aqui fica um esclarecimento básico do que se passou para os que encontrarem o tópico.
     
    Última edição: 11 de Novembro de 2010

Partilhar esta Página