1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Problema com lightbox2 e objecto em flash

Discussão em 'Web Development' iniciada por cyber_monk, 1 de Julho de 2008. (Respostas: 2; Visualizações: 542)

  1. cyber_monk

    cyber_monk Power Member

    Boas!

    Estou a desenvolver um site em php, e para visualizar as imagens estou a usar o lightbox2, até aqui tudo bem, em firefox vejo as imagens com aquele efeito caracteristico do lightbox, o problema surge qdo vou ao IE (7) e visualizo a mesma imagem, aparece-me um objecto em flash ,que embora apareça na posição correcta, está a aparecer por cima da imagem e por cima de tudo, qdo na realidade deveria ficar atrás do efeito da imagem.

    Alguém me pode ajudar?

    Aqui está a imagem do que me aparece..

    [​IMG]
     
  2. m.costa

    m.costa Power Member

    Sim, o IE por defeito poe os filmes flash acima de tudo, nem o z-index ajuda ; o segredo e' meter o wmode dos objectos flash para transparent.

    Código:
    <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0" width="123" height="456">
      <param name="movie" value="ficheiro.swf" />
      <param name="quality" value="high" />
    [b]  <param name="wmode" value="transparent" />[/b]
      <embed src="ficheiro.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="123" height="456" [b]wmode="transparent"[/b]></embed>
    </object>
    
     
  3. cyber_monk

    cyber_monk Power Member

    Obrigadão, Problema resolvido pelo menos parece que sim.. :)
     

Partilhar esta Página