1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.
  2. A secção Microsoft/Windows encontra-se actualmente em processo de reestruturação.
    Remover anúncio

Problema no Windows Xp e no Avast

Discussão em 'Windows 7 e anteriores' iniciada por .:|EsPoNjAs|:., 11 de Abril de 2008. (Respostas: 10; Visualizações: 2233)

  1. .:|EsPoNjAs|:.

    .:|EsPoNjAs|:. Power Member

    Boas pessoal tou com uns problemas aqui :005:

    Acabei de formatar o meu disco e instalei o windows xp(original), instalei entretanto o antivirus avast e fiz o registo com uma key fornecida por eles.

    Até aqui tudo bem...

    O que acontece é que o avast agora não actualiza nem faz nada :s
    ao abrir da a seguinte mensagem: "avast!: o sub-sistema AAVM detectou um erro de RPC."

    ja saquei um novo ficheiro de instalação do proprio site do avast, pedi uma nova chave de registo e nada.

    Relativamente ao windows passa-se algo de muito estranho... deixo o pc ligado, ou mesmo quando estou a trabalhar nele, ele reinicia sozinho :S

    Alguem me consegue dar uma ajudinha?
    Obrigada ;)
     
  2. DarkButterfly

    DarkButterfly Power Member

    Isso de reiniciar sozinho, ou muito me engano, é virus.
    Se ainda não tiveres instalado o Hijackthis, faz o download e instala. E faz uma verificação e posta aqui o log. Logo se vê se há algo aí.

    Quanto ao avast. Tenta desinstalar com um programa próprio para desinstalar aplicações. Tens o Revo Uninstaller. É gratuito e excelente. No processo de desinstalação escolhe a última opção.
    Faz um novo download/pedido de licença.

    Instala novamente e insere a licença. Se o problema persistir, acho que o melhor a fazer é mudar de antivirus.

    Abraços.
     
  3. .:|EsPoNjAs|:.

    .:|EsPoNjAs|:. Power Member

    Ok obrigada. Desconhecia qualquer uma das aplicações que referiste. Vou experimentar e posto os resutados ;)
     
  4. .:|EsPoNjAs|:.

    .:|EsPoNjAs|:. Power Member

    será que me podias dar uma ajuda aqui com hijackthis? não estou a perceber nada disto pa.

    queres saber da melhor? o avast esta a bombar :D :lol:
     
  5. DarkButterfly

    DarkButterfly Power Member

    Folgo em saber que o avast já funciona.

    Quanto ao Hijackthis, fazes o seguinte.

    Abres e se abrir o Main Menu (como é suposto) escolhes a 1ª opção.

    No fim da verificação o Hijackthis vai abrir um ficheiro do bloco de notas com coisas escritas. Seleccionas tudo e colas aqui.

    Abraços.
     
  6. Jockey

    Jockey Power Member

    Já agora que andas em testes podes testar a memoria do teu pc com o memtest, deixa fazer duas ou três passagens, isso de ter erros aleatórios, cheira a erros de memoria....já agora porque é que tiveste de formatar o pc? e reinstalar de novo?

    Cumps
     
  7. .:|EsPoNjAs|:.

    .:|EsPoNjAs|:. Power Member

    Ora já fiz o que indicaste e aqui está o resultado. Penso que seja isto que te estavas a referir

    Logfile of HijackThis v1.99.1
    Scan saved at 0:35:25, on 13-04-2008
    Platform: Windows XP SP2 (WinNT 5.01.2600)
    MSIE: Internet Explorer v7.00 (7.00.6000.16640)

    Running processes:
    C:\WINDOWS\System32\smss.exe
    C:\WINDOWS\system32\winlogon.exe
    C:\WINDOWS\system32\services.exe
    C:\WINDOWS\system32\lsass.exe
    C:\WINDOWS\system32\svchost.exe
    C:\WINDOWS\System32\svchost.exe
    C:\Programas\Alwil Software\Avast4\aswUpdSv.exe
    C:\Programas\Alwil Software\Avast4\ashServ.exe
    C:\WINDOWS\Explorer.EXE
    C:\WINDOWS\SOUNDMAN.EXE
    C:\WINDOWS\system32\RUNDLL32.EXE
    C:\PROGRA~1\ALWILS~1\Avast4\ashDisp.exe
    C:\WINDOWS\system32\spoolsv.exe
    C:\WINDOWS\system32\ctfmon.exe
    C:\WINDOWS\system32\nvsvc32.exe
    C:\Programas\Alwil Software\Avast4\ashMaiSv.exe
    C:\Programas\Alwil Software\Avast4\ashWebSv.exe
    C:\WINDOWS\system32\wuauclt.exe
    C:\Programas\MSN Messenger\usnsvc.exe
    C:\Programas\Mozilla Firefox\firefox.exe
    C:\DOCUME~1\Tiago\DEFINI~1\Temp\Directório temporário 3 para hijackthis.zip\HijackThis.exe

    R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Page_URL = http://go.microsoft.com/fwlink/?LinkId=69157
    R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Search_URL = http://go.microsoft.com/fwlink/?LinkId=54896
    R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896
    R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page = http://go.microsoft.com/fwlink/?LinkId=69157
    R0 - HKCU\Software\Microsoft\Internet Explorer\Toolbar,LinksFolderName = Hiperligações
    O2 - BHO: AcroIEHlprObj Class - {06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - C:\Programas\Adobe\Acrobat 5.0\Reader\ActiveX\AcroIEHelper.ocx
    O2 - BHO: (no name) - {7E853D72-626A-48EC-A868-BA8D5E23E045} - (no file)
    O2 - BHO: Windows Live Sign-in Helper - {9030D464-4C02-4ABF-8ECC-5164760863C6} - C:\Programas\Ficheiros comuns\Microsoft Shared\Windows Live\WindowsLiveLogin.dll
    O4 - HKLM\..\Run: [SoundMan] SOUNDMAN.EXE
    O4 - HKLM\..\Run: [NvCplDaemon] RUNDLL32.EXE C:\WINDOWS\system32\NvCpl.dll,NvStartup
    O4 - HKLM\..\Run: [nwiz] nwiz.exe /install
    O4 - HKLM\..\Run: [NvMediaCenter] RUNDLL32.EXE C:\WINDOWS\system32\NvMcTray.dll,NvTaskbarInit
    O4 - HKLM\..\Run: [avast!] C:\PROGRA~1\ALWILS~1\Avast4\ashDisp.exe
    O4 - HKLM\..\Run: [UserFaultCheck] %systemroot%\system32\dumprep 0 -u
    O4 - HKLM\..\Run: [KernelFaultCheck] %systemroot%\system32\dumprep 0 -k
    O4 - HKCU\..\Run: [ctfmon.exe] C:\WINDOWS\system32\ctfmon.exe
    O9 - Extra button: (no name) - {e2e2dd38-d088-4134-82b7-f2ba38496583} - %windir%\Network Diagnostic\xpnetdiag.exe (file missing)
    O9 - Extra 'Tools' menuitem: @xpsp3res.dll,-20001 - {e2e2dd38-d088-4134-82b7-f2ba38496583} - %windir%\Network Diagnostic\xpnetdiag.exe (file missing)
    O9 - Extra button: Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Programas\Messenger\msmsgs.exe
    O9 - Extra 'Tools' menuitem: Windows Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Programas\Messenger\msmsgs.exe
    O11 - Options group: [INTERNATIONAL] International*
    O12 - Plugin for .spop: C:\Programas\Internet Explorer\Plugins\NPDocBox.dll
    O18 - Protocol: livecall - {828030A1-22C1-4009-854F-8E305202313F} - C:\PROGRA~1\MSNMES~1\MSGRAP~1.DLL
    O18 - Protocol: msnim - {828030A1-22C1-4009-854F-8E305202313F} - C:\PROGRA~1\MSNMES~1\MSGRAP~1.DLL
    O23 - Service: avast! iAVS4 Control Service (aswUpdSv) - ALWIL Software - C:\Programas\Alwil Software\Avast4\aswUpdSv.exe
    O23 - Service: avast! Antivirus - ALWIL Software - C:\Programas\Alwil Software\Avast4\ashServ.exe
    O23 - Service: avast! Mail Scanner - Unknown owner - C:\Programas\Alwil Software\Avast4\ashMaiSv.exe" /service (file missing)
    O23 - Service: avast! Web Scanner - Unknown owner - C:\Programas\Alwil Software\Avast4\ashWebSv.exe" /service (file missing)
    O23 - Service: NVIDIA Display Driver Service (NVSvc) - NVIDIA Corporation - C:\WINDOWS\system32\nvsvc32.exe


    ora eu tive de formatar o pc pois ele tava instavel. problemas na bios que originaram conflitos com o disco rigido e que estava constantemente a crashar. xegou ao ponto de assim que entrar no windows bloquiava logo.

    relativamente á memoria, estou a espera que xegue os meus 2gb de ram. era para ter chegado ontem mas o fornecedor enganou-se na encomenda e envio ddr2 em vez de ddr. entretanto vou usar o memtest e depois posto aqui os resultados.
     
  8. DarkButterfly

    DarkButterfly Power Member

    Não há nada de mal nisso. E também só agora reparei que tinhas acabado de formatar o pc. :D
    O que seria de estranhar se de facto fosse vírus.
     
  9. .:|EsPoNjAs|:.

    .:|EsPoNjAs|:. Power Member

    ok. ainda bem ;)

    agora parece que ha aqui um problema em relação a ram. o amigo "Jockey" disse para usar o programa memtest para verificar a ram. ao usar o programa o gajo detectou logo erros a torto e a direito.
     
  10. DarkButterfly

    DarkButterfly Power Member

    Deverá ser a memória.
    Se tivesse reparado, de início, que havias formatado o pc, dir-te-ia para fazeres testes à memória, etc.

    Já agora, não fará mal nenhum fazeres o seguinte em linha de comandos, o seguinte:

    chkdsk /F/R (faz uma verificação ao disco rigído e se houver erros tenta-los-á reparar). É um processo que demora algum tempo, portanto não desesperes. Mas se demorar mais que 3 horas, aí já é esquesito :D

    Aliás, pessoalmente, até faço esta verificação de mês a mês.

    Abraços.
     
  11. .:|EsPoNjAs|:.

    .:|EsPoNjAs|:. Power Member

    ok. vou experimentar fazer isso mesmo. entretanto o avast já esta a dar o mesmo problema. não sei o que se passa.. o pc ta mesmo marado. vamos la a ver com a chegada da nova ram ele fique bom.
     

Partilhar esta Página