1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Problemas com X ??

Discussão em 'Novidades GNU/Linux & *nix World' iniciada por APLinhares, 14 de Abril de 2006. (Respostas: 13; Visualizações: 1223)

  1. APLinhares

    APLinhares OpenSource Moderator
    Staff Member

    Boas malta. Tou aqui com 1 pequenito problema :wow:
    Nao sei por alma de quem o meu X deixou de arrancar e começou a dar o seguinte :
    Código:
    
    X Window System Version 6.8.2 (Ubuntu 6.8.2-77 20051010174523 [email protected])
    Release Date: 9 February 2005
    X Protocol Version 11, Revision 0, Release 6.8.2
    Build Operating System: Linux 2.6.10 i686 [ELF] 
    Current Operating System: Linux tatil 2.6.12-10-686 #1 Sat Mar 11 16:22:51 UTC 2006 i686
    Build Date: 10 October 2005
        Before reporting problems, check http://wiki.X.Org
        to make sure that you have the latest version.
    Module Loader present
    OS Kernel: Linux version 2.6.12-10-686 ([email protected]) (gcc version 3.4.5 20050809 (prerelease) (Ubuntu 3.4.4-6ubuntu8.1)) #1 Sat Mar 11 16:22:51 UTC 2006 T
    Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Fri Apr 14 12:34:55 2006
    (==) Using config file: "/etc/X11/xorg.conf"
    (==) ServerLayout "Default Layout"
    (**) |-->Screen "Default Screen" (0)
    (**) |   |-->Monitor "Generic Monitor"
    (**) |   |-->Device "Intel Corporation 82852/855GM Integrated Graphics Device"
    (**) |-->Input Device "Generic Keyboard"
    (**) |-->Input Device "Configured Mouse"
    (**) |-->Input Device "Synaptics Touchpad"
    (WW) The directory "/usr/share/X11/fonts/cyrillic" does not exist.
        Entry deleted from font path.
    (WW) The directory "/usr/share/X11/fonts/CID" does not exist.
        Entry deleted from font path.
    (WW) `fonts.dir' not found (or not valid) in "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID".
        Entry deleted from font path.
        (Run 'mkfontdir' on "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID").
    (**) FontPath set to "/usr/share/X11/fonts/misc,/usr/share/X11/fonts/100dpi/:unscaled,/usr/share/X11/fonts/75dpi/:unscaled,/usr/share/X11/fonts/Type1,/usr/share/X11/fonts/100dpi,/usr/share/X11/fonts/75dpi,/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    (==) RgbPath set to "/usr/X11R6/lib/X11/rgb"
    (==) ModulePath set to "/usr/X11R6/lib/modules"
    (WW) Open APM failed (/dev/apm_bios) (No such file or directory)
    Couldn't open RGB_DB '/usr/X11R6/lib/X11/rgb'
    (II) Module ABI versions:
        X.Org ANSI C Emulation: 0.2
        X.Org Video Driver: 0.7
        X.Org XInput driver : 0.4
        X.Org Server Extension : 0.2
        X.Org Font Renderer : 0.4
    (II) Loader running on linux
    (II) LoadModule: "bitmap"
    (WW) Warning, couldn't open module bitmap
    (II) UnloadModule: "bitmap"
    (EE) Failed to load module "bitmap" (module does not exist, 0)
    (II) LoadModule: "pcidata"
    (WW) Warning, couldn't open module pcidata
    (II) UnloadModule: "pcidata"
    (EE) Failed to load module "pcidata" (module does not exist, 0)
    
    Fatal server error:
    Unable to load required base modules, Exiting...
    
    
    Please consult the The X.Org Foundation support 
         at http://wiki.X.Org
     for help. 
    Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    
    
    Se alguem tiver ideias :'(
     
  2. El_UnO

    El_UnO 1st Folding then Sex

    Podes por aki o teu xorg.conf? Tb ajudava :P
     
  3. APLinhares

    APLinhares OpenSource Moderator
    Staff Member

    ya ya .. :P apesar que NAO foi modificado...
    Código:
    # /etc/X11/xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
    # (Type "man /etc/X11/xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "Files"
        FontPath    "/usr/share/X11/fonts/misc"
        FontPath    "/usr/share/X11/fonts/cyrillic"
        FontPath    "/usr/share/X11/fonts/100dpi/:unscaled"
        FontPath    "/usr/share/X11/fonts/75dpi/:unscaled"
        FontPath    "/usr/share/X11/fonts/Type1"
        FontPath    "/usr/share/X11/fonts/CID"
        FontPath    "/usr/share/X11/fonts/100dpi"
        FontPath    "/usr/share/X11/fonts/75dpi"
            # paths to defoma fonts
        FontPath    "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
        FontPath    "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
    EndSection
    
    Section "Module"
        Load    "GLcore"
        Load    "i2c"
        Load    "bitmap"
        Load    "ddc"
        Load    "dri"
        Load    "extmod"
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "type1"
        Load    "vbe"
    EndSection
    
    Section "InputDevice"
        Identifier    "Generic Keyboard"
        Driver        "kbd"
        Option        "CoreKeyboard"
        Option        "XkbRules"    "xorg"
        Option        "XkbModel"    "pc105"
        Option        "XkbLayout"    "pt"
    #        Option          "RightAlt"    ModeShift
    EndSection
    
    Section "InputDevice"
        Identifier    "Configured Mouse"
        Driver        "mouse"
        Option        "CorePointer"
        Option        "Device"        "/dev/input/mice"
        Option        "Protocol"        "ImPS/2"
        Option        "Emulate3Buttons"    "true"
    #    Option        "ZAxisMapping"        "4 5"
    EndSection
    
    Section "InputDevice"
        Identifier    "Synaptics Touchpad"
        Driver        "synaptics"
        Option        "SendCoreEvents"    "true"
        Option        "Device"        "/dev/psaux"
        Option        "Protocol"        "auto-dev"
        Option        "HorizScrollDelta"    "0"
    EndSection
    
    Section "Device"
        Identifier    "Intel Corporation 82852/855GM Integrated Graphics Device"
        Driver        "i810"
        BusID        "PCI:0:2:0"
    EndSection
    
    Section "Monitor"
        Identifier    "Generic Monitor"
        Option        "DPMS"
    EndSection
    
    Section "Screen"
        Identifier    "Default Screen"
        Device        "Intel Corporation 82852/855GM Integrated Graphics Device"
        Monitor        "Generic Monitor"
        DefaultDepth    24
        SubSection "Display"
            Depth        1
            Modes        "1024x768"
        EndSubSection
        SubSection "Display"
            Depth        4
            Modes        "1024x768"
        EndSubSection
        SubSection "Display"
            Depth        8
            Modes        "1024x768"
        EndSubSection
        SubSection "Display"
            Depth        15
            Modes        "1024x768"
        EndSubSection
        SubSection "Display"
            Depth        16
            Modes        "1024x768"
        EndSubSection
        SubSection "Display"
            Depth        24
            Modes        "1024x768"
        EndSubSection
    EndSection
    
    Section "ServerLayout"
        Identifier    "Default Layout"
        Screen        "Default Screen"
        InputDevice    "Generic Keyboard"
        InputDevice    "Configured Mouse"
        InputDevice    "Synaptics Touchpad"
    EndSection
    
    Section "DRI"
        Mode    0666
    EndSection
    
    #Section "Extensions"
    #Option "Composite" "Enable"
    #EndSection
    
     
  4. El_UnO

    El_UnO 1st Folding then Sex

    Assim por alto, parece-me que os directorios na seccao Files podem nao estar correctos. Os meus estao assim:

    Código:
    Section "Files"
    	RgbPath      "/usr/lib/X11/rgb"
    	ModulePath   "/usr/lib/modules"
    	FontPath     "/usr/share/fonts/misc/"
    	FontPath     "/usr/share/fonts/TTF/"
    	FontPath     "/usr/share/fonts/Type1/"
    	FontPath     "/usr/share/fonts/CID/"
    	FontPath     "/usr/share/fonts/75dpi/"
    	FontPath     "/usr/share/fonts/100dpi/"
    EndSection
    Mas isto nao e certo e varia de sistema para sistema...tambem e esquisito nao teres um modulepath e um rgbpath. Procura por isso tudo no teu sistema e reconfigura o xorg.conf :P
     
  5. enok

    enok [email protected] Member

    não fizeste nenhum emerge recentemente?
    já experimentaste fazer um etc-update?
    e um revdep-rebuild só por via das duvidas?

    em ultimo caso... emerge xorg-x11 novamente.
     
  6. APLinhares

    APLinhares OpenSource Moderator
    Staff Member

    tou a usar o kubuntu (no portatil) ... e ha tentei 1 reinstall do xorg-x11, mas continuou igual.
    estranho é que por acaso ja nao actualizo á algum tempo e sempre deu direito...
    bem,vou fazer backup e tentar 1 xorg.conf reconfigurado...
     
  7. enok

    enok [email protected] Member

    o teu "My System"enganou-me bem então... ;)
     
  8. APLinhares

    APLinhares OpenSource Moderator
    Staff Member

    hehe, ja vi que nao leste tdo :P amd64 ta encostado (ainda :() e isto deu-se no portatil :(
    :007:
    no entanto foi util na mesma :) tentei ja isso mas nepias, reinstalou mas continua igual.
    tentei o reconfigure, mas continua com mesmo erro, quanto ao "caminho" julgo estarem correctos, pois nao mexi em nada e /usr/X11R6/lib é 1 link, suponho razoes compatibilidade.
    de certo mando o kubuntu pro c* de judas :-D tou com saudades d1 sistema de "puro sangue"...
     
  9. Morpheus

    Morpheus Banido

    nepias ... já procuraste algum xorg.conf_backup ou algo do género?
     
  10. PrOdG

    PrOdG Power Member

    Se o erro é ao carregar os módulos "bitmap" e "pcidata", porque não experimentas comentar as linhas
    Código:
      Load    "bitmap"
      Load    "pcidata"
    da zona dos módulos? Não faço ideia para que servem, anyway..

    No pior dos casos, podes sempre voltar a instalar uma versão anterior do Xorg.
     
  11. APLinhares

    APLinhares OpenSource Moderator
    Staff Member

    ora bem, comentar nao leva a nada, isto é, leva á mesma situaçao...
    Ja agora, Load "bitmpap" é usado para [FONT=Verdana, Arial, Helvetica, sans-serif][FONT=Verdana, Arial, Helvetica, sans-serif]bitmap-fonts.
    tentei também usar os 3 backups que tinha e nada :(
    vou forçar as path's manuais (se acertar nelas,lol)
    [/FONT]
    [/FONT]
     
  12. APLinhares

    APLinhares OpenSource Moderator
    Staff Member

    bem, nao consigo resolver isto, nem noutros foruns (ubuntuforum) me conseguem ajudar... acho que vou é format (lol) e aproveito pra meter puro debian. SO que levanta-se 1 questão.
    É possivel fazer backups (pra CD-R) de dados, sem ambiente X ??
     
  13. El_UnO

    El_UnO 1st Folding then Sex

    Sim, man cdrecord pa veres como :)

    Ou entao neste link:

    http://yolinux.com/TUTORIALS/LinuxTutorialCDBurn.html
     
  14. APLinhares

    APLinhares OpenSource Moderator
    Staff Member

Partilhar esta Página