1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.
  2. Informação: Pela 0:30 desta Sexta-feira (9 de Dezembro, 23:30 de Quinta-feira nos Açores) o Fórum e restantes sites da ZWAME vão estar offline para manutenção durante cerca de 1h30.
    Se necessário faremos actualizações via Twitter e Facebook.
    Remover anúncio

Problemas de comunicação - Rotas, VPNs, Gateways...

Discussão em 'Dúvidas e Suporte—Internet, Redes, Segurança' iniciada por Smig, 31 de Dezembro de 2007. (Respostas: 0; Visualizações: 441)

  1. Smig

    Smig Power Member

    Há algum bug relacionado com o sistema de roteamento do windows ou sou eu que não estou a perceber alguma coisa?

    Depois de configurações e desconfigurações várias, acabámos por conseguir fazer com que a comunicação entre várias redes ligadas por vpns funcionasse correctamente... mas com um custo, dezenas de rotas criadas manualmente em cada computador que pretenda comunicar com os pontos remotos (+ um ip secundário local em cada um na rede dos routers locais).

    Na altura não houve tempo para mais nada mas agora gostava de optimizar as coisas até porque é um trabalho extra de manutenção completamente desnecessário.

    Na minha cabeça, só vejo uma forma lógica/simples/económica de fazer isto. Configurar as rotas todas nos servidores que fazem naturalmente de gateways (firewalls/nats) e não fazer alterações nas workstations deixando as tais gatways como default gateway do windows. Certo?

    Ora isto só funciona de vez em quando. Às vezes com resultados misturados em que chego a meio do percurso mas os pacotes perdem-se pelo caminho ou chegam ao destino e não voltam à origem. Podia ser um problema na direcção oposta, em que no destino não existe informação suficiente para voltar mas como as duas abordagens não mudam nada no destino, acho este comportamento estranho.

    O ambiente da rede é complicado, há uma rede local, uma rede diferente para os routers locais (problemas com broadcasts) e várias redes remotas. São 3 saltos para chegar ao destino cujas rotas os definem correctamente em cada router, mas aparentemente tudo muda se, na origem, der um salto extra a uma gateway windows, em vez de ir directamente ao router local respectivo.

    Isto aplica-se não só à definição de uma default gateway mas também se for criada uma rota para a rede respectiva a apontar para essa gateway (que por sua vez contém a informação do router respectivo e assim por diante).

    E então entramos na twilight zone, situações como não conseguir pingar o destino mas chegar lá com o tracert, que por sua vez parece saltar um router a meio, chegando mesmo assim ao destino duma forma impossível e depois continuando a procurar por mais qualquer coisa para lá do ip de destino que já não encontra...

    Ora, antes de me virar para o domínio da metafísica e antes de perder muito mais tempo com isto, alguem com mais experiencia tem uma ideia do porquê disto não funcionar como era suposto? Alguma limitação do sistema de roteamento de pacotes do Windows? Alguma especificidade da rede em questão que só é ultrapassável com um roteamento explícito em todas as workstations? Alguma coisa que me está a escapar?
     

Partilhar esta Página