1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Problemas em instalar linux em portatil

Discussão em 'Novidades GNU/Linux & *nix World' iniciada por h2o, 10 de Agosto de 2007. (Respostas: 15; Visualizações: 1502)

  1. h2o

    h2o Power Member

    Como faço para instalar Linux num portatil compal IF90?
    Tentei algumas distros e não consigo nada, encravam sempre nalgum ponto ainda antes de arrancarem como live cds/dvds ou antes de instalarem.Suponho que seja por falta de drivers para sata?
     
  2. LnxSlck

    LnxSlck Power Member

    Dificilmente será por isso, talvez com acpi=off ao arrancar dê qualquer coisa.

    Já agora se colocasses os erros, as distros que usaste, e especificasses mais o teu problema terias mais ajuda
     
  3. h2o

    h2o Power Member

    AHCI=OFF:
    Nao é o acpi mas ahci, ja consegui arrancar algumas distro com ahci=off:knoppix e gentoo(este dá problemas do interface grafico e fica em modo texto...outra historia)

    O ubuntu 64bits chapeu...o ubunto 7.04 idem aspas...o 1º fica com o ecram negro e nao sai daí, depois de pedir para instalar apos o menu inicial. o ubunto "normal" 32bits diz:
    Busybox v1.1.3 (debian 1:1.1.3-3ubuntu3) Built-in shell (ash)
    enter help for a list of bult in commands.

    /bin/sh: can't access tty; job control turned off
    (initramf s)"
    arrancam as distros(em off so experimentei 2) por isso suspeito que seja de drivers sata embora o bluewithe64(distro baseada em slakware) devia funcar...

    Distros que tentei com ahci on: ubuntu(64 e 32bits 6 e 7.04), bluewhite64, knoppix, dsl e gentoo.


    Questões:
    Como faço pra instalar os drivers ahci no arranque de qualquer distro?Supondo que seja esse o problema principal...
    Posso carregar os drivers ahci de uma unidade usb? tive algum trabalho para implementar as mesmas no windows com nlite e tive de gastar mais um cd se pudesse evitar isso...



    Qual a distro mais propriada para o meu portatil?
    Para aprender linux.
    Maquina: compal IF90 T7500 2giga ram(que ja parecem pouco no CS3 :( ) disco 160Giga (devia ter ido para 250 tb..) e grafica 8600M GT
     
    Última edição: 12 de Agosto de 2007
  4. luikki

    luikki Power Member

    qual é apropriada, não sei....
    por que não testas com live cd's?
    live cd list
    e, se fizeres como eu....nunca mais largas o pclinuxos........
     
  5. h2o

    h2o Power Member

    Se instalar uma distro de linux posso mais tarde instalar drivers para ahci?
    e Porque raio nao consigo usar o cfdisk ou outro porque tenho a mensagem de que o disco estra protegido contra escrita?
    tenho partiçoes em ntfs e espaço nao particionado!
     
  6. h2o

    h2o Power Member

    Nenhuma alma caridosa para ajudar o proximo?:007:
     
  7. Wickwire

    Wickwire Power Member

    Já experimentaste, neste ponto, correr:

    modprobe piix (ou ata_piix)
    exit

    e ver se ele continua com o arranque?

    Se continuar, instalas o sistema se quiseres, fazes chroot e editas

    /etc/initramfs-tools/modules (ou o equivalente da distro que usares, neste caso é Ubuntu)

    adicionas piix ou ata_piix, salvas e executas update-initramfs -u,
    sais de chroot, rebootas e confirmas se já arranca bem.

    (pormenor elementar mas de qq forma... se tiveres /boot numa partição à parte, confirma que está mounted antes do chroot para alterar o initramfs)
     
  8. h2o

    h2o Power Member

    Avança com o modprobe mas depois desaparece o ecran e nem mensagens de erro nem nada...
     
  9. Wickwire

    Wickwire Power Member

    Há fortes probabilidades de esse ser um problema adicional, não relacionado com a questão do driver piix.

    De qq forma para confirmar, quando o ecrã desaparecer no fim do suposto arranque, carregas em ctrl+alt+F1 e vê se ele salta para interface de linha de comandos.

    Se tiveres interface de linha de comandos, confirma-se que o sistema arrancou de facto e que agora a questão é com o servidor gráfico:

    Como root editas o ficheiro /etc/X11/xorg.conf e tens duas hipóteses:

    Alternativa 1

    Procuras a secção da placa gráfica, algo deste género:

    Section "Device"
    Identifier "NVIDIA Corporation NV18 [GeForce4 MX 440 AGP 8x]"
    Driver "nvidia"
    BusID "PCI:1:0:0"
    EndSection

    Na linha do Driver substituis o que estiver por vesa, salvas e reinicias a parte gráfica do sistema:

    /etc/init.d/gdm restart (Ubuntu)
    ou
    /etc/init.d/kdm restart (Kubuntu)
    ou
    /etc/init.d/xdm restart

    ou da maneira que for na distro que usares e vês se já tens login para entrar no ambiente gráfico.

    Alternativa 2:

    Se na linha do Driver estiver via (se o portátil tiver uma placa Via) então manténs o driver via na configuração e por baixo dessa linha colocas:

    Option "VBEModes" "True"

    Salvas e reinicias a parte gráfica do sistema como descrito em cima.
     
  10. jpalbuquerque

    jpalbuquerque Power Member

    Eu tambem tive problemas no meu portatil, tinha precisamente o mesmo problema que tu.
    A melhor solução que arranjei foi instalar o ubuntu 7.10, ficou a funcionar relativamente bem, só ti que fazer o dkpg-reconfigure para a parte gráfica ficar a bombar :)
     
  11. Inoculado

    Inoculado Power Member

    eu tb estou com um stress ,1º porque a drive de Cd nao esta no melhor estado ,2º porque se trata de um p3 a 800 mhz ,ele arranca e perto do fim ,ja passado uma hora quase fica no preto.
    se pudesse correr por usb..
    Agora o pclinux q nao conhecia ,parece ser engraçado
     
  12. sir_arrentela

    sir_arrentela Power Member

    O arranque por USB tem piada sei que se corre, mas nao vi ainda nada a correr dessa maneira...
    Tens pelo menos 256mb de RAM?

    Quanto as outras questoes... o meu Ubuntu no meu Toshiba arrancou bem, mas nao tinha o driver grafico completo... para o ter foi um pesadelo, e mesmo assim teve de ser a ferros...
    So la fui com o Envy...

    Depois o som, nao dava mas tava registado... foi Alsa novo e alteraçao no Modprob.conf ... agora a Webcam e que ta esquesito... mas de resto esta tudo bem

    De resto ja viste se o teu PC ta no Linux Laptops?

    Cumps
     
  13. Wickwire

    Wickwire Power Member

  14. sir_arrentela

    sir_arrentela Power Member

    As coisas que eu tinha exprimentado nada se baseavam nisso...

    Afinal e preciso que a Pen seja FAT16?

    Ah...
     
  15. Inoculado

    Inoculado Power Member

    o pc coitado mal se mexia quanto mais arrancar um sistema operativo pelo CD,talvez agora limpinho ele va la
    tenho sim , exactamente 256 de ram o pc nao é meu estava atulhado quase nao se mexia ,e esse amigo meu disse para eu experimentar o ubuntu q eu ja lhe tinha falado ele sabe trabalhar com linux ,mas acho q o ubuntu é mais recente e pelos vistos desconhecia
    meti o pclinuxSO e estou a gostar ate agora ,mas é uma questao de experimentar outros sistemas
     
  16. [knap]

    [knap] Power Member

    Podes também arrancar por rede ou por USB se o leitor de cds não está no melhor estado. Debian permite-te fazer isso (arrancar por rede).
     

Partilhar esta Página