1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Problemas no Eclipse!!!

Discussão em 'Dúvidas e Suporte Técnico - GNU/Linux & *nix' iniciada por CowboyFromHell, 26 de Setembro de 2007. (Respostas: 14; Visualizações: 2268)

  1. CowboyFromHell

    CowboyFromHell Power Member

    Boas,
    mais uma vez peço desculpa por criar outro tópico, mas não estou a conseguir instalar o Eclipse no Ubuntu pq segundo o "adic/rem prog" diz q ha conflito com outro programa e para executar o gestor de pacotes synaptic para remover o outro programa, mas eu não faço a mínima ideia qual é!!!
    Alguém já teve problema semelhante? Sem o eclipse não faço nada:s

    PS: já agr existe algum editor/compilador decente para linux de java? Acho q o KWrite também dá para java mas tou habituado a eclipse e netBeans no windows

    Cheers
     
  2. JKL22

    JKL22 Power Member

    Por acaso "sudo apt-get install eclipse" não resolve?
     
  3. CowboyFromHell

    CowboyFromHell Power Member

    Noup aparece isto:

    Alguns pacotes não puderam ser instalados. Isso pode significar que
    você solicitou uma situação impossível ou se você está a usar a
    distribuição instável, que alguns pacotes requisitados ainda não foram
    criados ou foram tirados do Incoming.

    Já que você requisitou uma única operação é extremamente provável que o
    pacote esteja simplesmente não instalável e deve ser enviado um relatório de
    bug sobre esse pacote.
    A seguinte informação pode ajudar a resolver a situação:

    Os pacotes a seguir têm dependências não satisfeitas:
    eclipse: Depende: eclipse-jdt (= 3.1.2-1ubuntu6) mas não vai ser instalado
    Depende: eclipse-pde (= 3.1.2-1ubuntu6) mas não vai ser instalado
    Depende: eclipse-source (= 3.1.2-1ubuntu6) mas não vai ser instalado
    E: Pacotes estragados


    ....
     
  4. slack_guy

    slack_guy Power Member

  5. kronos

    kronos Power Member

    tenta "dpkg --configure -a" e depois volta a tentar instalar
     
  6. slack_guy

    slack_guy Power Member

    Daqui: http://wiki.eclipse.org/SDK_Known_Issues#Installing
    No caso do Linux, em vez de 'eclipse.exe' é 'eclipse'. Não há nada para instalar.
     
  7. lothar_m

    lothar_m Power Member

    já agora talvez fosse util que postasses o conteudo do teu source.list do apt.
     
  8. VuDu

    VuDu Power Member

    apt-get update && apt-get upgrade && apt-get install eclipse
    Vê se faz alguma diferença, caso tenham sido feitas alterações nos pacotes de instalação do eclipse, é bem provavel que precises de fazer um update antes de conseguires instalar com sucesso.
     
  9. k3ys3r

    k3ys3r Power Member

    se já tiveres um jdk instalado podes sacar a versão do eclipse directamente da página do eclipse.

    depois descomprimes e corres directamente da directoria, não precisas de fazer qualquer tipo de install.

    Além de ser simples tens a ultima versão, eclipse 3.3 europa, a versão do ubuntu (como a maior parte das outras distros ) anda na 3.2 .
     
  10. cheires

    cheires Power Member

    Para não estar a criar um novo tópico, aproveito este.
    Estou com problemas no eclipse, quase não consigo trabalhar.
    É o seguinte.
    Quando uso a combinação de teclar ctrl+space (auto-complete) o eclipse pura e simplesmente crasha e gera um log de erro.
    Ou ainda quando numa classe se escreve o "." para se escrever os métodos ou atributos, aparece uma janelinha com os respectivos métodos ou atributi, que também faz crashar o eclipse.
    Esta situação torna qualquer trabalho penoso.
    Estou a usar o Eclipse Galileu, mas no Ganymede também acontece. Uso o Slackware 13.
    Alguém tem ideia de como resolver esta situação?
     
  11. hasta.g5

    hasta.g5 I quit My Job for Folding

    Visto que já experimentaste outras versões, pode ser problema do workspace. Experimenta eliminar a pasta .metadata do workspace e .settings do projecto.
     
  12. Joze_N

    Joze_N Power Member

    Também os tens para linux.... assim a modos que são os dois feitos em java correm em todo o lado e mais algum(n é bem assim mas aqui aplica-se :P)
     
  13. cheires

    cheires Power Member


    Não resolveu, continua na mesma. No entanto obrigado pela sugestão

    Alguém tem mais alguma sugestão?
     
  14. Joze_N

    Joze_N Power Member

    vais até ao site do eclipse, sacas de lá o tar.gz, descompactas para uma pasta e pronto já tens o eclipse a trabalhar.

    Ele não precisa de nenhuma instalação especifica em nenhuma pasta especial.
     
  15. LnxSlck

    LnxSlck Power Member

    O teu problema pode passar por teres uma dependência não resolvida. Vais ver precisas de um pacote que não tens disponível nas tuas sources list. Como já foi dito e bem, vai ao site, fazes o download, descomprimes e corres.
     

Partilhar esta Página