1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Quase, quase quase a ter net!

Discussão em 'Dúvidas e Suporte Técnico - GNU/Linux & *nix' iniciada por | Blasted |, 2 de Outubro de 2008. (Respostas: 42; Visualizações: 2748)

  1. | Blasted |

    | Blasted | [email protected] Member

    Olá!

    Ando com um pequeno (grande) problema.
    Tenho Ubuntu e quero ligá-lo a uma rede wireless. A minha placa de rede é uma das tramadas (Realtek RTL8187B), mas esse não é o problema.
    Instalei o ndiswrapper e depois o driver da placa.
    Assim se for a Sistema > Administração > Windows Wireless Drivers aparece-me o driver da placa e diz que o hardware está presente.
    O problema vem agora. Como procurar por redes wireless?
    No icone de rede ao lado do relógio no canto superior direito, ele insiste em procurar por redes com fios e não por redes sem fios.
    Será por a placa estar desligada ou algo do género? Se sim, como a ligo?
    Já tentei algumas coisas que vi na net (google :D) e algumas dicas que também já vi aqui no fórum, mas não há meio de conseguir por isto a detectar redes wireless para me puder ligar.

    A vossa ajuda pf.

    Cumprimentos,
     
  2. | Blasted |

    | Blasted | [email protected] Member

    Já estive a ver e realmente parece-me uma boa opção.

    Mas eu acho que isto talvez tenha uma solução sem ter que andar a instalar outro gestor de redes.
    Fui á consola e fiz
    Código:
    iwlist scan
    
    E na parte de wlan0 aparece-me todos os detalhes da rede wireless a que me quero conectar. Isto indica que o computador encontrou a rede, certo? E agora como me conectar?
     
  3. | Blasted |

    | Blasted | [email protected] Member

    Bem, instalei o wicd e realmente é bem mais apelativo e funcional que o vinha de origem com o ubuntu.
    No entanto ainda estou com um problema.
    Ele detecta a minha rede, já configurei nas advanced settings com a chave wep, mas agora fazendo "Ligar", fica em baixo a dizer:

    [Validating authentication]

    Até que alguns segundos depois para, e diz que não está ligado. A chave WEP está certa.
    O que poderá ser?

    EDIT: Sorry pelo double post
     
  4. Frango.

    Frango. Power Member

  5. | Blasted |

    | Blasted | [email protected] Member

    CD pedido.

    No entanto, até lá se alguém me puder ajudar :D
    É que lá no site fala em 10 weeks de espera.. :-D
     
  6. APLinhares

    APLinhares OpenSource Moderator
    Staff Member

    Experimenta outra versão do ndiswrapper, ou outros drivers.
    Confirmaste no site oficial se a tua placa / chipset está suportada em alguma versão em especial? (bem, mudaram de site, já não encontro a lista).
     
  7. Frango.

    Frango. Power Member

    Yep, lá também dizia 10 weeks e no entanto recebi em 2 certinhas :D
     
  8. | Blasted |

    | Blasted | [email protected] Member

    O site de onde tirei os drivers é este : AQUI
    Na parte referente à RTL8187B
    O que queres dizer com estar suportada em alguma versão em especial?
     
  9. APLinhares

    APLinhares OpenSource Moderator
    Staff Member

    pode funcionar na versao x.52 por ex e na x.53 já não. Acontece-me isso com a pen que tenho noutro pc.
    Experimenta tb outra versao dos drivers (+ antiga por ex )
     
  10. | Blasted |

    | Blasted | [email protected] Member

    Desculpa, mas continuo a não perceber essa coisa das versões. Versões dos drivers? Da placa? Do Ubuntu?

    Quanto à versão mais antiga, já tentei e continua a não funcionar..
    Aquilo reconhece a minha rede e tudo, mas quando ponho ligar, fica em "Validating Authentication" e não liga.

    cumprimentos,
     
  11. APLinhares

    APLinhares OpenSource Moderator
    Staff Member

    estava a falar do ndiswrapper, sim.
     
  12. | Blasted |

    | Blasted | [email protected] Member

    Então passa por tentar uma versão mais antiga do ndiswrapper?
    Eu instalei aquela que vinha junto já com o CD do Ubuntu 8.04..

    E sem ser isso, o que poderá ser mais? O que poderei fazer mais?
     
  13. mbmdec

    mbmdec Power Member

    Vai até ao menu e penso que lá está um programa com o nome rede. depois tenta ver as definições da placa... mete em dhcp ou automático... Já não uso o ubuntu a algum tempo por isso estou a dizer isto mas sem muitas certezas... tenta ajuda no forum do ubuntu e pesquisa lá pelo nome da tua placa (RTL8187).
     
  14. SIG

    SIG Power Member

    Confirma primeiro se tens WEP ou WPA/WPA2. Até pode ser esse o erro. Talvez não, porque o wicd deverá detectar o tipo automaticamente. :P

    Como não uso o wicd andei pelo site deles e vi num dos screenshots um "Enable Debug Mode". Tenta activar isso, pode ser que ajude. Não sei para onde vai o output disso portanto terás que investigar.

    No terminal experimenta executar o "iwevent" e faz nova tentativa de ligação. Pode ser que dê alguma dica do que acontece.

    Outra coisa que podes tentar é retirar (temporariamente) a encriptação do router, isto é, tornar a rede aberta e fazer nova tentativa de ligação. Se der então é porque pelo menos já dá pela ligar o que indicará algum problema a tentar ligar-se a uma rede encriptada. Nesse caso até podes tentar outros modos de encriptação.
     
  15. | Blasted |

    | Blasted | [email protected] Member

    Como é que faço para retirar a encriptação do router?
    Tenho MEO cá em casa. Não tenho muita experiência nisto de redes, e portanto não faço a minima ideia de como trabalhar com o router.
     
  16. enok

    enok [email protected] Member

    se calhar usas cifras WEP de 64 bits e a rede é de 128 bits. ou vice-versa.
     
  17. Anistruk

    Anistruk I folded Myself

    Bem, antes de mais estou solidário contigo no problema porque a minha placa que é igual á tua, também não funciona...

    Agora em relação á Meo, a segurança se ainda tiveres de origem vem em WPA, e nesse sistema parece-me que ainda não há solução para a nossa placa. Existem registos dela a funcionar mas com WEP.

    No router vais a Rede Doméstica, Interfaces e deves ter lá Ethernet e Wireless, selecionas a Wireless e em cima tens Configurar. Aí é que mudas tudo.

    Boa sorte!
     
  18. | Blasted |

    | Blasted | [email protected] Member

    Então se aceder ao router, posso alterar e mudar de WPA para WEP?

    Ao tentar aceder ao router, ele pede-me a password de sistema. Esta é diferente da chave WPA, certo?
    É que se for, o técnico que cá veio, não me deixou a password de sistema.
     
  19. Anistruk

    Anistruk I folded Myself

    Que router é? É um THOMSON TG787? Se for o O IP é o 192.168.1.254, Login Administrator ea pass é 3!play
     

Partilhar esta Página