1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Quero criar um site, mas quero testá-lo no meu PC...

Discussão em 'Web Development' iniciada por eyeliner, 1 de Setembro de 2007. (Respostas: 20; Visualizações: 4411)

  1. eyeliner

    eyeliner Power Member

    Eias a todos.

    É assim, quero criar um blog e já tenho o wordpress.
    Mas não tenho sítio para alojar e antes de pensar em soluções pagas, queria criar o "esqueleto"
    no meu PC (local) e ver como tudo corre.

    O problema de tudo isto é que os php não são executados. Alguém sabe uma forma de contornar
    isso?

    Ou seja, fazer com que o meu PC fosse um servidor Web para fazer uns testes?
    É que não faço a mínima quais serão as palavras certas para pesquisar no Google.

    Obg.
     
  2. JuSt_Me_AnD_yOu

    JuSt_Me_AnD_yOu What is folding?

    Apache :)
    Se tiveres a correr windows saca o easyphp
     
  3. NINJA1200

    NINJA1200 [email protected] Member

    Então e que tal instalares o PHP no teu pc?
     
  4. JKL22

    JKL22 Power Member

  5. eyeliner

    eyeliner Power Member

    Obrigado pela rapidíssimas respostas. :)
    Vou já tentar. :)
     
  6. Biofobico

    Biofobico Power Member

    Talvez a melhor solução para o que procuras fazer....
     
  7. AliFromCairo

    AliFromCairo Power Member

    Também aconselho o XAMPP.
     
  8. CrazyBomber

    CrazyBomber Power Member

    Eu uso o EasyPHP.
    É só instalar e está a correr.

    Manualmente tb se pode fazer, mas dá mt trabalho... :sad:
     
  9. HecKel

    HecKel The WORM

  10. eyeliner

    eyeliner Power Member

    Grrr... O Vista "queima-me" o esforço todo. Parece que não se dá bem com o Apache... :(
     
  11. alfinete

    alfinete Power Member

    se o vista te queima, em principio o xammp devria dar , tenta por o php a correr no iis, tb dá mas nam sei como.

    tens é que por os files php a correr na pasta carta
    que agra nam me lembro qual é , mas é c:/xampp/.......


    , e no browser fazer h
    http://localhost/patacriadaporti/file ou
    http://127.0.0.1/patacriadaporti/file

    pois o iis é do proprio windows



    é que o vista a meu ver não vai ficar bom enquanto não sair service pack 1

    por isso nam sei como hades resolver o problema


    podes tb utilizar asp , que funciona o iis sem matrafalhices, mas depois a linguagem por detraz para funcionarem as coisas tem de ser vb ou c#, tb pode ser php, mas ja com uns truques.
     
    Última edição: 2 de Setembro de 2007
  12. Net_Holer

    Net_Holer Power Member

    Hmm se tens tantos problemas ao tentar correlo no pc entao faz isso num servidor gratis... a unica diferença e que tens uma pequena publicidade... tenta por exemplo no:
    http://www.100webspace.com/

    É onde tenho o meu fórum (da assinatura) ainda tenho o plano free mas em breve vou mudar para o pago.
    Espero ajudar :)
     
  13. JKL22

    JKL22 Power Member

    Acho que ele quer testar o site no PC antes de o colocar no alojamento para ser mais fácil, não me parece que o problema seja falta de alojamento.
     
  14. Existem alguns alojamentos gratis na net, o freehostia estava mto fix a ultima ver que usei. Para correres no teu PC tambem recomento o Xampp que é o que tenho usado à bastante tempo sem problemas, tens o Apache, PHP, Mysql e até FTP server tudo num so installer.

    No vista não sei como é que se porta mas em xp e 2k funca bem.
     
  15. eyeliner

    eyeliner Power Member

    Pois, o problema é que o Apache não se inicia no Vista como serviço, queixando-se de acessos e não sei quê.
    Já desactivei o UAC e dava-me o mesmo.
    Estão a ver? :(
     
  16. JKL22

    JKL22 Power Member

    Já experimentaste Clique com botão direito > Executar como administrador ?
     
  17. eyeliner

    eyeliner Power Member

    Sim, desactivei o UAC, abri excepção na Firewall...
    Não me ocorre mais nada a não ser chamar o Professor Bambo...[​IMG]
     
  18. JKL22

    JKL22 Power Member

    isto.
     
  19. eyeliner

    eyeliner Power Member

    Não dá. Por alguma razão estúpida, não consigo iniciá-lo com serviço.
     
  20. _lamy_

    _lamy_ Power Member


    Isso deve ser porque vai na volta eles ou querem q essa porta esteja restrita para o IIS ou tens mm o IIS a correr...

    tenta instalar o apache no porto 8080 que aparece nas opções aquando da isntalação ou tenta desactivar mm o IIS lá no painel de controlo - remover aplicações ou que é...

    se instalares no porto 8080 dps no browser é so fazer http://localhost:8080/pasta


    Depois tens q trabalhar na pasta htdocs dentro da pasta apache.

    Também te aconselho a instalar o xampp.


    Abraço
     

Partilhar esta Página