1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.
  2. A secção Microsoft/Windows encontra-se actualmente em processo de reestruturação.
    Remover anúncio

Reproduzir .mkv's [Vista SP1 Media Center]

Discussão em 'Windows 7 e anteriores' iniciada por Sion, 4 de Maio de 2008. (Respostas: 22; Visualizações: 1372)

  1. Sion

    Sion Power Member

    Boas pessoal.



    Hoje instalei o K-Lite Full para ver filmes em HD no meu PC e consigo ver na perfeição tanto no windows media player como no media player classic. O problema só aparece quando tenho o Windows Media Center maximizado. Já experimentei por o WMC em janela e aí dá fluído mas quando o maximizo começa a dar pausas, ou seja, ligeiros "breaks" quando está a reproduzir os filmes. O sistema é o que está no My System (Q6600, 4 GB's, 8600 GT). Antes de instalar o SP1 tudo funcionava lindamente mas entretanto tive que o formatar e agora apareceu-me este problema irritante.

    Eu já estive a pensar e será que é problema das drivers? Acho um bocado estranho dado que as instalei há pouquissimo tempo, logo são recentes.

    EDIT: reparei agora que também não ouço as vozes nos filmes em .mkv.



    cumps
     
    Última edição: 4 de Maio de 2008
  2. Sion

    Sion Power Member

    Ninguém? :(
     
  3. almsousa

    almsousa Power Member

    Isso pode ser um problema/conflito de drivers da placa gráfica.
     
  4. Sion

    Sion Power Member

    E como é que eu resolvo isso?
     
  5. almsousa

    almsousa Power Member

    experimenta actualizar os drivers da placa gráfica
     
  6. Sion

    Sion Power Member

    Ja consegui resolver o problema do som e dos "breaks" no media center. Pelos vistos era problema dos drivers mais recentes da nvidia e tive que voltar aos 163. Em relação ao som instalei o CCCP (Combined Community Codec Pack) e já funciona tudo excepto as legendas. Supostamente aquilo vem com o VSFilter mas não aparecem legendas nos .mkv e eu nao sei porquê.





    cumps
     
  7. Sion

    Sion Power Member

  8. konexion

    konexion Power Member

    experiementa usar o programa VLC.
    Além de ter uns codecs proprios internos, é dos melhores (ou melhor) programas para lêr .mkv e permite usar legendas, basta arrastar as legendas para dentro da tela.
     
  9. Sion

    Sion Power Member

    Pois mas a dúvida é expressamente em relação ao media center. A solução do VLC já eu conhecia e uso no Mac mas no PC em questão uso o Media Center nao só pelo visual mas também porque só com o media center é que o comando funciona.




    cumps
     
  10. Sion

    Sion Power Member

    Ninguém sabe como resolver isto?



    cumps
     
  11. igordafonseca

    igordafonseca Power Member

    Para as legendas instala o Vobsub. Funciona em todos os leitores mas no Media Center não sei, tenta;)
     
  12. Sion

    Sion Power Member

    Ja tentei e não funcionou... O CCCP já vem com o VSFilter que é igualzinho ao VobSub mas mesmo assim eu instalei o VobSub e as legendas teimam em não aparecer no Media center.



    cumps
     
  13. igordafonseca

    igordafonseca Power Member

    Suponho que as legendas estão na mesma pasta que os filmes e com o mesmo nome certo?
    Vi algures que podes tenta forçar o ffdshow a dar as legendas.
     
  14. Sion

    Sion Power Member

    Estão. Como?
     
  15. Sion

    Sion Power Member

  16. igordafonseca

    igordafonseca Power Member

    Já deste uma vista de olhos na opção subtitles? E googla um pouco.
     
  17. slowdive

    slowdive Power Member

    O CCCP tem um fórum, talvez lá te possam ajudar...
     
  18. Leinad4Mind

    Leinad4Mind Power Member

    Se tens o CCCP (que por acaso é o melhor codec pack algumas vez criado), e dizes que não te aparece legendas, só tens de fazer o seguinte:

    vais ao Iniciar -> Executar (Run) e metes:
    regsvr32 "C:\Programas\Combined Community Codec Pack\Filters\VSFilter.dll"

    tal cm está e as legendas já deverão aparecer, isto se estiverem nas mesma pasta que o video, com o mesmo nome. Ou como é mkv, ela pode bem estar no proprio container, portanto basta no media player classic, clicares no bot. dir. do rato e vais a navigate e selecionas a legenda que keres.

    Cumps.
     
  19. ciberg

    ciberg Moderador
    Staff Member

    Eu também tenho o mesmo problema.
    Já tentei a solução do regsvr32 e não dá.

    No XP funciona perfeitamente, tanto os avi como os mkv abrem com o VSFilter (icon com uma seta verde) e mete legendas em todos, aqui no Vista SP1 tenho exactamente a mesma configuração e só nos avi é que arranca o VSFilter, nos mkv o VSFilter não arranca.

    O problema de forçar legendas no FFDShow é que ou ficam muito grandes nos avi ou muito pequenas nos mkv (por causa da diferença de resolução) ou então nos avi aparecem legendas em duplicado no caso dos avi (ficam as legendas do VSFilter e as do FFDShow).

    Para andar a mudar definições sempre que se vai ver um ficheiro perde-se a vantagem de um Media Center.

    Já alguém resolveu isto?
    -----------------------------------------------------------------------
    EDIT:
    Após muito andar no google descobri isto:

    - O Windows Media Player 11 não utiliza o DirectVobSub a reproduzir mkv (por isso funcionava no meu XP e não no Vista) - utilizando o Media Player Classic funciona tudo OK.

    - O Media Center utiliza o WMP11 como player default

    - Não encontrei forma de alterar o player default do Media Center
     
    Última edição: 26 de Maio de 2008
  20. almsousa

    almsousa Power Member

    Boas, também tive o mesmo problema com o SP1 e leitura de .mkv com o media center. para veres as legendas tens k seleccionar no ffshow a opçao para aparecerem as legendas
     

Partilhar esta Página