1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.
  2. Informação: Pela 0:30 desta Sexta-feira (9 de Dezembro, 23:30 de Quinta-feira nos Açores) o Fórum e restantes sites da ZWAME vão estar offline para manutenção durante cerca de 1h30.
    Se necessário faremos actualizações via Twitter e Facebook.
    Remover anúncio

Sem som no ubuntu

Discussão em 'Dúvidas e Suporte Técnico - GNU/Linux & *nix' iniciada por MCH2387, 21 de Abril de 2009. (Respostas: 20; Visualizações: 1987)

  1. MCH2387

    MCH2387 Power Member

    boas
    venho pedir ajuda para resolver um problema que afecta os dias de hoje
    tenho o ubuntu instalado e não tenho som nas colunas nem nos phones

    ando com este problema à muito tempo e está-me a impedir a maior independência em relação ao windows

    muito obrigado
     
  2. InforMed

    InforMed Power Member

    Qual a placa de som que tens?
     
  3. MCH2387

    MCH2387 Power Member

    este F6V

    segundo está na pagina: Built-in Azalia compliant audio chip, with 3D effect & full duplex
    Built-in speaker and microphone
    video:ATI Mobility™ Radeon® HD 3470, External

    **** Lista de Dispositivos de Hardware PLAYBACK ****
    placa 0: Intel [HDA Intel], dispositivo 0: ALC662 Analog [ALC662 Analog]
    Subdispositivos: 1/1
    Subdispositivo #0: subdevice #0
    placa 0: Intel [HDA Intel], dispositivo 1: ALC662 Digital [ALC662 Digital]
    Subdispositivos: 1/1
    Subdispositivo #0: subdevice #0
    placa 1: HDMI [HDA ATI HDMI], dispositivo 3: ATI HDMI [ATI HDMI]
    Subdispositivos: 1/1
    Subdispositivo #0: subdevice #0
     
  4. MCH2387

    MCH2387 Power Member

    Ajuda pff.

    estou a entrar em parafuso, será que se instalar o ubuntu 9.04 o problema fica resolvido?

    também já pensei mudar de distro mas isso seria o ultimo caso, ainda não sei bem o que escolher no caso dessa solução, qualquer coisa que me livre destas maleitas
     
    Última edição: 22 de Abril de 2009
  5. InforMed

    InforMed Power Member

    Tens que editar um ficheiro. Faz na consola

    sudo gedit /etc/modprobe.d/alsa-base

    e coloca dentro do ficheiro

    options snd-hda-intel model=auto

    O model corresponde ao teu modelo! Há mais opçãoes.. vê se a auto funciona se não depois pensamos em mais!
     
  6. MCH2387

    MCH2387 Power Member

    coloco: options snd-hda-intel ALC662 Analog=auto?

    não sei bem que parte meto no model

    obrigado
     
  7. InforMed

    InforMed Power Member

    Não... coloca exactamente o que escrevi!

    options snd-hda-intel model=auto

    O modelo só vai ser necessário se o auto não funcionar!
     
  8. MCH2387

    MCH2387 Power Member

    nao funciona LOLOL
    que desânimo
     
  9. InforMed

    InforMed Power Member

    Ok!

    Vamos então a algo mais complexo: http://ubuntuforums.org/showthread.php?t=616845&highlight=sound tens aqui a solução!

    Escreve no terminal cat /proc/asound/card0/codec#* | grep Codec

    e depois com o resultado pesquisa nesta lista o que deves colocar em vez de auto!

    Se preferires dá-me o que diz que eu ajudo-te o que deves escrever!
     
  10. InforMed

    InforMed Power Member

    Dado a placa que pareces ter dever ter que adicionar um desta lista

    3stack-dig 3-stack (2-channel) with SPDIF
    3stack-6ch 3-stack (6-channel)
    3stack-6ch-dig 3-stack (6-channel) with SPDIF
    6stack-dig 6-stack with SPDIF

    ou seja no que te disse a cima em vez de auto colocas por exemplo 3stack-6ch ficando por exemplo

    options snd-hda-intel model=3stack-6ch

    Percebeste?
     
  11. MCH2387

    MCH2387 Power Member

    percebi sim senhor, vou experimentar

    preciso de reiniciar de cada vez que mudo?

    muito obrigado

    o resultado da pesquisa é Codec: Realtek ALC662 rev1
     
    Última edição: 22 de Abril de 2009
  12. InforMed

    InforMed Power Member

    Sim reinicia de cada vez!

    Um dessa lista deve resultar...
     
  13. InforMed

    InforMed Power Member

    Parece que o correcto para o teu portatil é:

    options snd-hda-intel model=3stack-dig
     
  14. MCH2387

    MCH2387 Power Member

    voce é brilhante, a primeira funcionou, ja dá som, mas é aconselhavel experimentar essa ultima para ver se tem melhor resultado?

    muito muito obrigado
     
  15. InforMed

    InforMed Power Member

    Não perdes nada em experimentar!

    Ainda bem que pude ajudar!

    Um abraço! Fica bem!
     
  16. MCH2387

    MCH2387 Power Member

    funciona também, espectacular. não consegui perceber se havia diferenças

    muito obrigado
     
  17. MCH2387

    MCH2387 Power Member

    desculpa parece-me que ainda não está a 100%. quando meto a tocar nas colunas toca baixo em ralação ao que o windows costuma tocar

    será pelo model que meti?

    obrigado
     
  18. InforMed

    InforMed Power Member

    Não... isso deve ser mesmo do volume que tens nas definições do som... No menu do som vê o que tens em pcm, front, master, etc

    Ou então faz alsamixer no terminal e aumenta o volume desejado!
     
  19. MCH2387

    MCH2387 Power Member

    hmm ja vi e esta tudo no maximo, fico por aqui que fico bem

    muito obrigado
     
  20. InforMed

    InforMed Power Member

    alsamixer no terminal!

    Não acredito que no alsamixer esteja tudo no máximo :)
     

Partilhar esta Página