1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Servidor caseiro com WAMP

Discussão em 'Dúvidas e Suporte—Internet, Redes, Segurança' iniciada por rodmarcos, 7 de Março de 2013. (Respostas: 8; Visualizações: 1681)

  1. rodmarcos

    rodmarcos Power Member

    Boas.
    Gostava de saber se alguém daqui já conseguiu utilizar o WAMP de modo a um utilizador externo à nossa rede conseguir ver o site em que estamos a trabalhar.
    Já fiz isto imensas vezes, em vários ISPS, mas mudei recentemente para a MEO e não sou capaz de o fazer. Já fiz port forward da porta 80, e agora dá-me sempre erro... FORBIDDEN: You don't have permission to access / on this server.
    Alguém me consegue ajudar? O router é o Thomson TG784n.

    Obrigado.
     
  2. rodmarcos

    rodmarcos Power Member

  3. barricas

    barricas Power Member

    Se bem que me lembro o wamp tem uma opção para permitir sem ser local.
     
  4. Cfreitas

    Cfreitas Power Member

    Essa resposta FORBIDDEN é do router ou do servidor WAMP?
    Tenta ver isso.
     
  5. rodmarcos

    rodmarcos Power Member

    Estás a falar do Put Online?...

    Boa pergunta! É do servidor Wamp. Quando coloco o wamp online, dá-me esse erro forbidden. Quando retiro o wamp, dá-me erro "Oops! Google Chrome could not connect to 188.xxx.xxx.xxx".

    Thanks
     
  6. Cfreitas

    Cfreitas Power Member

    Então deve ser o WAMP que está a bloquear acessos externos à rede.
    Faz o que o barricas disse.

    cumps
     
  7. barricas

    barricas Power Member

    experimenta connectar-te por uma proxy (ex: webproxy hidemyass) ao teu IP público e vê se dá esse erro.
    Se funcionar, é o que o cfreitas tinha em mente ao perguntar se era do router...
     
  8. rodmarcos

    rodmarcos Power Member

    Okay. Obrigado a todos pela ajuda.
    Mesmo ligando-me pelo telemóvel, através da rede 3G, dava-me o mesmo erro forbidden. Após várias experimentações, consegui ultrapassar o problema da seguinte forma:
    1. Clicar no ícone do Wamp-> Apache -> httpd.conf
    2. Procurar onde diz: "Require local" e mudar para "Require all granted"

    #
    # Controls who can get stuff from this server.
    #
    # Online --> Require all granted

    # onlineoffline tag - don't remove

    Require local all granted


    </Directory>

    Done. :D
    Espero ajudar alguém no futuro com o mesmo tipo de problema.
     
  9. Cfreitas

    Cfreitas Power Member

    Sempre era o Server que estava a dar erro.

    Estive a fazer os meus próprios testes e vi que temos que colocar as permissões para cada directório, pelo menos dos que já existem (não sei como é para os directórios criados por nós). Por exemplo, se tiverem uma distribuição XAMP e quiserem acesso ao phpmyadmin fora da vossa máquina têm que fazer o passo que o rodmarcos descreveu para a phpmyadmin directory no ficheiro local.
    Espero que isso possa ajudar o pessoal.

    Cumps.
     

Partilhar esta Página