1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

servidor de FTP

Discussão em 'Dúvidas e Suporte—Internet, Redes, Segurança' iniciada por gangster, 7 de Fevereiro de 2008. (Respostas: 8; Visualizações: 1052)

  1. gangster

    gangster Power Member

    Boas.

    Tenho um servidor com o windows 2003 R2 server e montei um FTP Server la (Serv-U).

    Acontece que tenho um router na rede, e já mapiei as portas 20 (FTP_DATA) e 21 (FTP CONNETION) para o ip interno deste servidor.

    O que está a acontecer é que, dentro da rede interna consiguo aceder ao ftp, baixar files, upload, tudo, já se me ligar de fora, ele liga-se mas dou-lhe um "dir" ou "ls" e ele perde a ligação.

    Já tive isto a funcionar bem, mas depois de me mudarem o router de casa deixou de funcionar, mas que eu me lembro, eram so estas 2 portas que eu tinha abertas para este serviço.

    O router tem o uPNP activo, caso isto tenha haver.

    PS : Tb tentei com o FTP do IIS mas deu o memso erro.

    Obrigado
     
  2. RicardoMoreira

    RicardoMoreira Power Member


    Aparenta ter a ver da forma como está configurado o servidor e as portas abertas, mais propriamente se está a funcionar em passive ou active mode.
     
  3. gangster

    gangster Power Member

    Olá Violet

    Os meus cumprimentos.

    Se eu me ligar pela rede interna, tanto como activo ou passivo eu consiguo me ligar.

    Existe mais alguma coisa que te ocorra e que eu possa testar?

    Obrigado
     
  4. Make.Love

    Make.Love Banido

    quando comprei o router wireless e meti o router adsl em modo bridge... nunca mais consegui que o meu servidor de ftp funcionasse. Tenho as portas correctamente abertas, ja tentei de tudo e nada funcionou. Consigo colocar servidores de outras aplicações a correr sem problemas, mas ftp nunca mais deu.

    :(

    Andei durante meses testei tudo que é opção e nada resultou. Experimentei inclusive outros servidores de ftp, sem sucesso tambem.

    EDIT: o meu problema está nas portas passivas (parece que nao sao abertas da forma correcta para as ligaçoes externas). Eu tenho atribuida uma range de portas, para garantir que nao sao usadas outras.
     
    Última edição: 10 de Fevereiro de 2008
  5. Santo38

    Santo38 Power Member

    Eu penso que o vosso problema está no ISP e não nos vossos servidores... Liguem o vosso servidor directamente ao modem (ADSL/Cabo) e façam um acesso do exterior e verifiquem se conseguem aceder ou não. Alguns dos nossos ISP's no seu brilhante traffic shapping bloqueiam FTP inbound...

    Saudações
     
  6. Make.Love

    Make.Love Banido

    Santo38, no meu caso garanto a 100% que nao é do ISP, pois só com o Router ADSL funciona sem problemas. Segundo os logs do FTP, o cliente pára mesmo quando tenta entrar pelas portas passivas... ou seja, nao sao abertas de forma correcta :s
     
  7. Santo38

    Santo38 Power Member

    Que router tens? Já falas-te com o fabricante?

    Tenta criar no router uma DMZ e mete o IP do servidor FTP lá dentro...

    Saudações
     
  8. Make.Love

    Make.Love Banido

    fiz isso mas o router "agarrou". Tive que fazer reset e foi entao que lembrei-me de uma coisa ... o router tem um servidor de FTP gerido por ele e estava ligado.... desliguei e voilá... já funciona o meu ftp. :D

    o router é um Asus WL500g Premium.
     
  9. Santo38

    Santo38 Power Member

    As máquinas tem sempre razão!

    Saudações
     

Partilhar esta Página