1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Guia Sincronizar Router Cisco 2501 com servidor NTP

Discussão em 'Análises e Artigos - Internet, Redes e Segurança' iniciada por jorgebraga, 4 de Dezembro de 2008. (Respostas: 1; Visualizações: 5206)

  1. jorgebraga

    jorgebraga Power Member

    É possível sincronizar as horas dos dispositivos da nossa rede com a Hora Legal de Portugal.

    Isto permite termos o relógio dos nossos routers "acertado" pela hora em vigor em Portugal.

    Para loggar determinados eventos é importante que os dispositivos na rede tenham a sua hora sincronizada uns com os outros e com a hora legal do país onde se encontram.

    É possível também que dispositivos da nossa rede actuem eles próprios como servidores NTP para outros dispositivos (não é abordado neste tutorial mas é facilmente configurável).Eu configurei o meu router Cisco 2501 com os servidores NTP do Observatório Astronómico de Lisboa.

    É bastante simples:

    copenhaga>ena
    Password:***********
    copenhaga#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    copenhaga(config)#ntp ser
    copenhaga(config)#ntp server ntp02.oal.ul.pt
    Translating "ntp02.oal.ul.pt"...domain server (255.255.255.255) [OK]

    copenhaga(config)#ntp server ntp04.oal.ul.pt
    Translating "ntp04.oal.ul.pt"...domain server (255.255.255.255) [OK]

    copenhaga(config)#end

    Para ver a configuração:

    copenhaga#sh run
    Building configuration...

    Current configuration:
    !
    ! Last configuration change at 00:49:30 UTC Thu Dec 4 2008
    !
    version 12.0
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname copenhaga
    !
    enable secret 5 $1$Okmm$l2qMONdFOvb.KoL1Gydss.
    !
    ip subnet-zero
    no ip routing
    !
    !
    !
    interface Ethernet0
    ip address 192.168.1.3 255.255.255.0
    no ip directed-broadcast
    ip accounting output-packets
    no ip route-cache
    no ip mroute-cache
    !
    interface Serial0
    ip address 192.168.1.1 255.255.255.0
    no ip directed-broadcast
    no ip route-cache
    no ip mroute-cache
    no fair-queue
    !
    interface Serial1
    no ip address
    no ip directed-broadcast
    no ip route-cache
    no ip mroute-cache
    shutdown
    !
    ip default-gateway 192.168.1.1
    ip classless
    !
    banner motd ^COla Macnet^C
    !
    line con 0
    transport input none
    line aux 0
    line vty 0 4
    login
    !
    ntp clock-period 17179845
    ntp server 194.117.9.136
    ntp server 194.117.9.130
    end

    copenhaga#

    Se este router não for o gateway para a Internet, isto é, se este router para se ligar à Internet precisar de estar a ligado a outro router, devem configurar o gateway do seguinte modo:

    copenhaga#
    copenhaga#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    copenhaga(config)#ip default-gateway 192.168.1.1


    Claro que também têm de ter a interface Ethernet do router configurada com um IP válido. No meu caso esta é a minha configuração:

    copenhaga#sh ip int brief
    Interface IP-Address OK? Method Status Protocol
    Ethernet0 192.168.1.3 YES NVRAM up up
    Serial0 192.168.1.1 YES NVRAM down down
    Serial1 unassigned YES unset administratively down down

    Agora indo ver as horas podemos comprovar que o Router está sincronizado:

    copenhaga#sh clock detail
    01:09:01.778 UTC Thu Dec 4 2008
    Time source is NTP
    copenhaga#

    comandos NTP úteis:
    show ntp status
    show ntp associations

    Espero que tenha ajudado!

    Se tiverem questões coloquem comentários.
     
    Última edição pelo moderador: 6 de Dezembro de 2008
  2. redowk

    redowk Power Member

    Estes comandos lazem log pelo uptime o que pode compliar um bocado se for preciso debugging
    Usa antes:

    service timestamps log datetime localtime
    service timestamps debug datetime localtime
    Para fazer log pelo clock da antena, que podes verificar com o comando "show clock"

    Para ultrapassares o problema do horário de verão podes usar:

    clock timezone GMT 0
    clock summer-time GMT recurring
     

Partilhar esta Página