1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

[Solucionado]NTLDR is missing: já não sei o que fazer

Discussão em 'Dúvidas e Suporte Técnico PC' iniciada por Shakawkaw, 6 de Maio de 2005. (Respostas: 8; Visualizações: 2747)

  1. Shakawkaw

    Shakawkaw Suspenso

    Boas,
    o meu PC anda a dar-me outra vez problemas.
    Quando ia fazer o update das musicas no meu iPod, ligando através de Firewire fiquei sem imagem, como o pc não respondia, fiz reset. Quando ia aceder ao disco deu-me um erro: NTLDR is missing.
    Eu já tentei fazer repair através do cd do windows, mas assim que ele examina o disco dá-me um BSOD com erro no ntfs.sys. A mesma coisa se simplesmente tentar aceder ao disco através do cd do windows.
    Pesquisei pela net, e a solução que indicavam (criação de uma boot disk com o ntldr e ntdetect.com além de um boot.ini) não funciona, dando o mesmo erro. Entretanto decido sacar o disco de outro pc para fazer o boot através do XP desse disco, e apareceu-me o ecran a dizer que uma das minhas drives tinha de ser verificada, ao qual fiz skip (não quero que me encha de lixo uma drive cheia de informação importante), após isso aparece-e o tal BSOD de erro no ntfs.sys, não fazendo boot ao sistema operativo mesmo através de outros disco.
    Nem consigo fazer um fdisk /mbr...
    Quando aconeceu isto tudo, logo após ligar o iPod, o windows mostrou-me uma mensagem a dizer que ficheiros de sistema tinham sido alterados e se eu queria restaura-los através do cd do windows, ao qual respondi que não (se arrependimento matasse... ).
    Sinceramente já não sei o que fazer, o disco está carregado de informação importante, da qual não tenho backups (ia fazer este fds :( ), e preciso do PC operacional rapidamente...

    Alguém pode ajudar-me?

    Obrigado

    P.S. - Desculpem se não fui muito claro, mas a esta hora não dá mais... e tenho de me levantar às 8h :( :( :(
     
    Última edição: 6 de Maio de 2005
  2. Barata

    Barata I folded Myself

    Na BIOS revê a prioridade do Boot!

    LOL, bem sei que isto parece mto vago, mas peço desculpa pela hora...uma vez que estou a chegar do Enterro da UA! :x2:
     
  3. Forgotten

    Forgotten Banido

    poderá ser o disco a dar sinal :( , tenta um check disk
     
  4. kazuza

    kazuza Power Member

    Instala a consola de recuperação e faz

    fix mbr

    Depois faz:

    chkdsk c: /r /f (vai demorar umas horitas... )
     
  5. CrONiK

    CrONiK 1st Folding then Sex

    Boas
    Já me apareceram na loja 2 maquinas com esse problema e em 1 era a partição do disco k se tinha apagado, no 2º era os controladores IDE da board k tavam na sucata, agr no teu caso pode ser outra coisa *****...

    []'z :003:
     
  6. Shakawkaw

    Shakawkaw Suspenso

    @Barata - O boot priority da Bios está bem configurado.

    @Prodigy & kazuza - O problema é que não consigo achar nenhuma maneira de aceder ao disco. Não consigo aceder à consola de reparação através do cd do XP, que ele dá-me o tal BSOD do ntfs.sys... :(

    Já tinha tido um problema parecido com este antes, mas ai consegui aceder através de outro disco e com GetDataBack recuperar os dados (dessa vez tinham ido os sistemas de ficheiros à vida), mas agora nem consigo aceder através de outro disco... :(
     
  7. DekkeR

    DekkeR Power Member

    Experimenta correr um Linux Live CD para ganhares acesso à partição e conseguir fazer backup dos dados.
     
  8. Shakawkaw

    Shakawkaw Suspenso

    Já estou a sacar o Knoppix... agora é que de facto me fez jeito os 4Mbps, tou a sacar a 330K/s... ;)
    Mas antes vou experimentar outra solução, após muito pesquisar encontrei aqui alguém com o mesmo problema que eu tenho, e parece que conseguiu resolver com uma boot disk de uma aplicação chamada NTFSchk. Vou experimentar, depois posto aqui o resultado. É só deixar acabar o download do Knoppix, que em todo o caso fica cá para quando for necessário... ;)
     
  9. Shakawkaw

    Shakawkaw Suspenso

    Funcionou... :D :D :D :D :D
    Fiquei tão contente que vou criar uma página com a descrição do problema e respectiva solução, com o utilitário lá para download... :D
    Infelizmente o check do windows já me tinha enchido a drive c: com lixo, e o sistema dá erro a iniciar, mas o disco já está a 100%. Nem sequer vou arriscar a uma recovery install, vou fazer backup de tudo através do outro disco e fazer um clean install (isto vai ser chato para as configurações dos serviços que tinha feito para uma cadeira: JDK->Tomcat->Tomcat HTTPS->JWSDP->Bouncy Castle->MySQL->CVS->Eclipse->Eclipse plugins :( ).
    Foi um alivio de todo o tamanho, mas aquela boot disk milagrosa tratou do assunto em menos de 1min (não se admite, perde um tipo horas à procura de uma solução que demora 1min a processar :D )

    Estou tão contente que só devo tar aqui a dizer asneira, devo parecer um miudo que acabou de perder a virgindade... :P :D

    Obrigado a todos pela ajuda e disponibilidade... ;)

    EDIT: Agora é backup, backup e backup... ;)
     
    Última edição: 6 de Maio de 2005

Partilhar esta Página