1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

su: senha incorreta no ssh

Discussão em 'Novidades GNU/Linux & *nix World' iniciada por jbrasil, 23 de Março de 2007. (Respostas: 18; Visualizações: 1625)

  1. jbrasil

    jbrasil Power Member

    Colegas,
    Boa tarde !
    Instalei o ssh no mandriva free 2007.
    Versão: OpenSSH_4.5p1, OpenSSL 0.9.8b 04 May 2006
    Configurei no arquivo sshd_config o seguinte paramêtro:
    AllowUsers jbrasil
    Conecto via ssh, com meu usuário (jbrasil)
    Ao mudar para root, ocorre senha incorreta.
    [[email protected] ~]$ su - root
    Password:
    su: senha incorreta
    Obs: Não estou digitando a senha errada.
    Consigo logar com user root, no prompt do linux.
    É alguma configuração que tenho que fazer no sshd_config ?
    Muito estranho, nunca vi isto.
    Obrigado pela ajuda.
    José Roberto.
     
  2. spastikman

    spastikman Banido

    verifica se estás na wheel ...
     
  3. Prodigy

    Prodigy Suspenso

    Verifica no sshd_config, se tem permisão para logar como root por ssh, e tenta apenas "su -".
     
  4. PrOdG

    PrOdG Power Member

    Duvido que tenha alguma coisa a ver com o ssh.. Tens acesso físico à máquina onde te estás a ligar? Se sim, consegues fazer a mesma operação (mudar de jbrasil para root) ?

    E como disse o Prodigy, não precisas de escrever "root", basta "su -".
     
  5. Mektub

    Mektub Power Member

    No sshd_config existe o parametro: PermitRootLogin yes

    No entanto não creio que tenha ver com isso como já disse o PrOdG.

    Mektub
     
  6. PrOdG

    PrOdG Power Member

    Esse parâmetro PermitRootLogin impede ou permite que se façam ligações do género ssh [email protected], não tem nada a ver com o que se pode ou não fazer dentro da sessão. E, excepto em casos muito especiais, deve estar desactivada por default.

    Continuo é a achar que, se a sessão já está inicializada, não tem nada a ver com o ssh.
     
  7. jbrasil

    jbrasil Power Member

    Então,
    Aparentemente a permissão está correta no arquivo sshd_config
    -rw-r--r-- 1 root root 3,1K Mar 23 14:32 sshd_config

    Mesmo estando fisicamente na máquina, logo com o user jbrasil, ao passar para root ( su - ) ocorre a mesma mensagem...
    Obrigado.
    José Roberto.
     
  8. PrOdG

    PrOdG Power Member

    As permissões de acesso ao ficheiro é uma coisa diferente :P

    Se tens exactamente o mesmo problema ao aceder fisicamente à máquina então o problema não é do SSH. Das duas uma, ou não estás no grupo wheel (não sei qual é a mensagem de erro nessa situação) ou estás-te a enganar na password.
     
  9. jbrasil

    jbrasil Power Member

    Coloquei o user jbrasil no grupo wheel, porém não deu certo.

    [[email protected] etc]# less /etc/group | grep wheel
    wheel:x:10:jbrasil

    Não estou digitando a senha errada....

    Veja o arquivo de configuração sshd_config
    Algum parâmetro a ser alterado ?
    Obrigado pela ajuda.
    José Roberto.

    # $OpenBSD: sshd_config,v 1.74 2006/07/19 13:07:10 dtucker Exp $
    # This is the sshd server system-wide configuration file. See
    # sshd_config(5) for more information.
    # This sshd was compiled with PATH=/usr/local/bin:/bin:/usr/bin
    # The strategy used for options in the default sshd_config shipped with
    # OpenSSH is to specify options with their default value where
    # possible, but leave them commented. Uncommented options change a
    # default value.
    Port 22
    #Protocol 2,1
    Protocol 2
    #AddressFamily any
    ListenAddress 10.0.0.102
    ListenAddress 10.1.0.50
    # HostKey for protocol version 1
    HostKey /etc/ssh/ssh_host_key
    # HostKeys for protocol version 2
    HostKey /etc/ssh/ssh_host_rsa_key
    HostKey /etc/ssh/ssh_host_dsa_key
    # Lifetime and size of ephemeral version 1 server key
    #KeyRegenerationInterval 1h
    #ServerKeyBits 768
    # Logging
    # obsoletes QuietMode and FascistLogging
    #SyslogFacility AUTH
    #LogLevel INFO
    # Authentication:
    #LoginGraceTime 2m
    PermitRootLogin no
    #StrictModes yes
    #MaxAuthTries 6
    #RSAAuthentication yes
    #PubkeyAuthentication yes
    #AuthorizedKeysFile .ssh/authorized_keys
    # For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
    #RhostsRSAAuthentication no
    # similar for protocol version 2
    #HostbasedAuthentication no
    # Change to yes if you don't trust ~/.ssh/known_hosts for
    # RhostsRSAAuthentication and HostbasedAuthentication
    #IgnoreUserKnownHosts no
    # Don't read the user's ~/.rhosts and ~/.shosts files
    #IgnoreRhosts yes
    # To disable tunneled clear text passwords, change to no here!
    PasswordAuthentication yes
    PermitEmptyPasswords no
    # Change to no to disable s/key passwords
    #ChallengeResponseAuthentication yes
    # Kerberos options
    #KerberosAuthentication no
    #KerberosOrLocalPasswd yes
    #KerberosTicketCleanup yes
    #KerberosGetAFSToken no
    # GSSAPI options
    #GSSAPIAuthentication no
    #GSSAPICleanupCredentials yes
    # Set this to 'yes' to enable PAM authentication, account processing,
    # and session processing. If this is enabled, PAM authentication will
    # be allowed through the ChallengeResponseAuthentication and
    # PasswordAuthentication. Depending on your PAM configuration,
    # PAM authentication via ChallengeResponseAuthentication may bypass
    # the setting of "PermitRootLogin without-password".
    # If you just want the PAM account and session checks to run without
    # PAM authentication, then enable this but set PasswordAuthentication
    # and ChallengeResponseAuthentication to 'no'.
    #UsePAM no
    #AllowTcpForwarding yes
    #GatewayPorts no
    X11Forwarding yes
    #X11DisplayOffset 10
    #X11UseLocalhost yes
    #PrintMotd yes
    #PrintLastLog yes
    #TCPKeepAlive yes
    #UseLogin no
    UsePrivilegeSeparation yes
    #PermitUserEnvironment no
    #Compression delayed
    #ClientAliveInterval 0
    #ClientAliveCountMax 3
    #UseDNS yes
    #PidFile /var/run/sshd.pid
    #MaxStartups 10
    #PermitTunnel no
    # no default banner path
    #Banner /some/path
    # override default of no subsystems
    Subsystem sftp /usr/lib/ssh/sftp-server
    AllowUsers jbrasil
    # Example of overriding settings on a per-user basis
    #Match User anoncvs
    # X11Forwarding no
    # AllowTcpForwarding no
    # ForceCommand cvs server
     
  10. Prodigy

    Prodigy Suspenso

    Se querias entrar como "root"

    PermitRootLogin no

    Altera para

    PermitRootLogin yes

    Contúdo poderá não ser disso, mas não custa tentar ;)
     
    Última edição: 26 de Março de 2007
  11. jbrasil

    jbrasil Power Member

    Quero entrar com user: jbrasil
    Consigo autenticar com user: jbrasil via SSH.
    O problema está em passar para root, no prompt do linux (via SSH).
    su -
    ou
    su - root
    Obrigado.
    José Roberto.
     
  12. jbrasil

    jbrasil Power Member

    Colegas,
    Boa tarde !
    Não sei se comentei na lista...
    Mas estando fisicamente na máquina, e logando com usuário comum (jbrasil) também não consigo alterar para root
    Ocorre a mesma mensagem: senha inválida
    Estou achando que o linux, está bloqueando alguma coisa.
    Detalhe: não informa nada nos logs:

    /var/log/messages
    /var/log/syslog
    /var/log/auth.log
    /var/log/user.log
    Caraca, um assunto simples.. vira um bicho de sete cabeça.
    :-(
    Alguma dica ?
    Muito obrigado pela ajuda.
    []'s
    J. Roberto.
     
  13. PrOdG

    PrOdG Power Member

    Esquece o SSH, o problema não está aí.

    Sinceramente se tens a certeza que a password está correcta, não estou mesmo a ver o que possa ser. Posta aí os conteúdos do ficheiro etc/group . Pode ser que ajude.
     
  14. luxitan

    luxitan Power Member

    vê se no ficheiro de sudoers (/etc/sudoers) tens a linha :
    %wheel ALL=(ALL) ALL


    então podes fazer 'sudo su' em vez de su
     
  15. jbrasil

    jbrasil Power Member

    Amigo,
    Segue abaixo:

    root:x:0:
    bin:x:1:
    daemon:x:2:messagebus,haldaemon
    sys:x:3:
    adm:x:4:
    tty:x:5:
    disk:x:6:
    lp:x:7:
    mem:x:8:
    kmem:x:9:
    wheel:x:10:jbrasil
    mail:x:12:
    news:x:13:
    uucp:x:14:
    man:x:15:
    floppy:x:19:
    games:x:20:
    tape:x:21:
    cdrom:x:22:
    utmp:x:24:
    usb:x:43:
    cdwriter:x:80:
    audio:x:81:
    video:x:82:
    users:x:100:
    nogroup:x:65534:
    rpm:x:101:
    vcsa:x:69:
    xgrp:x:102:xfs
    ntools:x:103:
    ctools:x:104:
    messagebus:x:70:
    haldaemon:x:71:
    avahi:x:72:
    xfs:x:73:
    postfix:x:74:
    postdrop:x:105:postfix
    nobody:x:106:
    clamav:x:75:
    slocate:x:107:
    yujo:x:500:
    jbrasil:x:501:
    sshd:x:76:
    squid:x:502:
    ntp:x:77:
    nagios:x:503:
    backup:x:504:
    teste:x:505:

    Muito obrigado.
    José Roberto.
     
  16. khaluh

    khaluh Power Member

    Viva.

    Estou com um problema semelhante.

    Aproveitando as aulas que tenho de Linux, resolvi fazer os exercicios em casa e precisei de ir para o root.

    (Eu nas aulas uso o FC6 e em casa tenho o Ubuntu 6.10, mas penso que os comandos sao iguais, certo?)

    Entro com a minha pass normal, na "consola" faço su e, ao pedir a palavra pass, diz que é a errada, só nao me lembro se na instalação ele pediu para colocar palavra chave para root ou não... Mas se ele pediu, estou certo que coloquei a palavra que tento usar (uso a mesma para estas coisas de Linux, tanto casa como aulas para evitar confusões)...

    A questão é: há possibilidade de conseguir ir ao root ou alterar a pass do root?
     
  17. spastikman

    spastikman Banido



    yup

    no grub/lilo, inicia o o kernel acrescentando um "0" Zero.

    ex:

    linux 0
    vmlinux 0

    ou zero, ou então acrescenta "init=/bin/bash".

    Quando entrares na consola, digita passwd, e muda a password.
     
  18. luxitan

    luxitan Power Member

    no ubuntu o root não tem pass (ou tem uma aleatoria). Faz sudo su (usa a tua pass) e depois passwd para mudares a de root.
     
  19. jbrasil

    jbrasil Power Member

    Amigos,
    Boa tarde !
    Problema resolvido...
    Solução: instalar o múdulo coreutils:5.97.5-1.mdv2007.0
    hehehehe
    :-)
    Valeu...
    Gostaria de agracer pela ajuda de todos.
    Muito Obrigado.
    José Roberto.
     

Partilhar esta Página