1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

[Tutorial] Instalar o modem 3G Huawei E600 (Kanguru) em Ubuntu 6.06

Discussão em 'Novidades GNU/Linux & *nix World' iniciada por souto, 21 de Junho de 2006. (Respostas: 3; Visualizações: 7068)

  1. souto

    souto To fold or to FOLD?

    Viva,

    Encontrei um guia similar a este pela internet, já nao sei onde. De qualquer maneira ficam aqui as instrucções por alto, do que se deve fazer.

    Passo 1: Inserir o cartão:


    Antes de inserir o cartão, escrever num terminal o seguinte:
    Código:
    tail -f /var/log/messages
    Assim, poderemos ver o que se passa quando inserirmos o cartão 3G no slot PCMCIA.

    Deve aparecer na consola uma série de texto, qualquer coisa deste género:
    Código:
    Jun 21 13:35:52 localhost kernel: [17191910.432000] pccard: CardBus card inserted into slot 1
    Jun 21 13:35:52 localhost kernel: [17191910.432000] PCI: Enabling device 0000:06:00.0 (0000 -> 0002)
    Jun 21 13:35:52 localhost kernel: [17191910.432000] ACPI: PCI Interrupt 0000:06:00.0[A] -> Link [LNKD] -> GSI 9 (level, low) -> IRQ 9
    Jun 21 13:35:52 localhost kernel: [17191910.432000] ohci_hcd 0000:06:00.0: OHCI Host Controller
    Jun 21 13:35:52 localhost kernel: [17191910.432000] ohci_hcd 0000:06:00.0: new USB bus registered, assigned bus number 3
    Jun 21 13:35:52 localhost kernel: [17191910.432000] ohci_hcd 0000:06:00.0: irq 9, io mem 0x26000000
    Jun 21 13:35:52 localhost kernel: [17191910.520000] hub 3-0:1.0: USB hub found
    Jun 21 13:35:52 localhost kernel: [17191910.520000] hub 3-0:1.0: 1 port detectedJun 21 13:35:52 localhost kernel: [17191910.624000] PCI: Enabling device 0000:06:00.1 (0000 -> 0002)
    Jun 21 13:35:52 localhost kernel: [17191910.624000] ACPI: PCI Interrupt 0000:06:00.1[B] -> Link [LNKD] -> GSI 9 (level, low) -> IRQ 9
    Jun 21 13:35:52 localhost kernel: [17191910.624000] ohci_hcd 0000:06:00.1: OHCI Host Controller
    Jun 21 13:35:52 localhost kernel: [17191910.624000] ohci_hcd 0000:06:00.1: new USB bus registered, assigned bus number 4
    Jun 21 13:35:52 localhost kernel: [17191910.624000] ohci_hcd 0000:06:00.1: irq 9, io mem 0x26001000
    Jun 21 13:35:52 localhost kernel: [17191910.708000] hub 4-0:1.0: USB hub found
    Jun 21 13:35:52 localhost kernel: [17191910.708000] hub 4-0:1.0: 1 port detectedJun 21 13:35:53 localhost kernel: [17191911.432000] usb 3-1: new full speed USB device using ohci_hcd and address 2
    Jun 21 13:35:53 localhost kernel: [17191911.648000] option 3-1:1.0: Option 3G data card converter detected
    Jun 21 13:35:53 localhost kernel: [17191911.648000] usb 3-1: Option 3G data card converter now attached to ttyUSB0
    Jun 21 13:35:53 localhost kernel: [17191911.652000] option 3-1:1.1: Option 3G data card converter detected
    Jun 21 13:35:53 localhost kernel: [17191911.652000] usb 3-1: Option 3G data card converter now attached to ttyUSB1
    Jun 21 13:35:53 localhost kernel: [17191911.656000] option 3-1:1.2: Option 3G data card converter detected
    Jun 21 13:35:53 localhost kernel: [17191911.656000] usb 3-1: Option 3G data card converter now attached to ttyUSB2
    No meu caso, interessa-me o dispositivo ttyUSB0. isto nao deve variar.

    Após termos feito isto, está na altura de configurarmos a ligação.

    Escrever na consola
    Código:
    sudo pppconfig
    Depois, escolher a opção para criar uma nova ligação, com os seguintes dados: (poderão não ser pedidos na ordem que escrevi):

    Dynamic DNS
    PAP Protocol
    Username é o numero do cartão, password é o PIN
    O número de telefone a marcar é *99***1#
    O programa vai dizer que pode detectar automaticamente a porta onde o modem está ligado; no meu caso não detectou; como tal usei o dispositivo /dev/ttyUSB0 (case sensitive)

    Guardar os dados, fazer quit, the end.

    Para activar a ligação:

    Código:
    $ pon 'nome da ligacao'
    Para desactivar a ligação:

    Código:
    $ poff 'nome da ligacao'
    Para ejectar o 3G card:

    Código:
    $ sudo cardctl eject
    É extremamente importante que se execute este último comando antes de se sacar a placa; quem não fizer isto arrisca-se a danificar a placa.

    Cumprimentos.
     
  2. Problemas

    boas,

    fiz exactamente o que vem descrito aqui e não obtive nenhuma mensagem de erro, mas depois de fazer "pon..." abro o Firefox e não tenho ligação, nem consigo pingar nenhum IP, será que há forma de verificar se a ligação está a funcionar ou não?

    Entretanto já experimentar com o Network Propreties e até com o Knoppix e o erro é na ligação quando faz o ATDT*99***1#.

    Já verifiquei nas propriedades do Windows e é mesmo este o número.

    Será que alguém me pode ajudar????

    os erros que tenho são

    Jul 26 21:47:17 ubuntu pppd[7312]: pppd 2.4.4b1 started by root, uid 0
    Jul 26 21:47:19 ubuntu chat[7313]: timeout set to 60 seconds
    Jul 26 21:47:19 ubuntu chat[7313]: abort on (ERROR)
    Jul 26 21:47:19 ubuntu chat[7313]: abort on (BUSY)
    Jul 26 21:47:19 ubuntu chat[7313]: abort on (VOICE)
    Jul 26 21:47:19 ubuntu chat[7313]: abort on (NO CARRIER)
    Jul 26 21:47:19 ubuntu chat[7313]: abort on (NO DIALTONE)
    Jul 26 21:47:19 ubuntu chat[7313]: abort on (NO DIAL TONE)
    Jul 26 21:47:19 ubuntu chat[7313]: abort on (NO ANSWER)
    Jul 26 21:47:19 ubuntu chat[7313]: send (ATZ^M)
    Jul 26 21:47:19 ubuntu chat[7313]: send (AT&FH0M0^M)
    Jul 26 21:47:19 ubuntu chat[7313]: expect (OK)
    Jul 26 21:47:19 ubuntu chat[7313]: ATZ^M^M
    Jul 26 21:47:19 ubuntu chat[7313]: OK
    Jul 26 21:47:19 ubuntu chat[7313]: -- got it
    Jul 26 21:47:19 ubuntu chat[7313]: send (ATDT*99***1#^M)
    Jul 26 21:47:19 ubuntu chat[7313]: timeout set to 75 seconds
    Jul 26 21:47:19 ubuntu chat[7313]: expect (CONNECT)
    Jul 26 21:47:19 ubuntu chat[7313]: ^M
    Jul 26 21:47:19 ubuntu chat[7313]: AT&FH0M0^M^M
    Jul 26 21:47:19 ubuntu chat[7313]: ERROR
    Jul 26 21:47:19 ubuntu chat[7313]: -- failed
    Jul 26 21:47:19 ubuntu chat[7313]: Failed (ERROR)
    Jul 26 21:47:20 ubuntu pppd[7312]: Exit.


    Tks

    delgas
     
    Última edição: 27 de Julho de 2006
  3. guilherme

    guilherme Power Member

    Essas placas sao mais antigas ou mais recentes que as merlin u740? é q o meu kit da kanguru veio com uma merlin e nao consigo por a funcionar de modo nenhum n atribui a nenhuma tty, mas reconhece que foi introduzida uma placa
     

Partilhar esta Página