[Tutorial] Tutoriais para Ubuntu 8.04 hardy

rj.rodrigues

Power Member
Como Instalar a placa gráfica e activar os efeitos do compiz

Tudo muito bem explicado aqui: pag1 pag2
Caso não funcione, mas ao executar o seguinte comando comando na consola
Código:
glxinfo | grep "direct rendering"
ele responde com: << $direct rendering: Yes >> veja o tutorial a baixo deste

Caso obtenha << $direct rendering: No >> tente da seguinte maneira:
instalar o envy
Código:
sudo apt-get install envyng-gtk
sudo envyng-gtk
E instale os drivers da gráfica pelo envy

-------------------------------------------------------------------

Colocar o compiz a funcionar em algumas placas da ati que ficaram na blacklist

Bem subitamente o compiz parou de funcionar em algumas placas da ATI no Ubuntu 8.04 hardy
Provavelmente a sua placa ficou na blacklist do novo compiz
Para porem novamente a funcionar basta seguirem os seguintes passos:
Na consola:
Código:
mkdir -p ~/.config/compiz/ && echo SKIP_CHECKS=yes >> ~/.config/compiz/compiz-manager
Código:
gksudo gedit /usr/bin/compiz
e adicionar o seguinte:
Código:
SKIP_CHECKS="yes"
eu adicionei por de baixo de: VERBOSE="yes"

e agora devem estar prontos para por os efeitos novamente activos

-------------------------------------------------------------------

Como resolver o problema do som no Firefox 3 beta

Código:
sudo aptitude purge libflashsupport
sudo aptitude install build-essential automake1.9 autoconf libtool libesd0-dev libpulse-dev libssl-dev git
git clone http://git.0pointer.de/repos/libflashsupport.git/
cd libflashsupport
./bootstrap.sh --prefix=/usr
make
sudo make install
sudo ldconfig
Reiniciar o Firefox e testar.
@link
Creditos: iGama

-------------------------------------------------------------------

Instalar codecs de áudio e vídeo

Código:
echo "deb http://packages.medibuntu.org/ hardy free non-free" | sudo tee -a /etc/apt/sources.list
wget -q http://packages.medibuntu.org/medibuntu-key.gpg -O- | sudo apt-key add - && sudo apt-get update
Código:
sudo aptitude install w32codecs ffmpeg
Ainda ficam com acesso a varios pacotes:
Código:
    *  Acrobat Reader
    * Google Earth
    * IBM Java Runtime Environment
    * SUN Java Runtime Environment
    * Opera
    * Real Player
    * Skype 
    * bmp-wma
    * xmms-wma
-------------------------------------------------------------------

Adicionar as fonts da Microsoft

Promeiro é preciso activar os repositórios Unviverse e Multiverse. Se não sabe pode ver aqui
Código:
sudo apt-get install xfonts-intl-european
sudo apt-get install gsfonts-x11
sudo apt-get install msttcorefonts
sudo fc-cache -f -v
sudo cp /etc/fonts/local.conf /etc/fonts/local.conf_backup
sudo gedit /etc/fonts/local.conf
procure por "Uncomment below to enable the freetype autohinter module"
e remova os comentarios
mais info @link
Se quiser as fonts do Vista basta seguir o que diz aqui

-------------------------------------------------------------------

Mouse multi-botões no Linux

-------------------------------------------------------------------

AMSN + TCL/TK + Cold Skin
Aqui e no seguinte

-------------------------------------------------------------------

Resolver o problema do wireless lento no hardy

-------------------------------------------------------------------

Quem quiser contribuir com tutorias poste abaixo
Aguardem por mais
:)
 
Última edição:

Parafuso

Power Member
Mouse multi-botões no Linux

Por exemplo os botões laterais “Avançar” e “Voltar” — que uso frequentemente para navegação no histórico de páginas web (Firefox) — do meu rato Logitech MX700 deixaram de funcionar.

Eis o que se deve fazer...

Primeiro, assegure-se de ter instalado o pacote xserver-xorg-input-evdev referente ao driver evdev. Se necessário, instale o pacote.
Você pode fazer isso graficamente pelo Gerenciador de Pacotes Synaptic (menu Sistema -> Administração) ou por linha de comando:

sudo apt-get install xserver-xorg-input-evdev

Depois, localize o nome exacto do dispositivo do seu rato.

cat /proc/bus/input/devices

No meu caso, para o Logitech MX700 encontrei N: Name=”PS2++ Logitech MX Mouse”.

Depois, edite o arquivo de configuração do X11. Antes disso, faça uma cópia de segurança.

sudo bash
cd /etc/X11/
cp -p xorg.conf xorg.conf.backup
gedit xorg.conf

Comente a configuração de InputDevice anteriormente existente para o rato e adicione uma nova similar a esta, usando o driver evdev (minha configuração anterior usava o driver rato):

Section "InputDevice"
Identifier "Logitech MX700"
Driver "evdev”
Option “Name” “PS2++ Logitech MX Mouse”
Option “HWHEELRelativeAxisButtons” “7 6″
EndSection

O Identifier pode ser livremente escolhido por você. Se o seu rato é outro modelo, substitua pelo nome mais apropriado. Já a opção “Name” deve receber exactamente o mesmo nome encontrado no arquivo de devices.

Ainda no arquivo xorg.conf, localize a secção ServerLayout, verifique e actualize a linha InputDevice relativa ao rato. O nome do InputDevice deve ser o exacto Identifier do rato que você definiu.

Section "ServerLayout"
...
Inputdevice "Logitech MX700"
...
EndSection

Salve o arquivo xorg.conf.

Pronto. Reinicie o X11, saindo (logout) e entrando novamente, para activar as novas configurações.

Para testar o funcionamento de todos os botões e controles do rato no driver evdev, você pode usar a aplicação gráfica xev. Execute a partir de uma janela de comando, pois as informações de eventos gerados na janela gráfica de teste aparecem em texto no console.

Uma observação: Vi em alguns fóruns que a opção Option "CorePointer" não deve ser usada na secção InputDevice com o evdev. No meu caso, realmente testei adicionar esta opção e o meu rato ficava completamente inoperante com ela.
 

pedropcruz

Power Member
epa nao e por nd mas.. isto e obvio ser um tutorial de?.. Ubuntu sim ja percebi.. mas isso nao explika kuase nd pah...

Tipo a ppl k nao sbe mexer mm no Ubuntu.. nao sabem onde ir ali ou ali.. nao e configs pah... axo eu... eu por exemplo nao sei... mas isso tb prk sou loiro :P...

CumpZ

RiTuAiS
 

hasta.g5

I quit My Job for Folding
epa nao e por nd mas.. isto e obvio ser um tutorial de?.. Ubuntu sim ja percebi.. mas isso nao explika kuase nd pah...

Tipo a ppl k nao sbe mexer mm no Ubuntu.. nao sabem onde ir ali ou ali.. nao e configs pah... axo eu... eu por exemplo nao sei... mas isso tb prk sou loiro :P...

CumpZ

RiTuAiS

Um tutorial é para o que é. Este é para configurar o Ubuntu 8.04.

Não tem sentido fazer um tutorial para ir ali ou ali no Ubuntu. Se não sabes ir ali ou ali no Ubuntu, não sabes em mais nenhuma distro.
Mas recursos para aprender a ir ali ou ali não faltam na Techzone, repara nos tópicos em sticky:

  • [THREAD=115660]Ler antes de criar novo tópico sff[/THREAD]
  • [THREAD=175758]Introdução ao GNU/Linux & *nix World - Como começar [/THREAD]
 

pedropcruz

Power Member
Um tutorial é para o que é. Este é para configurar o Ubuntu 8.04.

Não tem sentido fazer um tutorial para ir ali ou ali no Ubuntu. Se não sabes ir ali ou ali no Ubuntu, não sabes em mais nenhuma distro.
Mas recursos para aprender a ir ali ou ali não faltam na Techzone, repara nos tópicos em sticky:
  • [thread=115660]Ler antes de criar novo tópico sff[/thread]
  • [thread=175758]Introdução ao GNU/Linux & *nix World - Como começar [/thread]

Dsclpa me entao.. e k sou aki novo e ando a aprender coisas novas... srry :S...

CumpZ

RiTuAiS
 

rj.rodrigues

Power Member
Resolver o problema do wireless lento no hardy

Este turorial não funciona com WPA, para isso tens que seguir este, sendo que este dará mt mais trabalho e provavelmente network manager irá parar de funcionar (terás que utilizar outro manager ex: wireless assistant )

Código:
iwconfig
se na zona do wireless (wlan0 pra mim) estiver "Bit Rate=1 Mb/s" é possivel resolver da seguinte maneira

Se o identificador for wlan0 e o wireless de 54 MB/s, caso contrario é só alterar estes valores para o seu caso.
Código:
sudo gedit /etc/network/interfaces
adicionar antes do mapping
Código:
pre-up iwconfig wlan0 rate 54M
depois execute o seguinte comando:
Código:
sudo /etc/init.d/networking restart
Se não der erro já deve tar tudo Ok.

Reinicie o computador e corra o comando
Código:
iwconfig
pra verificar se ja aparece os 54 MB/s , se sim já tem o problema resolvido.
 
Última edição:

rj.rodrigues

Power Member
Isso basicamente deixa a net inutilizavel se nao tiveres "ao pé" do router... :|
N percebi bem o que queres dizer, mas o problema que tem o hardy é k se estiveres longe do sinal a net fica mt lenta o que não acontecia no Gutsy. Para resolver esse problema é so seguir o tutorial acima.
 

VuDu

Power Member
N percebi bem o que queres dizer, mas o problema que tem o hardy é k se estiveres longe do sinal a net fica mt lenta o que não acontecia no Gutsy. Para resolver esse problema é so seguir o tutorial acima.

Com esse comando forças a usar a rate de 54Mbps. Só consegues essa rate se tiveres bem perto do router, ao afastareste o sinal baixa e não consegues manter uma ligação estavel.
Basicamente, reduzes drasticamente a area em que consegues ter ligação.
Mas, na volta, se calhar isso é mudado dinamicamente e esse comando torna-se inutil.

Em relação ao problema, eu também estou com o Hardy num portatil com placa wireless da intel e não tenho problemas nenhuns.
 

rj.rodrigues

Power Member
Acho que tas enganado. Aqui em casa não conseguia ter mais k 20kb/s pk tava longe do router e consegui resolver isso da maneira que descrevi, agora consigo ter +/- 360kb/s

Lembra-te que a potemcia do sinal não tem nada a ver com a taxa de tranferencia da placa. O sistema operativo é que ajusta o rate de transf (automaticamente) pk não consegue ter mais.
 
Topo