1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

ubuntu 8.10 ecrâ "pisca"

Discussão em 'Dúvidas e Suporte Técnico - GNU/Linux & *nix' iniciada por The Dealer, 12 de Dezembro de 2008. (Respostas: 11; Visualizações: 1593)

  1. The Dealer

    The Dealer Power Member

    Tenho um problema.

    Instalei o ubuntu 8.10, e já instalei os codecs necessários para correr mp3 e divx. Tenho também já o driver apropriado para a minha placa gráfica (segundo Controladore de hardware). O problema é que quando corro um destes formatos, o ecrâ "pisca", tornando-se impossivel a sua visualização (no caso do mp3, são os efeitos que piscam).

    Procurei drivers da minha placa gráfica (uma integrada, ATI X1200), mas apenas encontrei para X1250.

    Que posso fazer?
     
  2. cheires

    cheires Power Member

    Tenho o mesmo problema.
    Também tenho uma placa grafica ATI. No meu caso a mobility 3650, e a ATI não tem suporte directo para esta placa (nem windows nem linux, pelo menos lá no site) tem apenas para a 3650 normal.
    Já instalei esse drivers, já removi os codecs, voltei a instalar novamente, e nada feito, "pisca" sempre o ecrã quando vejo filmes.
    Penso que o problema deverá estar relacionado com a placa gráfica, porque no /etc/X11/xorg.conf, o driver que é usado para a placa gráfica não é ATI. Não sei se a solução passará por aí.
    E digo isto, porque instalei um joguito muito simples, mas que também acontece o mesmo problema que nos videos.
    Por enquanto é esperar para ver....
     
    Última edição: 15 de Dezembro de 2008
  3. The Dealer

    The Dealer Power Member

    Faz isto e depois vê como reage. E utiliza vários players para testares.

     
  4. cheires

    cheires Power Member

    Com essa opção os videos já não "piscam".
    Mas os videos HD são mais lentos a reproduzir....
    Mas pelo menos já dão os divx normais...
    Mas isto só funciona para o reprodutor de filmes, com o vlc ainda ficou pior.
    E a situação no jogo continua igual também... comtinua a "piscar".
    Como esta situação também ocorre no jogo é o que me leva a pensar que seja algum problema relacionado com a placa gráfica.
    Obrigado pela dica
     
    Última edição: 15 de Dezembro de 2008
  5. The Dealer

    The Dealer Power Member

    De nada. Se por acaso descobrires uma solução a 100 % comunica.Pois eu também penso que esteja relacionado com os drivers pelo seguinte. Quando vou aos controladores de hardware e desactivo o driver que lá está, não pisca em nenhum, mas fica lento no totem, mas no VLC fica bem, com a contrapartida que neste ultimo deixo de ter som (não tem logica nenhuma eu sei).

    A lição que retiro é que a placa gráfica tem capacidade (e compatibilidade) para correr mpg, divx, HD, etc, só que nós é que não sabemos configurar. ("Pois") :)
     
  6. cheires

    cheires Power Member


    Axo que não passa tanto por aí.
    Axo que é mais a ATI que não desenvolve drivers como deve ser para linux. Penso que será mais esse o caso do que "nós não sabemos configurar".
    Já usei divers em linux da nvidia e nunca tive este tipo de problemas. Nesse aspecto a nvidia ainda está melhor que a ATI.
    Também o próprio Ubuntu não tem um sistema de configurações muito transparente. Sinceramente já ponderei mudar de distribuição.
    Sempre usei Slackware, e embora seja mais complicado por as coisas a funcionar, o que é certo é que quando funcionam, funcionam mesmo. No Ubunto, é mais à la windows...
    Claro que comunico quando descobrir a solução ;)
     
  7. The Dealer

    The Dealer Power Member

    Se calhar o problema também passa por aqui. Eis um excerto das intrucções de instalação dos ultimos drivers:

    E depois eu a unica coisa que sei ver é o Kernel... procurei pelos outros packages no repositório mas não encontrei..
     
  8. jmike72

    jmike72 Power Member

    Boas.

    Eu também tinha este problema dos filmes a "piscar" no Debian com os drivers da ATI e o Compiz. Desligando o Compiz, tudo funcionava bem, mas com ele ligado dava problemas que resolvi adicionando uns parâmetros ao xorg.conf como se segue:

    Na secção Module:

    Código:
    Load    "dri"
    Secção Device:

    Código:
    Option        "VideoOverlay" "off"
    Option        "OpenGLOverlay" "on"
    Option      "TexturedVideo" "off"
    
    Adicionei as seguintes secções:

    Código:
    Section "Extensions"
        Option "RENDER" "Enable"
        Option "DAMAGE" "Enable"
        Option "Composite" "Enable"
    EndSection
    
    Section "DRI"
        Group        "Video"
        Mode         0666
    EndSection
    
    Com isto, tenho filmes no Totem e mplayer sem "piscar". Jogos não testei, pois não entram cá. O único que continua a dar problemas é o Google Earth e sempre que quero trabalhar com ele tenho de desligar o Compiz.

    Experimentem e digam qq coisa.

    Miguel
     
  9. The Dealer

    The Dealer Power Member

    Em "Load DRI" é para adicionar e não substituir o LOAD GLX que lá está certo?

    Eu fiz isso, e de facto, parou de piscar, mas em filmes divx, uns funcionam bem, outros estão muito lentos. Em filmes HD, é completamente impossível ver...
     
  10. jmike72

    jmike72 Power Member

    Sim, é para adicionar.

    Eu não tenho problemas! Testei agora mesmo com um 1080p sem problemas.

    Miguel
     
  11. The Dealer

    The Dealer Power Member

    Bem, eu penso que resolvi o problema, de uma forma bastante "primitiva" devo confessar. Resolvi apagar o compiz (algo que não uso na totalidade (a unica coisa que penso que utilizo do compiz, são os efeitos que considero bastante práticos para passar para o ambiente lateral).

    Por isso o que fiz foi o seguinte. Abri o gestor de pacotes Synaptic, e apaguei 5 "selecções" (das que "cabem no ecrâ")do compiz que lá estão, pela ordem, a 1ª,2ª,3ª,5ª e 6ª (remoção completa e de todas as suas dependências). Reinicei, e voilá, tenho um desktop todo corrupto, sem barrras, com erros no "show desktop", enfim um caos total. No entanto experimentei (a grande custo), tentar correr os filmes, e funcionaram todos perfeitamente.

    Por isso decidi remover um a um, para ir vendo qual é o package que está a dar palavras. Neste momento tenho apenas o 1º, 5º e 6 (e dependencias associadas), e continua na mesma. No entanto agora estou num dilema pois ao tentar eliminar um dos 3, têm todos várias dependencias associadas.

    Enfim, ao menos já sei uma forma de resolver o problema (nem que seja usar o ubuntu 8.04 que penso que não tem o compiz), em ultimo recurso vou também experimentar remover package a package a ver o que acontece...
     
    Última edição: 15 de Dezembro de 2008
  12. The Dealer

    The Dealer Power Member

    Bem, tendo como ponto de partida as tais 5 "selecções" que eu falei, eliminei a primeira (compiz), vim mais abaixo, eliminei compiz-gnome, compizfusionplugins-main e compizfusionplugins-extra, e por (penso) que funciona tudo bem (na reprodução). Em relação a efeitos visuais, penso que perdi praticamente tudo, até o simples deslocamento para o ambiente de trabalho do lado perdi, assim como efeitos de minimizar etc.

    Sei que é uma solução um bocado "parva", mas foi a unica que consegui para resolver o meu problema, que é reproduzir videos. Por favor, se alguem tiver uma melhor, se acuse :)
     

Partilhar esta Página