1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Ubuntu 8.10 + Vídeos 1080p = mais lento que xp??

Discussão em 'Dúvidas e Suporte Técnico - GNU/Linux & *nix' iniciada por sem2006, 7 de Dezembro de 2008. (Respostas: 5; Visualizações: 1354)

  1. sem2006

    sem2006 Power Member

    Pois é...Eu bem que tento mudar para linux, mas parece que o linux continua a perder onde é mais essencial para mim...

    Então é assim:

    Com o XP Pro + SP3, usando o media player classic e o coreavc consigo perfeitamente ver vídeos 1080p na minha máquina, ficando com uma ocupação média de cerca de 60% de processador (50% numa core de 10% na outra). A máquina é um Atlhon 64 x2 4200+.

    Já no ubuntu (e até estou a usar uma versão 64 bits) já não consigo o mesmo. A taxa de ocupação do cpu sobe por ali acima e é só paragens. Existe alguma coisa que consiga melhorar isto ?
     
    Última edição pelo moderador: 7 de Dezembro de 2008
  2. rj.rodrigues

    rj.rodrigues Power Member

    experimenta outros programas:
    smplayer (mplayer)
    VLC
    kaffeine
    ...
     
  3. sem2006

    sem2006 Power Member

    O VLC já experimentei...os outros 2 ainda não...mais logo testo isso.
     
  4. kaxias

    kaxias Power Member

    Pode mesmo estar relacionado com a arquitectura 64bits do linux.

    Os programas decoders podem estar optimizados para 32bits.
     
  5. jmike72

    jmike72 Power Member

    Também tenho andado a mexer nisto de filmes 1080p e o problema está nos codecs. O CoreAVC do windows permite que a descodificação seja feita pela gráfica, deixando o processador livre para outras coisas. O problema é que não se encontra um codec para Linux que faça o mesmo e passe a descodificação para a gráfica! Até agora, parece que a NVIDIA é quem está mais adiantada em fornecer API para isso, mas mesmo assim, ainda está muito atrasada em relação ao Windows e não sei quando teremos aceleração por hardware a 100% no Linux para podermos ver filmes 1080p sem engasgos.

    Entretanto encontrei a noticia da NVIDIA aqui.

    Miguel
     
  6. sem2006

    sem2006 Power Member

    Sim, também acabei por descobrir isso. Descobri também que só algumas gráficas da nvidia é que eles activam essa descodificação por hardware nos drivers, sendo que no meu caso que é uma integrada no chipset isso não se passa. Com estou para adicionar uma gráfica com capacidades pure video, pdoe ser que se resolva.

    Entretanto estou com outro problema: em vídeos 720p estou a ficar sem som ao fim de algum tempo :'(
     

Partilhar esta Página