1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

UBUNTU e SOM no HP Pavillion dv6165ea

Discussão em 'Dúvidas e Suporte Técnico - GNU/Linux & *nix' iniciada por dolphman, 21 de Fevereiro de 2007. (Respostas: 11; Visualizações: 3105)

  1. Bom dia.

    Tenho o seguinte problema no meu portatil hp pavillion dv6165ea, a correr Ubuntu 6.06 :

    $ lspci | grep -i audio
    0000:00:1b.0 0403: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

    O som sai pelas colunas externas, mas quando ligo os headphones, nada acontece, ou seja, o som continua a sair pelas colunas externas e nada de som nos phones.

    Alguém tem alguma sugestão?


    Som a parte, tudo o resto corre 5 estrelas no ubuntu :)

    Obrigado.
     
  2. CR_

    CR_ Power Member

    $alsamixer e liga. (tecla M para Mute/"unmute")
     
  3. Pois, mas só tenho dois canais disponíveis... o MASTER e o PCM

    E embora "mate" o som nas colunas exteriores, nada acontece nos phones... será que é qualqer coisa relacionada com o driver?
     
  4. PrOdG

    PrOdG Power Member

    Isso tem a ver com os drivers in-kernel para a tua placa de som. Retira do kernel o suporte para OSS e ALSA, e instala o pacote de drivers mais actualizado correspondente para Ubuntu (não uso essa distro, não sei qual é o nome).
     
    Última edição: 21 de Fevereiro de 2007
  5. Pois, isto não tá nada fácil.... depois de muito google por aí, parece que este problema é bem conhecido de muito boa gente... e apontam a solução para um novo kernel que há de vir....... ou seja, com o kernel x não dá som, com o kernel x.1 ja da som mas se mexer no botao y deixa de tocar..

    - experimentei todas e mais algumas configurações do alsa... deu em nada (até aquela opção em que se coloca o modelo na configuração da placa de som)

    - experimentei activar e desactivar modulos no kernel, mas também nada aconteceu

    Mudar de distribuição está fora de questão, uma vez que o Ubuntu funciona-me as mil maravilhas para tudo o resto..


    Parece que vou ter de aguardar mais uns tempos a ver se a nova versao do Ubuntu ja me traz isto resolvido... :(
     
  6. c3l5o

    c3l5o I'm cool cuz I Fold

    Eu aconselhava mesmo experimentar uma outra distro tipo Opensuse ou assim... Da minha experiência pessoal sempre achei o ubuntu um pouco limitante para alterar configs de kernel e etc... Mas isto sou eu que estou habituado a outros voos que dão muito mais dores de cabeça :P

    E não é por o ubuntu funcionar que não deves experimentar outras distros que até podem fazer cenrtas coisas que precises de forma mais eficiente... You'll never know until you try it... ;)
     
  7. APLinhares

    APLinhares OpenSource Moderator
    Staff Member

  8. Agradeço a dica, mas isso foi a primeira coisa que esperimentei... tb deu em nada
     
  9. APLinhares

    APLinhares OpenSource Moderator
    Staff Member

    Mas deu tudo direito ? (sem erros na compilação e dps na detecção do alsa)
     
  10. Quaker

    Quaker Power Member

    Headphones

    Eu tb tenho o mesmo problema mas já o resolvi. Isso é um bug dos drivers da alsa. falta-lhe acrescentar uma linha a um ficheiro.... Eu já vi isso nos forums do ubuntu se encontrar eu faço o post... Se encontrares faz tb o post tb ando a procuro dessa linha.... lol
     
  11. Parece que os nossos amigos do Ubuntu não esqueceram este problema no 7.04 ... o live CD arrancou na boa e o som funcionou perfeitamente!!!! Portanto, a solução é upgrade de distribuição :)
     
  12. Eu estive tendo o mesmo problema, o som funcionava na caixa, mas qdo plugava o fone de ouvido ele num desligava a caixa de som.

    Eu uso Gentoo, e acredito que a solução deve ser a mesma.

    Além de estar com os seus drivers atualizados, vc deve fazer o seguinte acrescimo no seu arquivo de configuração do alsa (no Gentoo ele fica em /etc/modules.d/alsa)

    options snd-hda-intel model=laptop

    Após fazer o update do som, no Gentoo é realizar:

    #update-modules
    #/etc/init.d/alsasound restart

    E voial.

    Tudo ok funcionando.

    Abraços
     

Partilhar esta Página