1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Ubuntu- não consigo pôr a consola a compilar c

Discussão em 'Dúvidas e Suporte Técnico - GNU/Linux & *nix' iniciada por Zenit, 16 de Janeiro de 2009. (Respostas: 3; Visualizações: 1134)

  1. Quando utilizo os comandos cc ou gcc para compilar um ficheiro.c diz-me que não consegue encontrar o ficheiro stdio.h.

    Já tentei instalar o build-essential mas a consola dá varias falhas e diz que devia fazer um update.
    Quando tento correr o update também dá alguns problemas.

    Tenho alguma alternativa ao build-essential para ter bibliotecas para compilar em c?

    Já tentei instalar também o glibc-doc e deu erro novamente!

    Se alguém me puder ajudar ficaria muitíssimo agradecido.
     
  2. nasic

    nasic Power Member

  3. É um bocado extenso mas aqui vai...


    • --------------problemas com build-essensial------------------------------------
    [email protected]:~$ sudo apt-get install build-essential A Ler Listas de Pacotes... Pronto
    Construindo Árvore de Dependências
    Lendo informação de estado... Pronto
    Os seguintes pacotes extra serão instalados:
    dpkg-dev g++ g++-4.1 libc6-dev libstdc++6-4.1-dev
    Pacotes sugeridos :
    debian-keyring gcc-4.1-doc lib64stdc++6 glibc-doc manpages-dev
    libstdc++6-4.1-doc
    Os seguintes NOVOS pacotes serão instalados:
    build-essential dpkg-dev g++ g++-4.1 libc6-dev libstdc++6-4.1-dev
    0 pacotes actualizados, 6 pacotes novos instalados, 0 a remover e 0 não actualizados.
    É necessário fazer o download de 7386kB de arquivos.
    Depois de descompactar, 29,8MB adicionais de espaço em disco serão utilizados.
    Você deseja continuar [Y/n]? y
    AVISO: Os seguintes pacotes não podem ser autenticados
    libc6-dev libstdc++6-4.1-dev g++-4.1 g++ dpkg-dev build-essential
    Instalar estes pacotes sem verificação [y/N]? y
    Err http://pt.archive.ubuntu.com feisty/main libc6-dev 2.5-0ubuntu14
    404 Not Found
    Err http://pt.archive.ubuntu.com feisty/main libstdc++6-4.1-dev 4.1.2-0ubuntu4
    404 Not Found
    Err http://pt.archive.ubuntu.com feisty/main g++-4.1 4.1.2-0ubuntu4
    404 Not Found
    Err http://pt.archive.ubuntu.com feisty/main g++ 4:4.1.2-1ubuntu1
    404 Not Found
    Err http://pt.archive.ubuntu.com feisty/main dpkg-dev 1.13.24ubuntu6
    404 Not Found
    Err http://pt.archive.ubuntu.com feisty/main build-essential 11.3
    404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/pool/main/g/glibc/libc6-dev_2.5-0ubuntu14_i386.deb 404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/pool/main/g/gcc-4.1/libstdc++6-4.1-dev_4.1.2-0ubuntu4_i386.deb 404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/pool/main/g/gcc-4.1/g++-4.1_4.1.2-0ubuntu4_i386.deb 404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/pool/main/g/gcc-defaults/g++_4.1.2-1ubuntu1_i386.deb 404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/pool/main/d/dpkg/dpkg-dev_1.13.24ubuntu6_all.deb 404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/pool/main/b/build-essential/build-essential_11.3_i386.deb 404 Not Found
    E: Impossível obter alguns arquivos, execute talvez apt-get update ou tente com --fix-missing?


    • ----------------------problemas com get update

    [email protected]:~$ sudo apt-get update
    Ign http://pt.archive.ubuntu.com feisty Release.gpg
    Ign http://pt.archive.ubuntu.com feisty/main Translation-pt_PT
    Ign http://pt.archive.ubuntu.com feisty/restricted Translation-pt_PT
    Ign http://pt.archive.ubuntu.com feisty/universe Translation-pt_PT
    Ign http://pt.archive.ubuntu.com feisty/multiverse Translation-pt_PT
    Obter:1 http://pt.archive.ubuntu.com feisty-updates Release.gpg [189B]
    Ign http://pt.archive.ubuntu.com feisty-updates/main Translation-pt_PT
    Ign http://pt.archive.ubuntu.com feisty-updates/restricted Translation-pt_PT
    Ign http://pt.archive.ubuntu.com feisty Release
    Atingido http://pt.archive.ubuntu.com feisty-updates Release
    Ign http://pt.archive.ubuntu.com feisty/main Packages
    Ign http://pt.archive.ubuntu.com feisty/restricted Packages
    Ign http://pt.archive.ubuntu.com feisty/restricted Sources
    Ign http://pt.archive.ubuntu.com feisty/main Sources
    Ign http://pt.archive.ubuntu.com feisty/multiverse Sources
    Ign http://pt.archive.ubuntu.com feisty/universe Sources
    Ign http://pt.archive.ubuntu.com feisty/universe Packages
    Ign http://pt.archive.ubuntu.com feisty/multiverse Packages
    Atingido http://pt.archive.ubuntu.com feisty-updates/main Packages
    Atingido http://pt.archive.ubuntu.com feisty-updates/restricted Packages
    Atingido http://pt.archive.ubuntu.com feisty-updates/main Sources
    Atingido http://pt.archive.ubuntu.com feisty-updates/restricted Sources
    Err http://pt.archive.ubuntu.com feisty/main Packages
    404 Not Found
    Err http://pt.archive.ubuntu.com feisty/restricted Packages
    404 Not Found
    Err http://pt.archive.ubuntu.com feisty/restricted Sources
    404 Not Found
    Err http://pt.archive.ubuntu.com feisty/main Sources
    404 Not Found
    Err http://pt.archive.ubuntu.com feisty/multiverse Sources
    404 Not Found
    Err http://pt.archive.ubuntu.com feisty/universe Sources
    404 Not Found
    Err http://pt.archive.ubuntu.com feisty/universe Packages
    404 Not Found
    Err http://pt.archive.ubuntu.com feisty/multiverse Packages
    404 Not Found
    Obter:2 http://archive.ubuntu.com feisty-updates Release.gpg [189B]
    Ign http://archive.ubuntu.com feisty-updates/restricted Translation-pt_PT
    Ign http://archive.ubuntu.com feisty-updates/main Translation-pt_PT
    Ign http://archive.ubuntu.com feisty-updates/multiverse Translation-pt_PT
    Ign http://archive.ubuntu.com feisty-updates/universe Translation-pt_PT
    Atingido http://archive.ubuntu.com feisty-updates Release
    Atingido http://archive.ubuntu.com feisty-updates/restricted Packages
    Atingido http://archive.ubuntu.com feisty-updates/main Packages
    Atingido http://archive.ubuntu.com feisty-updates/multiverse Packages
    Atingido http://archive.ubuntu.com feisty-updates/universe Packages
    Atingido http://archive.ubuntu.com feisty-updates/restricted Sources
    Atingido http://archive.ubuntu.com feisty-updates/main Sources
    Atingido http://archive.ubuntu.com feisty-updates/multiverse Sources
    Atingido http://archive.ubuntu.com feisty-updates/universe Sources
    Obter:3 http://security.ubuntu.com feisty-security Release.gpg [189B]
    Ign http://security.ubuntu.com feisty-security/main Translation-pt_PT
    Ign http://security.ubuntu.com feisty-security/restricted Translation-pt_PT
    Ign http://security.ubuntu.com feisty-security/universe Translation-pt_PT
    Ign http://security.ubuntu.com feisty-security/multiverse Translation-pt_PT
    Atingido http://security.ubuntu.com feisty-security Release
    Atingido http://security.ubuntu.com feisty-security/main Packages
    Atingido http://security.ubuntu.com feisty-security/restricted Packages
    Atingido http://security.ubuntu.com feisty-security/restricted Sources
    Atingido http://security.ubuntu.com feisty-security/main Sources
    Atingido http://security.ubuntu.com feisty-security/multiverse Sources
    Atingido http://security.ubuntu.com feisty-security/universe Sources
    Atingido http://security.ubuntu.com feisty-security/universe Packages
    Atingido http://security.ubuntu.com feisty-security/multiverse Packages
    Ign http://ubuntu.beryl-project.org feisty Release.gpg
    Ign http://ubuntu.beryl-project.org feisty/main Translation-pt_PT
    Ign http://ubuntu.beryl-project.org feisty/main Translation-pt_PT
    Ign http://ubuntu.beryl-project.org feisty Release
    Ign http://ubuntu.beryl-project.org feisty/main Packages
    Ign http://ubuntu.beryl-project.org feisty/main Sources
    Ign http://ubuntu.beryl-project.org feisty/main Packages
    Ign http://ubuntu.beryl-project.org feisty/main Sources
    Err http://ubuntu.beryl-project.org feisty/main Packages
    404 Not Found [IP: 88.191.250.18 80]
    Err http://ubuntu.beryl-project.org feisty/main Sources
    404 Not Found [IP: 88.191.250.18 80]
    Err http://ubuntu.beryl-project.org feisty/main Packages
    404 Not Found [IP: 88.191.250.18 80]
    Err http://ubuntu.beryl-project.org feisty/main Sources
    404 Not Found [IP: 88.191.250.18 80]
    Obtidos 3B em 4m14s (0B/s)
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/dists/feisty/main/binary-i386/Packages.gz 404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/dists/feisty/restricted/binary-i386/Packages.gz 404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/dists/feisty/restricted/source/Sources.gz 404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/dists/feisty/main/source/Sources.gz 404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/dists/feisty/multiverse/source/Sources.gz 404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/dists/feisty/universe/source/Sources.gz 404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/dists/feisty/universe/binary-i386/Packages.gz 404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/dists/feisty/multiverse/binary-i386/Packages.gz 404 Not Found
    Falha ao obter http://ubuntu.beryl-project.org/dists/feisty/main/binary-i386/Packages.gz 404 Not Found [IP: 88.191.250.18 80]
    Falha ao obter http://ubuntu.beryl-project.org/dists/feisty/main/source/Sources.gz 404 Not Found [IP: 88.191.250.18 80]
    Falha ao obter http://ubuntu.beryl-project.org/dists/feisty/main/binary-i386/Packages.gz 404 Not Found [IP: 88.191.250.18 80]
    Falha ao obter http://ubuntu.beryl-project.org/dists/feisty/main/source/Sources.gz 404 Not Found [IP: 88.191.250.18 80]
    A Ler Listas de Pacotes... Pronto
    E: Falhou o download de alguns ficheiros de índice, foram ignorados ou os antigos foram usados em seu lugar.


    • --------------------problemas com o glibc-doc-------------------------------

    [email protected]:~$ sudo apt-get install glibc-doc
    A Ler Listas de Pacotes... Pronto
    Construindo Árvore de Dependências
    Lendo informação de estado... Pronto
    Os seguintes pacotes foram instalados automáticamente e já não são necessários:
    linux-libc-dev
    Utilize 'apt-get autoremove' para os remover.
    Os seguintes NOVOS pacotes serão instalados:
    glibc-doc
    0 pacotes actualizados, 1 pacotes novos instalados, 0 a remover e 0 não actualizados.
    É necessário fazer o download de 3414kB de arquivos.
    Depois de descompactar, 8954kB adicionais de espaço em disco serão utilizados.
    AVISO: Os seguintes pacotes não podem ser autenticados
    glibc-doc
    Instalar estes pacotes sem verificação [y/N]? y
    Err http://pt.archive.ubuntu.com feisty/main glibc-doc 2.5-0ubuntu14
    404 Not Found
    Falha ao obter http://pt.archive.ubuntu.com/ubuntu/pool/main/g/glibc/glibc-doc_2.5-0ubuntu14_all.deb 404 Not Found
    E: Impossível obter alguns arquivos, execute talvez apt-get update ou tente com --fix-missing?


    • -------------------------------erros na compilação---------------------

    #include <stdio.h>

    int main(void);
    {
    printf("hello /n");
    return 0
    }

    [email protected]:~$ cc progemc.c -o progemc
    progemc.c:2:19: error: stdio.h: Ficheiro ou directoria inexistente
    progemc.c:5: error: expected identifier or ‘(’ before ‘{’ token

    -------------------------------------------------------------------------------------------------------------


    Quanto aos repositórios nem sei bem por onde começar...
    Devo activar os repositórios oficiais? Que repositórios devo procurar e instalar para resolver o problema?

    Desculpem o tamanho do post, mas não há uma maneira de esconder parte do texto numa caixa?
     
  4. trmanco

    trmanco Power Member

    Não é por nada, mas o Feisty Fawn (7.04) parou de ser suportado pela Canonical

    Terás que actualizar para o 7.10, 8.04 (LTS) ou 8.10
     

Partilhar esta Página