1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Unmount de disco secundário deixou de funcionar no mountain lion

Discussão em 'Dúvidas e Suporte Técnico - Apple' iniciada por dragao-azul, 29 de Julho de 2012. (Respostas: 9; Visualizações: 646)

  1. dragao-azul

    dragao-azul I fold therefore I AM

    Boas,

    Ontem actualizei para o mountain, mas o script que tenho para fazer unmount do meu HDD deixou de funcionar... Tenho 2 partições, uma para armazenamento de ficheiros e outra com o windows, quando corro o script (que funcionava bem no lion) ele só me faz unmount da partição do windows e dá erro na outra, não sei porquê, apenas diz que é impossível fazer o unmount. O script é simplesmente "diskutil unmount /dev/disk1".

    Alguém com 2 discos pode ver se tem este problema? Há alguma forma de ver se o disco está a ser usado para alguma coisa que não deva?

    Thz!
     
  2. elioc9

    elioc9 Power Member

    para que fazes o unmount do disco secundário?
     
  3. dragao-azul

    dragao-azul I fold therefore I AM

  4. cerdeira

    cerdeira Power Member

    O script que uso e diferente desse, e continuou a funcionar normalmente. Se calhar tens alguma coisa a correr a partir dessa partição, agora como se vê isso também não sei
     
  5. dragao-azul

    dragao-azul I fold therefore I AM

    elioc9, li mal a pergunta, faço para poupar bateria.

    Que script usas cerdeira? Supostamente não estou a correr nada, só se a actualização meteu lá alguma coisa. Antes dava e depois deixou de dar, aliás o disco continua a parar quando inativo, mas como está montado liga mais regularmente.
     
  6. cerdeira

    cerdeira Power Member

    Este:
    hdiutil eject `diskutil list | grep Nome_do_disco | awk '{print $6}'`
     
  7. dragao-azul

    dragao-azul I fold therefore I AM

    Esse teu script também não funciona para mim, diz que o disco está em uso :s
     
  8. dragao-azul

    dragao-azul I fold therefore I AM

    Alguém tem alguma sugestão de como verificar se algum programa está a utilizar o disco para alguma coisa? Queria ver se resolvia isto... Será que uma nova instalação do OS de raiz resolve?
     
  9. elioc9

    elioc9 Power Member

    explica-me só uma coisa, o teu disco não se desliga ao fim de uns minutos sem uso? o meu vai abaixo e assim se mantem ate fazer um download ou abrir algo que esteja no disco.

    com o disk utility não consegues fazer o unmount?
     
  10. dragao-azul

    dragao-azul I fold therefore I AM

    Desliga, nem me lembro como deixei isto mas acho que até se desliga após um minuto de inactividade. Só queria deixar isto desligado porque é de facto raro usar o disco e assim garanto que ele fica mesmo desligado o tempo todo.

    O disk utility também não me deixa fazer unmount, diz-me o mesmo que dos outros lados, para confirmar se não tenho ficheiros nem aplicações abertos no disco.
     

Partilhar esta Página