USG e Meo Fibra

Qaz.xc

Power Member
Eu tentei novamente e já desisti, da próxima irei tentar meter OpenWRT no edgerouter e testar por aí... pelo que vejo na net o edgerouter não é exactamente igual ao USG a funcionalidade do igmp-proxy... tantas configs e tanto problema com multicast...
 

Dr4g3r

Power Member
Eu tentei novamente e já desisti, da próxima irei tentar meter OpenWRT no edgerouter e testar por aí... pelo que vejo na net o edgerouter não é exactamente igual ao USG a funcionalidade do igmp-proxy... tantas configs e tanto problema com multicast...

Que edgerouter tens? É que com aquela configuração e com o edgerouter ligado directamente À ONT, tem que funcionar. Comigo jã funcionou tudo direitinho.
 

Qaz.xc

Power Member
Que edgerouter tens? É que com aquela configuração e com o edgerouter ligado directamente À ONT, tem que funcionar. Comigo jã funcionou tudo direitinho.

Tenho o edgerouter X (ER-X) , funciona tudo 100%, IPTV para sempre passado 5-10s, e já meti o mac address correcto sim... opá não sou grande pistola em redes mas copy paste sei fazer..

show ip multicast interface mostra correcto, mfc também, eu sinceramente não sei porque o meu é especial, que eu já tive uma vez a funcionar por uns dias e depois deixou de dar e nunca mais consegui.
Já estou a dúvidar das capacidades do igmp-proxy do ER-X, com o USG o pessoal acaba por conseguir de uma ou outra maneira através do IGMP snooping... agora idk.

Posso ser burro mas acho que neste caso já testei tudo o que havia para testar.
Firmware está actualizado (o de dezembro)
 

Dr4g3r

Power Member
Estranho, é que a mim também me encravou, mas eu tenho o router da meo ligado, faz algum sentido que mais cedo ou mais tarde deixe de funcionar. Tu tens o router da meo a funcionar juntamente com o edgerouter por causa do telefone?

Abraços
 

Qaz.xc

Power Member
Estranho, é que a mim também me encravou, mas eu tenho o router da meo ligado, faz algum sentido que mais cedo ou mais tarde deixe de funcionar. Tu tens o router da meo a funcionar juntamente com o edgerouter por causa do telefone?

Abraços

Não, eu estou a testar especificamente para eliminar os telefones da equação + router meo... ou seja, nem testei com o router MEO ligado numa das portas, mas o meu entendimento de redes isso não têm interferência na configuração do ER-X para IPTV.
Já pensei seriamente em comprar um router que sei que funcione tipo USG e arrumar isto para canto ou switch, parece bom router mas o IPTV da MEO tá fdd de configurar.
 

TommyPT

Power Member
Não, eu estou a testar especificamente para eliminar os telefones da equação + router meo... ou seja, nem testei com o router MEO ligado numa das portas, mas o meu entendimento de redes isso não têm interferência na configuração do ER-X para IPTV.
Já pensei seriamente em comprar um router que sei que funcione tipo USG e arrumar isto para canto ou switch, parece bom router mas o IPTV da MEO tá fdd de configurar.

Vou dizer algo que pode parecer parvo mas experimenta desligar o ONT da electricidade durante uns segundos e voltar a ligar. Tive um caso em que a minha box não dava sinal (e fartei-me de fazer reboots ao roter e switch) e no fim era o ONT que devia ter algo pendurado.
 
Já existe alguma solução para o cenário FGW -> USG?
Tive a trabalhar sem problemas no passado com ONT->MEO Router -> USG , mas desde que troquei não consigo.
 

Dr4g3r

Power Member
Já existe alguma solução para o cenário FGW -> USG?
Tive a trabalhar sem problemas no passado com ONT->MEO Router -> USG , mas desde que troquei não consigo.

Nao vais conseguir. Isto só funciona para quem tem a ont e o router em equipamentos distintos. Tu tens o router e a ont no mesmo equipamento não ira funcionar.

Cumprimentos;
 

s0ldier

Power Member
A única vantagem teres ligado diretamente à USG é não teres um possível ponto de falha no FGW. Ao ativares o Bridge mode no FGW ele fica "invisível" para a rede, pelo que é igual a teres ONT->USG.
 

warrior89

Power Member
Também estou aqui na mesma situação e já dei imensas voltas mas sem sorte....
Já tentei o que fui vendo aqui (obrigado malta!) e noutros sítios, mas a imagem da box para passados 5/10 s.

Neste momento o que tenho é isto:

Edgerouter X:
- ETH0 WAN
- ETH1 TL-SG108E Switch
- ETH4 UniFi AP

O FGW (ONT+Router) está em modo bridge ligado ao edgerouter.
E para funcionarem os canais, a box está ligada ao FGW (fora da rede)

Eu queria conseguir ligar a box ao edgerouter ou ao switch para libertar uma tomada de rede que tenho na sala e para conseguir usar a app do MEO Remote.

Tentei configurar +- com o que vi por aqui e aqui: https://community.ui.com/questions/...P/a0fb840b-8aad-4072-bf0e-279c53244475?page=1
Primeiro com a box ligada ao switch e o FGW na porta eth0 do edgerouter e depois com a box ligada diretamente ao edgerouter, mas o resultado é sempre o mesmo... aqueles segundos de falsa esperança até que a imagem para :-D
 

Qaz.xc

Power Member
Também estou aqui na mesma situação e já dei imensas voltas mas sem sorte....
Já tentei o que fui vendo aqui (obrigado malta!) e noutros sítios, mas a imagem da box para passados 5/10 s.

Neste momento o que tenho é isto:

Edgerouter X:
- ETH0 WAN
- ETH1 TL-SG108E Switch
- ETH4 UniFi AP

O FGW (ONT+Router) está em modo bridge ligado ao edgerouter.
E para funcionarem os canais, a box está ligada ao FGW (fora da rede)

Eu queria conseguir ligar a box ao edgerouter ou ao switch para libertar uma tomada de rede que tenho na sala e para conseguir usar a app do MEO Remote.

Tentei configurar +- com o que vi por aqui e aqui: https://community.ui.com/questions/...P/a0fb840b-8aad-4072-bf0e-279c53244475?page=1
Primeiro com a box ligada ao switch e o FGW na porta eth0 do edgerouter e depois com a box ligada diretamente ao edgerouter, mas o resultado é sempre o mesmo... aqueles segundos de falsa esperança até que a imagem para :-D

Pois, eu também já testei N de situações como tu, N de configs, só consegui uma vez durante 2/3 dias pôr a funcionar... depois do nada voltou a parar imagem.

O edgerouter X não sei se terá bugs no firmware que impessam isto.. da mesma forma que se quiseres fazer setup VPN nele é bastante mais lento que um edgerouter Lite.

Opah, não sei, já tive tentado a comprar outro router melhor para tirar as teimas, o problema é que eu tenho um unifi AP como tu e o USG não sei se conseguiria configurar (se bem que esse parecem ter mais sucesso).

Algum iluminado de redes está disposto a diagnosticar aqui o problema? Eu até empresto o meu edgerouter para o efeito...
 
Muito Obrigado, graças a ti, consegui finalmente ter a minha STB a funcionar sem o hgw do MEO.
Boa tarde

Alguem me pode ajudar, ao nível de utilizador...

Comprei um USG e queria ligar ao ont da meo, mas nao consigo ter internet. Ha alguma configuração adicional, alem da configuração do ipv4 estático, em que coloquei o Ip estático, subnet 255.255.255.0 e o router 192.168.1.254 no ipv6 coloquei disable e coloquei os dns que estavam no Router da meo...

A outra solução é criar uma Bridge no Vigor 2960vn, mas também nao encontro nada.

Desculpem as minhas perguntas de leigo... mas gostaria de ajuda.

obrigado
 
Vou deixar aqui a minha config para ajudar quem precisar.

O setup é simples, Edgerouter X com WAN na porta eth0, LAN na porta eth1 e IPTV na porta eth4. Rede Guest na VLAN 1337.

LAN - 172.16.10.0/24
GUEST - 172.16.254.0/24
IPTV - 172.16.253.0/24

https://pastebin.com/mrLXNrXP

Cumps

Boas noites.
tenho uma questão, com o edgerouter X e com a config que meteste no post mais acima , é possivel passar todo o trafego da wan para outra porta para posteriormente ligar ao pfsense e atuar como firewall em vez do edgerouter.

o que eu queria era :

ONT ► WAN (eth0) do edgerouter

WAN (eth1) ► pfsense WAN (resumidamente queria obter o ip publico noutra porta do edgerouter)

IPTV (eth4) ► 172.16.253.0/24

É possível?, porque gostava de separar logo a IPTV

Senão terei que ligar o ONT ao PFfsense e separar la

Cumprimentos
 

macalex

Power Member
Podem me dar uma ajuda indicando o caminho para ter a funcionar somente para net o UniFi Dream Machine Pro?

Ficando o router da MEO para IPTV e Telefone.

Tenho ONT + Router separados.

A uns anos na Vodafone tinha um switch que recebia o sinal do ONT e passava para um router meu e para o da Vodafone ficando o da Vodafone a tratar do telefone e iptv no entanto deixou de funcionar quando deixaram de permitir dois IPS.Dessa maneira funciona na MEO atualmente?

EDITED

Já tenho a funcionar apenas para net mais simples é impossível.
Não consegui foi por o IPV6 a funcionar. Podem me dar uma ajuda?
IPV6 já a funcionar.
Telefone já a funcionar ligado ao Unifi num SPA504G.
Só me falta a IPTV
 
Última edição:

imaNuS

Power Member
Podem me dar uma ajuda indicando o caminho para ter a funcionar somente para net o UniFi Dream Machine Pro?

Ficando o router da MEO para IPTV e Telefone.

Tenho ONT + Router separados.

A uns anos na Vodafone tinha um switch que recebia o sinal do ONT e passava para um router meu e para o da Vodafone ficando o da Vodafone a tratar do telefone e iptv no entanto deixou de funcionar quando deixaram de permitir dois IPS.Dessa maneira funciona na MEO atualmente?

EDITED

Já tenho a funcionar apenas para net mais simples é impossível.
Não consegui foi por o IPV6 a funcionar. Podem me dar uma ajuda?
IPV6 já a funcionar.
Telefone já a funcionar ligado ao Unifi num SPA504G.
Só me falta a IPTV

Como conseguiste colocar o Voip a funcionar no SPa ? Como conseguiste os dados da conta SIP ?
 

Qaz.xc

Power Member
Podem me dar uma ajuda indicando o caminho para ter a funcionar somente para net o UniFi Dream Machine Pro?

Ficando o router da MEO para IPTV e Telefone.

Tenho ONT + Router separados.

A uns anos na Vodafone tinha um switch que recebia o sinal do ONT e passava para um router meu e para o da Vodafone ficando o da Vodafone a tratar do telefone e iptv no entanto deixou de funcionar quando deixaram de permitir dois IPS.Dessa maneira funciona na MEO atualmente?

EDITED

Já tenho a funcionar apenas para net mais simples é impossível.
Não consegui foi por o IPV6 a funcionar. Podem me dar uma ajuda?
IPV6 já a funcionar.
Telefone já a funcionar ligado ao Unifi num SPA504G.
Só me falta a IPTV

Eu depois de flashar openwrt no ER-X o IPTV funcionou logo de raiz mal configurei o igmp-proxy, enquanto que no EdgeOS por alguma razão não funcionava...

De qualquer das maneiras, hoje o problema "voltou" aparentemente sem mexida da minha parte, já reiniciei os serviços e o router e os mesmos 10s de imagem mantêm.... ou mudaram os IP's do multicast ou então não sei, alguém têm algumas luzes para eu não andar a perder umas horitas a tentar fazer debug?
 

redalert

Folding Member
Eu depois de flashar openwrt no ER-X o IPTV funcionou logo de raiz mal configurei o igmp-proxy, enquanto que no EdgeOS por alguma razão não funcionava...

De qualquer das maneiras, hoje o problema "voltou" aparentemente sem mexida da minha parte, já reiniciei os serviços e o router e os mesmos 10s de imagem mantêm.... ou mudaram os IP's do multicast ou então não sei, alguém têm algumas luzes para eu não andar a perder umas horitas a tentar fazer debug?

Não sei se será a solução, mas não custa tentar atribuires no DHCP (LAN), para o Mac Address da Box, os DNS públicos da MEO. Invés do que é mantido pelo USG. Por exemplo: o 212.55.154.174.

Só para despistar algum tipo de mDNS que a MEO possa estar a utilizar na sua rede.
 

Qaz.xc

Power Member
Não sei se será a solução, mas não custa tentar atribuires no DHCP (LAN), para o Mac Address da Box, os DNS públicos da MEO. Invés do que é mantido pelo USG. Por exemplo: o 212.55.154.174.

Só para despistar algum tipo de mDNS que a MEO possa estar a utilizar na sua rede.

Hoje fiz um reset ao openwrt (vários, porque sou nabo, tava a ver que tinha de fazer hard-reset lol) e voltou a funcionar com as mesmas configs... impressionante:

0 configs de firewall, apenas versão 19.07.3 openwrt, instalado o igmpproxy e as configs são defaults (só tenho de meter a VLAN 12 no GUI)

config igmpproxy
option quickleave 1
# option verbose [0-3](none, minimal[default], more, maximum)

config phyint
option network wan
option zone wan
option direction upstream
list altnet 192.168.1.0/24

config phyint
option network lan
option zone lan
option direction downstream

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fde7:d2d5:fad6::/48'

config interface 'lan'
option type 'bridge'
option ifname 'eth0.1'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'

config device 'lan_eth0_1_dev'
option name 'eth0.1'
option macaddr 'b4:fb:e4:51:a2:4a'

config interface 'wan'
option proto 'dhcp'
option ifname 'eth0.12'

config device 'wan_eth0_2_dev'
option name 'eth0.2'
option macaddr 'b4:fb:e4:51:a2:4b'

config interface 'wan6'
option proto 'dhcpv6'
option ifname 'eth0.12'
option reqaddress 'try'
option reqprefix 'auto'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '1 2 4 6t'
option vid '1'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '0t 3 6t'
option vid '12'
 
Topo