USG e Meo Fibra

macalex

Power Member
Como conseguiste colocar o Voip a funcionar no SPa ? Como conseguiste os dados da conta SIP ?

Intercetei o tráfego do router da meo ao fazer reset, no XML tens o SIP.AuthUserName e SIP.AuthPassword.

Depois é só configurar com estes dados:

SIP Server: sip.sapo.pt
SIP Proxy: proxy.ims.iptv.telecom.pt:5070
Username: +35121xxxxxxx
Domain: sip.sapo.pt
Login: +35121xxxxxxx
Password: --password-do-voip--
Transport: UDP
Register Refresh: 3600
Publish Presence: on

A IPTV não consigo, pode funcionar um dia no próximo começa a travar.
Alguém tem a IPTV a funcionar num UNIFI?

No entanto tenho dois ips um no Unifi e outro no da MEO, se fizerem como a vodafone e apenas permitirem um deixa de funcionar desta maneira.
 
Última edição:

imaNuS

Power Member
Intercetei o tráfego do router da meo ao fazer reset, no XML tens o SIP.AuthUserName e SIP.AuthPassword.

Depois é só configurar com estes dados:

SIP Server: sip.sapo.pt
SIP Proxy: proxy.ims.iptv.telecom.pt:5070
Username: +35121xxxxxxx
Domain: sip.sapo.pt
Login: +35121xxxxxxx
Password: --password-do-voip--
Transport: UDP
Register Refresh: 3600
Publish Presence: on

A IPTV não consigo, pode funcionar um dia no próximo começa a travar.
Alguém tem a IPTV a funcionar num UNIFI?

No entanto tenho dois ips um no Unifi e outro no da MEO, se fizerem como a vodafone e apenas permitirem um deixa de funcionar desta maneira.

Gostava de saber fazer isso. Julgo que utilizaste o wireshark?! Se algum dia tiveres um tempo e disponibilidade de explicar mais ao detalhe manda mensagem por favor. Podemos trocar informações porque eu tenho um USG há quase 1 ano a funcionar com IPTV MEO sem problemas
 
A ter em atenção:

- Regras de Firewall para Multicast e IGMP
- colocar o MAC ADDRESS do vosso router MEO no interface WAN do ERX
- Na minha configuração:
ETH0 > Porta WAN;
ETH1 > Porta LAN ligada ao router MEO (para disponibilizar linha telefónica). Necessário ter a VLAN 12
ETH2 > Ligação para BOX MEO.
ETH3 e ETH 4 > LAN normal onde tenho pcs

- Indicar no igmp-proxy o Interface de downstream e upstream.

alguma duvida avisem. e se conseguirem por a funcionar avisem :)

Código:
set firewall all-ping enable
set firewall broadcast-ping disable
set firewall ipv6-receive-redirects disable
set firewall ipv6-src-route disable
set firewall ip-src-route disable
set firewall log-martians enable
set firewall name WAN_IN default-action drop
set firewall name WAN_IN description 'WAN to internal'
set firewall name WAN_IN rule 10 action accept
set firewall name WAN_IN rule 10 description 'Allow IPTV Multicast UDP'
set firewall name WAN_IN rule 10 destination address 232.0.0.0/8
set firewall name WAN_IN rule 10 log disable
set firewall name WAN_IN rule 10 protocol udp
set firewall name WAN_IN rule 10 state established enable
set firewall name WAN_IN rule 10 state invalid disable
set firewall name WAN_IN rule 10 state new enable
set firewall name WAN_IN rule 10 state related enable
set firewall name WAN_IN rule 20 action accept
set firewall name WAN_IN rule 20 description 'Allow IGMP'
set firewall name WAN_IN rule 20 log disable
set firewall name WAN_IN rule 20 protocol igmp
set firewall name WAN_IN rule 20 state
set firewall name WAN_IN rule 30 action accept
set firewall name WAN_IN rule 30 description 'Allow established/related'
set firewall name WAN_IN rule 30 state established enable
set firewall name WAN_IN rule 30 state related enable
set firewall name WAN_IN rule 40 action drop
set firewall name WAN_IN rule 40 description 'Drop invalid state'
set firewall name WAN_IN rule 40 state invalid enable
set firewall name WAN_LOCAL default-action drop
set firewall name WAN_LOCAL description 'WAN to router'
set firewall name WAN_LOCAL rule 10 action accept
set firewall name WAN_LOCAL rule 10 description 'Allow IPTV Multicast UDP'
set firewall name WAN_LOCAL rule 10 destination address 232.0.0.0/8
set firewall name WAN_LOCAL rule 10 log disable
set firewall name WAN_LOCAL rule 10 protocol udp
set firewall name WAN_LOCAL rule 10 state established enable
set firewall name WAN_LOCAL rule 10 state invalid disable
set firewall name WAN_LOCAL rule 10 state new enable
set firewall name WAN_LOCAL rule 10 state related enable
set firewall name WAN_LOCAL rule 20 action accept
set firewall name WAN_LOCAL rule 20 description Teste
set firewall name WAN_LOCAL rule 20 destination address 255.255.255.255
set firewall name WAN_LOCAL rule 20 log disable
set firewall name WAN_LOCAL rule 20 protocol all
set firewall name WAN_LOCAL rule 30 action accept
set firewall name WAN_LOCAL rule 30 description Teste2
set firewall name WAN_LOCAL rule 30 destination address 224.0.0.1
set firewall name WAN_LOCAL rule 30 log disable
set firewall name WAN_LOCAL rule 30 protocol all
set firewall name WAN_LOCAL rule 40 action accept
set firewall name WAN_LOCAL rule 40 description 'Allow established/related'
set firewall name WAN_LOCAL rule 40 state established enable
set firewall name WAN_LOCAL rule 40 state related enable
set firewall name WAN_LOCAL rule 50 action drop
set firewall name WAN_LOCAL rule 50 description 'Drop invalid state'
set firewall name WAN_LOCAL rule 50 state invalid enable
set firewall receive-redirects disable
set firewall send-redirects enable
set firewall source-validation disable
set firewall syn-cookies enable
set interfaces ethernet eth0 description ONT
set interfaces ethernet eth0 duplex auto
set interfaces ethernet eth0 speed auto
set interfaces ethernet eth0 vif 12 address dhcp
set interfaces ethernet eth0 vif 12 description 'Internet MEO'
set interfaces ethernet eth0 vif 12 firewall in name WAN_IN
set interfaces ethernet eth0 vif 12 firewall local name WAN_LOCAL
set interfaces ethernet eth0 vif 12 mac 'XX:XX:XX:XX:XX:XX'
set interfaces ethernet eth1 description ROUTER_MEO
set interfaces ethernet eth1 duplex auto
set interfaces ethernet eth1 speed auto
set interfaces ethernet eth1 vif 12 address 192.168.11.254/24
set interfaces ethernet eth1 vif 12 description VIF12_ROUTER_MEO
set interfaces ethernet eth1 vif 12 mtu 1500
set interfaces ethernet eth2 address 192.168.10.254/24
set interfaces ethernet eth2 description IPTV
set interfaces ethernet eth2 duplex auto
set interfaces ethernet eth2 speed auto
set interfaces ethernet eth3 description Local
set interfaces ethernet eth3 duplex auto
set interfaces ethernet eth3 speed auto
set interfaces ethernet eth4 description Local
set interfaces ethernet eth4 duplex auto
set interfaces ethernet eth4 speed auto
set interfaces loopback lo
set interfaces switch switch0 address 10.0.1.254/23
set interfaces switch switch0 description Local
set interfaces switch switch0 mtu 1500
set interfaces switch switch0 switch-port interface eth3
set interfaces switch switch0 switch-port interface eth4
set interfaces switch switch0 switch-port vlan-aware disable
set protocols igmp-proxy interface eth0 role downstream
set protocols igmp-proxy interface eth0 threshold 1
set protocols igmp-proxy interface eth0.12 alt-subnet 0.0.0.0/0
set protocols igmp-proxy interface eth0.12 role upstream
set protocols igmp-proxy interface eth0.12 threshold 1
set protocols igmp-proxy interface eth2 alt-subnet 0.0.0.0/0
set protocols igmp-proxy interface eth2 role downstream
set protocols igmp-proxy interface eth2 threshold 1
set service dhcp-server disabled false
set service dhcp-server hostfile-update disable
set service dhcp-server shared-network-name DHCP_INT_MEO authoritative disable
set service dhcp-server shared-network-name DHCP_INT_MEO subnet 192.168.11.0/24 default-router 192.168.11.254
set service dhcp-server shared-network-name DHCP_INT_MEO subnet 192.168.11.0/24 dns-server 192.168.11.254
set service dhcp-server shared-network-name DHCP_INT_MEO subnet 192.168.11.0/24 lease 86400
set service dhcp-server shared-network-name DHCP_INT_MEO subnet 192.168.11.0/24 start 192.168.11.1 stop 192.168.11.100
set service dhcp-server shared-network-name REDE_MEO authoritative disable
set service dhcp-server shared-network-name REDE_MEO subnet 192.168.10.0/24 default-router 192.168.10.254
set service dhcp-server shared-network-name REDE_MEO subnet 192.168.10.0/24 dns-server 212.55.154.174
set service dhcp-server shared-network-name REDE_MEO subnet 192.168.10.0/24 dns-server 212.55.154.190
set service dhcp-server shared-network-name REDE_MEO subnet 192.168.10.0/24 lease 86400
set service dhcp-server shared-network-name REDE_MEO subnet 192.168.10.0/24 start 192.168.10.50 stop 192.168.10.200
set service dhcp-server shared-network-name LAN2 authoritative enable
set service dhcp-server shared-network-name LAN2 subnet 10.0.0.0/23 default-router 10.0.1.254
set service dhcp-server shared-network-name LAN2 subnet 10.0.0.0/23 dns-server 10.0.1.254
set service dhcp-server shared-network-name LAN2 subnet 10.0.0.0/23 lease 86400
set service dhcp-server shared-network-name LAN2 subnet 10.0.0.0/23 start 10.0.0.1 stop 10.0.1.220
set service dhcp-server static-arp disable
set service dhcp-server use-dnsmasq disable
set service dns forwarding cache-size 150
set service dns forwarding listen-on eth1
set service dns forwarding listen-on switch0
set service dns forwarding listen-on eth1.12
set service gui http-port 80
set service gui https-port 443
set service gui older-ciphers enable
set service nat rule 5010 description 'masquerade for WAN'
set service nat rule 5010 outbound-interface eth0.12
set service nat rule 5010 type masquerade
set service ssh port 22
set service ssh protocol-version v2
set service unms disable
set system host-name ubnt
set system ntp server 0.ubnt.pool.ntp.org
set system ntp server 1.ubnt.pool.ntp.org
set system ntp server 2.ubnt.pool.ntp.org
set system ntp server 3.ubnt.pool.ntp.org


Muito Obrigado pela tua partilha.
Funcionou bem comigo 5 estrelas.

depois de testar a tua configuração, customizei para a minha rede.
usei VLan aware
Minha config:

C/ Vlan Aware
VLAN1- internet/wifi
VLAN10 - IPTV Meo
VLAN15 - VPN

Edgerouter X

ETH0 > (VLAN 12)Porta WAN;
ETH1 > (VLAN 12)Porta LAN ligada ao router MEO na porta WAN
Vlan Aware
ETH2 > (VLAN 1) Wifi
ETH3 > (VLAN 1,10,15) Smart Switch GS105 > BOX meo (na Vlan10)
ETH4 > (VLAN 1,10,15) Smart Switch GS108 > etc

Mais um agradecimento a este thread que muito me ajudou.

se poder ajudar deixem aqui.

Cumps
keecy
 

OnTheNet

Mestre BOINC
Estava aqui a estrear-me no mundo meo com o edgerouter x que adquiri. Quase nada percebo de redes.mas sou bom no copy corta e cose paste

O router meo que me instalaram é o fgw.

Se configurar vlan12 não tenho NET nem acesso a nada,l mesmo com o fgw em bridge.
se colocar apenas acesso dchp sem VLAN os 12 e o fgw em bridge na porta 4 tenho acesso a net.

É defeito dos novos fgw que passam a porta bridge já com VLAN incluída por assim dizer?
 

josesilva10

Power Member
Estava aqui a estrear-me no mundo meo com o edgerouter x que adquiri. Quase nada percebo de redes.mas sou bom no copy corta e cose paste

O router meo que me instalaram é o fgw.

Se configurar vlan12 não tenho NET nem acesso a nada,l mesmo com o fgw em bridge.
se colocar apenas acesso dchp sem VLAN os 12 e o fgw em bridge na porta 4 tenho acesso a net.

É defeito dos novos fgw que passam a porta bridge já com VLAN incluída por assim dizer?
O modo bridge não tem VLAN nas portas LAN.
 

_bean_killer

Power Member
Boas.
Tenho o Meo fibergateway em modo bridge com um router wireless Asus RT-AC88U.
O wifi está desligado no Meo fibergateway a box está ligada no router da Asus.
Até ao momento está tudo ok e a funcionar sem problemas.
Mudei de casa e necessito de ligar mais dispositivos, pelo que irei adquirir o switch unifi USW-24POE e 1 ou 2 AP's para ligar ao switch e espalhar wifi pela casa.
Gostaria de saber o seguinte:
1 - é possível anular o fibergateway e ligar a fibra diretamente a algum outro gateway da unifi, conseguindo igualmente ter net e serviço de televisão por RF e pela box, pois tenho mais que uma TV e só numa tenho a box.
2 - se tal não for possível, o que recomendam para ligar entre o fibergateway e o switch, de modo que consiga ter a meo box a funcionar apartir de um dos AP's que está ligado depois do switch?
 

s0ldier

Power Member
1 - é possível anular o fibergateway e ligar a fibra diretamente a algum outro gateway da unifi, conseguindo igualmente ter net e serviço de televisão por RF e pela box, pois tenho mais que uma TV e só numa tenho a box.
Não consegues anular o FGW, pois ele é que faz a conversão da fibra no ONT integrado. Ligas a porta 4 em bridge como tu tens atualmente e ligas na WAN da gateway Ubiquiti.
2 - se tal não for possível, o que recomendam para ligar entre o fibergateway e o switch, de modo que consiga ter a meo box a funcionar apartir de um dos AP's que está ligado depois do switch?
O que podes fazer é ligar tudo como disse acima, ligar a porta 1,2,3 do FGW a uma porta do switch, crias uma vlan "MEO" e onde precisares de ligar a BOX configuras essa VLAN no switch. Os APs não precisam de difundir essa rede para a box funcionar, a não ser que tenhas a Box WiFi, nesse caso não te posso ajudar porque não tenho essa box. Tive uma situação parecida, mas no switch só existia a rede da MEO para WiFi pelo que não havia necessidade de grandes alterações e a box estava a funcionar.
 

tr3s

Power Member
Estive a ver os routers ubiquiti edgerouter x para gerir a minha rede meo, estou cansado do FGW, má gestão de dispositivos e dns bloqueados à meo.
Será que esse router serve para o que necessito? A minha box é uma mi box, rede wifi uso os devolo powerline e em termos de funcionalidades apenas quero colocar alguns aparelhos com ip fixo, conseguir fazer um controlo parental e ter visível e bem organizados os dispositivos ligados ou que já tiver ligados ao router.
 

tr3s

Power Member
Instalei hoje um edgerouter x, e notei que fazendo um speedtest ao mesmo servidor, no er x tenho menos velocidade do que ligado directamente ao router meo, uma diferença de 400 no er x e 900 no fgw.
Li em algum lado que podia ser o qos, mas eu não tenho nada configurado para ter o qos a trabalhar.

Fiz o teste ligado por cabo ao fgw e depois à porta eth1 do erx com o fgw em bridge ligado ao er x.
Que pode ser? Solução?
 

Qaz.xc

Power Member
Meu edgerouter com openwrt deixou de funcionar o IPTV como funcionava... do nada, desta vez reflashar não resultou, já tentei mudar mac address da WAN mas nada.... alguém têm solução?

Uma solução que funciona sempre é dar rewind tipo 15s (2x 7s) para trás cada vez que se muda de canal, aí funciona sempre, FYI...
 

Qaz.xc

Power Member
Btw, o meu erro acima foi a regra do IGMP na firewall estar ativa com IPV4-only , o que provavelmente a MEO agora faz multicast em ipv6 e estava a bloquear indevidamente.

Desativado a regra ou liberando para ipv4 e ipv6 fica OK, grrr, tantos dias com este problema...
 

macacao

Power Member
Boa noite malta,

Recentemente adquiri uma Unifi Dream Machine Pro (UDM), e desde então tenho andado aqui à batatada para conseguir ter IPTV a funcionar com a box ligada à UDM, que por sua vez está ligada (WAN) ao FGW da meo na porta 4 (bridge).

O kernel de origem da UDM não suporta routing multicast, necessário para o cenário IPTV. Após alguma pesquisa, encontrei uma maneira de instalar um custom kernel que possibilita a utilização do igmpproxy.
Estando a UDM a correr o "novo" kernel e com o igmpproxy instalado, estas são as configs que estou a utilizar de momento:

/etc/igmpproxy.conf
Código:
quickleave

phyint eth8 upstream  ratelimit 0  threshold 1
    altnet 192.168.0.0/16 #LAN
    altnet 10.0.0.0/8 #

phyint br0 downstream  ratelimit 0  threshold 1
Nota: eth8 na UDM é a WAN. br0 é a interface para a minha LAN.


Regras de firewall:
WAN IN:
action accept
destination address 232.0.0.0/8
protocol UDP
state established enable
state invalid disable
state new enable
state related enable

WAN LOCAL:
action accept
destination address 224.0.0.1
protocol IGMP

Não esquecer também ativar o IGMP Snooping na LAN correspondente.

Acredito que estas regras também possam ser aplicadas na USG quando ligada ao FGW em modo bridge.

Consegui chegar a estes valores após muitaaaaa tentativa e erro, outras configs que estão aqui no topic, noutros forums, análise de logs, etc. No entanto, acredito que possam existir alguns tweaks para melhorar esta config.

Cumps
 
Última edição:

s0ldier

Power Member
Obrigado macacao, estou a pensar comprar uma UDMP para gerir a rede da minha casa e dos meus sogros (casas lado a lado) e o objetivo era controlar tudo só através da UDMP.

Não era possível e mais fácil criares uma VLAN "MEO" que ligasse a qualquer outra porta do FGW e que servisse só para o IPTV? Era a minha ideia para não andar a martelar coisas na DM.


Com custom kernel, como ficam os updates?
 

badanas

Power Member
Obrigado macacao, estou a pensar comprar uma UDMP para gerir a rede da minha casa e dos meus sogros (casas lado a lado) e o objetivo era controlar tudo só através da UDMP.

Não era possível e mais fácil criares uma VLAN "MEO" que ligasse a qualquer outra porta do FGW e que servisse só para o IPTV? Era a minha ideia para não andar a martelar coisas na DM.


Com custom kernel, como ficam os updates?

Até podes ter um Switch Managed no meio onde usas uma porta com a vlan IPTV e igmpsnooping activado e outra porta para ligares a udm
 

macacao

Power Member
Obrigado macacao, estou a pensar comprar uma UDMP para gerir a rede da minha casa e dos meus sogros (casas lado a lado) e o objetivo era controlar tudo só através da UDMP.

Não era possível e mais fácil criares uma VLAN "MEO" que ligasse a qualquer outra porta do FGW e que servisse só para o IPTV? Era a minha ideia para não andar a martelar coisas na DM.


Com custom kernel, como ficam os updates?
Sim esse cenário também deverá funcionar. Eu neste momento, por questões logísticas da casa, apenas consigo puxar um cabo do FGW para a UDM, daí ter investido nesta alternativa. No entanto, no futuro poderei optar por essa via.

Relativamente aos updates da UDM, para manter as coisas a funcionar, teremos que esperar pelo update do kernel antes de fazer o update na UDM.

Cumps
 
Topo