1. Este site usa cookies. Ao continuar a usar este site está a concordar com o nosso uso de cookies. Saber Mais.

Versão do squid não é suportada pelo webmin

Discussão em 'Dúvidas e Suporte Técnico - GNU/Linux & *nix' iniciada por jbrasil, 20 de Agosto de 2007. (Respostas: 2; Visualizações: 830)

  1. jbrasil

    jbrasil Power Member

    Colegas,
    Instalei o Mandriva Linux release 2007.0 (Official) for i586.
    Instalei o squid + webmin, via urpmi.
    Porém, ao acessar o squid pelo webmin, ocorre a mensagem abaixo:

    --------------------------------------------------------------------------------
    A versão do Squid não é suportada pelo Webmin. Apenas as versões 1.1 a 2.5 são suportadas por esse módulo.
    O comando squid -v retornou :
    Squid Cache: Version 2.6.STABLE1

    configure options: '--build=i586-mandriva-linux-gnu' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/sbin' '--sbindir=/usr/sbin' '--sysconfdir=/etc/squid' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib' '--libexecdir=/usr/lib/squid' '--localstatedir=/var' '--sharedstatedir=/usr/com' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--x-includes=/usr/include' '--x-libraries=/usr/lib' '--enable-icap-support' '--with-maxfd=1024' '--disable-poll' '--enable-epoll' '--enable-snmp' '--enable-useragent-log' '--enable-referer-log' '--enable-removal-policies=heap,lru' '--enable-storeio=aufs,coss,diskd,ufs,null' '--enable-cachemgr-hostname=localhost' '--enable-truncate' '--enable-underscores' '--enable-carp' '--enable-async-io' '--enable-htcp' '--enable-icmp' '--enable-delay-pools' '--enable-linux-netfilter' '--enable-default-hostsfile=/etc/hosts' '--enable-ssl' '--with-openssl=/usr' '--enable-arp-acl' '--enable-wccp' '--enable-wccpv2' '--enable-auth=basic,digest,ntlm,negotiate' '--enable-basic-auth-helpers=getpwnam,LDAP,MSNT,multi-domain-NTLM,NCSA,PAM,SASL,SMB,YP' '--enable-ntlm-auth-helpers=fakeauth,no_check,SMB' '--enable-digest-auth-helpers=ldap,password' '--enable-external-acl-helpers=ip_user,ldap_group,session,unix_group,wbinfo_group' '--enable-follow-x-forwarded-for' '--with-pthreads' '--disable-dependency-tracking' '--disable-ident-lookups' '--enable-large-cache-files' '--with-large-files' '--with-build-environment=default' 'CFLAGS=-O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fomit-frame-pointer -march=i586 -mtune=pentiumpro -fasynchronous-unwind-tables -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64' 'CPPFLAGS=-I/usr/include/openssl ' 'build_alias=i586-mandriva-linux-gnu'

    --------------------------------------------------------------------------------
    Já atualizei os pacotes do squid/webmin, via mcc (console de gerenciamento), e não resolveu.
    Não estava querendo, remover os pacotes do squid/webmin, e instalar de forma compilada.
    Estive pequisando, sobre o paramêtro rebuild do rpm.
    rpm --rebuild
    E também, o rpmbuild --rebuild
    Porém, ainda não tenho idéia de como vou fazer downgrade da versão do squid de 2.6 para 2.5.
    Alguém, pode me dar algumas dicas ?
    Obrigado.
    José Roberto.


    [[email protected] etc]# rpm -qi squid
    Name : squid Relocations: (not relocatable)
    Version : 2.6.STABLE1 Vendor: Mandriva
    Release : 4.3mdv2007.0 Build Date: Qua 21 Mar 2007 16:45:04 BRT
    Install Date: Seg 20 Ago 2007 18:39:51 BRT Build Host: mercury.mandriva.com
    Group : System/Servers Source RPM: squid-2.6.STABLE1-4.3mdv2007.0.src.rpm
    Size : 3915573 License: GPL
    Signature : DSA/SHA1, Qua 21 Mar 2007 16:56:05 BRT, Key ID 9aa8d0d022458a98

    [[email protected] etc]# rpm -qi webmin
    Name : webmin Relocations: (not relocatable)
    Version : 1.290 Vendor: Mandriva
    Release : 4.4mdv2007.0 Build Date: Sex 22 Jun 2007 14:37:12 BRT
    Install Date: Seg 20 Ago 2007 18:00:36 BRT Build Host: mercury.mandriva.com
    Group : System/Configuration/Other Source RPM: webmin-1.290-4.4mdv2007.0.src.rpm
    Size : 37159640 License: BSD
    Signature : DSA/SHA1, Sex 22 Jun 2007 14:46:20 BRT, Key ID 9aa8d0d022458a98
     
  2. droidman

    droidman Power Member

    parece-me que estamos com o mesmo problema...
     
  3. JotaM33

    JotaM33 Power Member

    O webmin já vai na 1.410 e desde a 1.300 que já suporta o squid 2.6.

    Experimenta actualizar o webmin pela opção de «Upgrade Webmin» dentro do «Webmin Configuration»
     

Partilhar esta Página